Tablo Ripper - Automatically download new recordings


#1296

Your settings.xml file is located here: C:\ProgramData\TabloRipper

Have you looked at your log file to see what’s actually going on? What’s the error message look like?


#1297

Hello CycleJ,

thank you for your fast response. The logfile basicly just shows that FFMPEG timed out. I tried several recordings and all ended with the same error. Exporting them while being on site works though.

Log:

29.09.2018 21:50:47 SyncTabloRecordings_Selected
29.09.2018 21:50:47 InitTotalCount
29.09.2018 21:50:47 Total item count = 1
29.09.2018 21:50:47 SyncTabloRecordings
29.09.2018 21:50:47 recList.Length=57
29.09.2018 21:50:47 newCompletedList.recIdList.Length=0
29.09.2018 21:50:47 RemuxRecording
29.09.2018 21:50:47 FFMPEG    : C:\Program Files\TabloRipper\ffmpeg.exe
29.09.2018 21:50:47 TempOutput: D:\Video\tmp\Foreground_rip.mp4
29.09.2018 21:50:47 Output    : D:\Video\The Flash\Season 04\The Flash - s04e22 - Think Fast.mp4
29.09.2018 21:50:47 InvokeApi
29.09.2018 21:50:47 JSON: {"token":"c33302e2-5813-4d8f-8bdd-b4649178adc6","expires":"2018-09-30T19:50:47Z","playlist_url":"http:\/\/10.19.1.112:80\/stream\/pl.m3u8?yqVv3Vvrj_7sIPeBG1KpsQ","bif_url_sd":"http:\/\/10.19.1.112:80\/stream\/bif?yqVv3Vvrj_7sIPeBG1KpsQ","bif_url_hd":"http:\/\/10.19.1.112:80\/stream\/bif?yqVv3Vvrj_7sIPeBG1KpsQ&hd","video_details":{"width":1280,"height":720}}
29.09.2018 21:50:47 Options: -y -i http://10.19.1.112:80/stream/pl.m3u8?yqVv3Vvrj_7sIPeBG1KpsQ -codec copy -strict -2 -c:a aac -threads 0 -metadata title="The Flash" -metadata description="Think Fast" -metadata synopsis="DeVoe assaults an A.R.G.U.S. facility to complete his Enlightenment Machine; Barry realizes the only way to stop DeVoe is to allow his friends to help; Barry is reluctant to risk his friends' lives and considers taking on DeVoe solo." -metadata date="2018-09-26 02:00:00" "D:\Video\tmp\Foreground_rip.mp4"
29.09.2018 21:50:47 Running as user: "C:\Program Files\TabloRipper\ffmpeg.exe" -y -i http://10.19.1.112:80/stream/pl.m3u8?yqVv3Vvrj_7sIPeBG1KpsQ -codec copy -strict -2 -c:a aac -threads 0 -metadata title="The Flash" -metadata description="Think Fast" -metadata synopsis="DeVoe assaults an A.R.G.U.S. facility to complete his Enlightenment Machine; Barry realizes the only way to stop DeVoe is to allow his friends to help; Barry is reluctant to risk his friends' lives and considers taking on DeVoe solo." -metadata date="2018-09-26 02:00:00" "D:\Video\tmp\Foreground_rip.mp4" in C:\Program Files\TabloRipper\
29.09.2018 21:59:41 Aborted: FFMPEG timed out!

Also I really do not have a settings.xml file. I reinstalled TR on my wife’s computer and she also does not have the file. My command prompt shows me the following (it’s the german version of Windows 10):
C:\Program Files\TabloRipper>dir
Volume in Laufwerk C: hat keine Bezeichnung. // I have not named my drive so there is no label to it
Volumeseriennummer: XXXX-XXXX // I blanked out the volume ID

Verzeichnis von C:\Program Files\TabloRipper

30.09.2018 19:56 .
30.09.2018 19:56 …
12.01.2018 11:43 83.968 Common.dll
22.01.2017 20:00 40.222.720 ffmpeg.exe
12.01.2018 11:43 1.175.040 TabloRipper.exe
18.07.2015 11:54 187 TabloRipper.exe.config
12.01.2018 11:43 8.192 TabloRipperService.exe
23.07.2015 10:45 187 TabloRipperService.exe.config
6 Datei(en), 41.490.294 Bytes
2 Verzeichnis(se), 51.965.317.120 Bytes frei

I hope this helps to better describe my problem to you.

Regards


#1298

You’re looking in “Program Files”, not “ProgramData” - the latter is normally hidden, but you can access it using the File Explorer.


#1299

Any new updates regarding Tablo Ripper for Mac at all?


#1300

Have you looked here?


#1301

Hello CycleJ,

I finally got around checking and I have to admit you were absolutely right. I found the settings.xml and did fiddle a little with it. However it turned out that the connection to the tablo stops at some point which in turn freezes FFMPEG… This also happens when streaming with VLC. Local usage shows none of the symptoms so my guess is that this is actually a network problem (or at least network stack related since multiple applications are suffering from the same issue).
Thanks again for your patience and help.

Regards


#1302

I’m always happy to help. Sometimes a hint is all it takes to help someone get “unstuck”.


#1303

Great program! I have one feature recommendation.
Do not use the output folder for the tmp folder. Or make it user selectable where to put it.
When it is put in the output folder, the library adds it to the list of shows.


#1304

Thanks for the kind words. I’ve stopped development on this project but will continue supporting it for the foreseeable future.


#1305

I enjoy using it so be sure to come back with the Tablo ATSC 3.0 version in the future…:grinning:


#1306

I suggest you use a folder just for Tablo Ripper and then once Tablo Ripper is done running, move the recordings to another folder. FYI, there are ways to automate that.

Yes, thank you CycleJ!


#1307

I am sort of doing that now. I use a program called ‘Remove Old Files’ to delete the empty folders (ie.tmp) in the library every 1 minute. There could be a timing issue if you automated coping the files. I ran into that and cutoff half a show.

The best solution, if development was still being done, would be for Tablo Ripper to allow you to select the location of the tmp folder like they do the Output folder or just change it to use the program data folder or the TabloRipper folder.


#1308

Great work. Please allow window to maximize.


#1310

Good Morning. Does the Tablo Ripper pass surround sound?

Bill


#1311

I haven’t tried it, but see no reason it wouldn’t. Has anyone else tried it yet?


#1312

I rip to Plex.


#1313

When 5.1 SS was first implemented I used Tablo Ripper to rip a few shows I had recorded with 5.1 turned on. My ripped files came out in standard stereo, but I’m not sure if the programs I recorded actually had 5.1 or not. After that first trial, I turned 5.1 off and haven’t tried it again. I still use Tablo Ripper every day, but all recordings are in stereo.


#1314

I am now using two tablos. Both tablos show up in Tablo Ripper by selecting them from the dropdown. However, recordings only appear to be getting ripped from the original tablo, and not the new one. They both have up to date Tablo versions. Is there anything special to do to have the shows in my settings get pulled from either Tablo?


#1315

Multi-Tablo support isn’t great, but it should work. When you change your selection you’ll need to exit the GUI to write your “current” selection to the settings file. That’s used by the background task to rip new recordings. Yes, that’s awkward, but there were a few people (long ago) that helped me get that much working.