Tablo Ripper - Automatically download new recordings


#1

TabloRipper is a Windows program that rips Tablo recordings to your PC.

Use the GUI to manually select recordings, or use the background service to automatically rip new recordings. Please click the download link (below) for more information.

Don’t bother to read all the posts in this topic (unless you have too much time on your hands and really want to).

Do if you have a question or suggestion, post it here because I’ll get a notification and will try to respond.

Download the latest version here: GitHub

Important Note:

Starting with Tablo Version 2.2.11 beta 5, your old version of TabloRipper (1.x.x) will stop working. No worries, just download the latest version (all 2.x.x versions will continue working) and you’re good to go.


Can I pull recorded video files off Tablo?
Tablo ripper with auto upload to a plex account?
Wait for ATV Tablo app or goto TiVo Roamio w/Lifetime subscription
Archiving Shows
Can't install Tablo Ripper
Tablo Exporter and Tablo Ripper
How to extract files from your Tablo
TabloRipper - Automatically limit the number of recordings (AutoDelete)
Tablo not working on Windows 7 PC
New ex-SimpleTV user - where do I start?
Cloud Backup/File Migration for Hardware changes
How to extract files from your Tablo
#2

Hey, i am new to tablo and brand new to this forum only because i saw your app and want to play. Just tried your creation and now have a big folder of extracted files that all play fine. If this is your alpha version for comments then count me in as a supporter, available for testing help if you need it. Keep it going pls!


#4

After I install the program, install FFMPEG, what are the next steps? I set the Path to FFMPEG just the root folder ffmpeg-2.7.2/, is that correct? Then I installed the service, then hit “start service”. Should I hit “start” instead? Is there any progress bar to know if it is working?

I’m really excited to use this, thanks for putting this together!

Edit: I tried backing out, then hitting “start” instead. It says “Exception: URI formats are not supported.” How should I proceed?

Edit 2: Got everything up and running, seems to be working great! I’m still trying to figure out if there is a faster way to rip the movies from Tablo, then strip commercials, then upload to Plex.


#5

The “Release Notes.txt” file in the download directory lists current limitations by version - the major one being that the service option is currently incomplete. I’m working on it!

That means you need to use the GUI for not only configuration, but ripping. At least for now. Once the service is functional you’ll be able to rip manually through the GUI, or let the service rip new recordings automatically in the background.

You are correct, you merely need to point the ffmpeg folder setting to the subdirectory containing ffmpeg.exe. If the application can’t locate ffmpeg.exe using the configured path, you’ll get an error message in the output log window when you hit Start.

The non-supported URI message means that the application can’t locate your Tablo. I’ll work on a better message for that particular case. Did you get a list of Tablos in the top combobox? Try hitting the Refresh button? Nothing’s going to work until the application sees your Tablo.

Worst case, enable Verbose logging and post the output. I’ll take a look at it.

Thanks for your feedback!

PS - Please try today’s version. I’ve added a bit of logic to select the first tablo in the list automatically if none has been selected previously.


#6

Thank you for this program! Worked as described without any hassle. I already had mcebuddy and plex setup from my WMC days and this software put the files into my ToBeConverted directory, mcebuddy picked them up and converted them, dropping them into my Plex library where I could play them fine - no new configurations necessary. Now I can sync to my tablet for offline viewing.

Thanks so much!


#7

Hello, i just uninstalled the first version you released and tried to install the latest version (27) in .msi form and it will not install; cant find any of its own files offering up an error 1309 “Error reading from file:…”. Is the .msi not ready for distro yet or does it need care and feeding unlike the older .exe?

UPDATE: Just tried ver 27 in .exe form and that installs and runs fine. Ppl need to check the Release Notes to try and keep up with. Dont know why .MSI does not work but all is fine with .EXE now.


#8

You’re so right. I had a good build and a bad build this morning. Guess which one I uploaded?

The good news is that you get tomorrow’s build today.

The bad news (read the “Release Notes” for details) is that I had to relocate the configuration files to a different directory so the background service has permission to read them.

If you don’t want to start over from scratch, the Release Notes describe how to move the old files to the new location. But if you don’t mind starting over, you don’t need to copy them. Just reconfigure your settings, and everything will download again.

PS - The background service is in the very early stages of testing. Tread lightly if you do experiment with it.


#12

Decided to give it a shot… I didn’t necessarily want all videos stored on my Tablo, so I stopped it after one was downloaded. It’s in standard mp4 format and played well, with very high quality. Running it through MCEbuddy now to see how well it works at removing commercials. I realize that this is in the early stage of development, but just wanted to say how impressed I am with what you have. It’s nice to be able to pull video off my Tablo so that I can use it any way I choose, such as burning to DVD. Well done, and thanks!


#15

Tried and true! It installs and runs fine now as an EXE install. thanks for the quick attention.


#19

I love the new UI and filter options. It would be nice to have checkboxes to choose which programs to download in the future!

I am setting up a workflow with the MCE Buddy (thanks for the recommendation, it’s a fantastic program). I wish the process was slightly faster, but these 1080p files are large, and I’m sure there’s nothing you could do. A movie is taking about 45 minutes- 1 hour to complete at this point for me.


#20

You read my mind. Once I get version 1.0 ready for primetime, my to-do list includes ‘manual selections’ and an option to pass your own settings to FFMPEG.

If you’re using Comskip within MCEBuddy, there is a ‘donate’ version that runs much faster. You might want to check it out. But yes, my notebook takes about the same amount of time as your PC. Another user has a smokin’ desktop PC that gets the same job done 5x faster!


#21

Do you know if the donate version has the option to run comskip by itself? Didn’t see that option in the free version, and it didn’t seem to make sense to have to convert from a video file already in the desired mp4 format. I’d like to be able to forgo format conversion and just remove commercials.


#22

Yes I bought the donate version. The process goes very quickly until the “second pass” comskip step which takes about 2 hours itself! I’m using the newest beta. Do you experience the same thing?


#23

I’m new to all of this (well, not programming, I’ve been doing that quite a while). But I’m neither a MCEBuddy or Comskip expert. Let me refer you to their website http://www.kaashoek.com/comskip/. There seem to be tools + options to do just about anything - except rip Tablo files automagically. And that’s why I created “step 1” in the process.


#24

Really want to try this, but don’t know where ffmpeg is or how to locate it. The program doesn’t show up inC:\ Program Files or C:\Program Files(x86), nor does the windows command window find it on a search. Soooo, where for art thou, ffmpeg?


#25

Never mind; figured out I have to install it separately. It turns out I had it for the previous ripper program.


#26

For reference, here’s my output log file from MCEBuddy for six 1-hour shows and one 30-minute show.

YMMV


#27

Try clicking the TabloRipper “Readme” link yet? :smile:

But to answer your question directly, FFMPEG is a free program that you need to download and install. TabloRipper depends on FFMPEG to do the heavy lifting.

Here’s the link:
https://www.ffmpeg.org/download.html

Edit: I’ve included the current version of ffmpeg.exe in the download folder.


#28

Just tried your latest update. Love the new Selection Filters option. Does just what I wanted. If you never did another update, I now have the capability I can really use, to download specific shows and use them as I please. However, your software has a LOT of potential… for example, interrogate the Tablo and come up with a list of recorded content, which would allow for easy selection of single or multiple shows for download. I suspect that you already have this in mind. Also, it would be nice to have built in capability to delete commercials. That way you could avoid having to install another program to do this. Maybe integrate Comskip into your software?


#29

Got it running, seems to be all installed. Set the utility to run from midnight to midnight and clicked Start. Been over an hour, no error (or any other) messages, but nothing in the Out bucket. I must be missing something.