Tablo for Plex - Now available in the Plex Channel Store


#1

The plex plugin is now in the channel store, making it very easy to extend your Tablo to all your devices whether it is via DLNA (WD Live, PS3, XBOX, etc) or a native Plex application on your FireTV, iPhone , Samsung TV just to name a few. 


Installation is easy: 

  1. Make sure your Tablo is running the latest firmware
  2. To get started install Plex from https://plex.tv on your PC, Mac, or NAS such as a Synology.
  3. Next open the web interface and Choose Channels
  4. Now click the Install Channels button 
  5. Click What’s New and Select Tablo
  6. Click Install
Please keep in mind that this is NOT Supported by the folks at Tablo but you are welcome to post here and @PIX64 and myself @Davidvr will try to help resolve any issues you may have.

Betas:
Development Beta’s are available @ https://github.com/davidjvr/TabloTV-Plex-Channel/wiki
Please do not post issues with beta’s here, instead PM @PIX64 and @Davidvr or create a issue on github

More Information:
Our original post is available at http://community.tablotv.com/discussion/230/introducing-plex-channel-for-tablotv/p1 with a bit more information about how we got this plugin started. 

Tablo via Plex video:
https://vimeo.com/102383634

Tablo Plex Channel - Tablo Connect?
Firmware 2.2.2 drives "Loading, Please Wait"
#2
Also a big thanks to everyone who helped us test the plugin!

#3

Just curious, since i’m a STB whore, anyone get this working on Fire?  How about WD TV Live?


P.S.  Nice job on the channel guys!

#4

@Davidvr I’m seeing listed TV Shows, but no movies. I just noticed the other day,


#5

Back at it after a much needed vacation with the Family!


sorry for my lack of responses or involvement over the past week and a half.

#6

Not sure where I’m supposed to post–let me know if I’m in the wrong place.


Cannot install Tablo channel.  Spins and spins.  Cancel it, go back, and it says it’s installed if I try to install again, but it doens’t show as an installed channel.  Looked at the locations on the server and there are files Tablo.bundle and others–I’ve wiped all Tablo everything in Plex folders and re-started, same thing.  

#7

@django363 have you restarted plex after installing the channel? 


#8

The channel doesn’t install…it just spins and spins.  After many minutes, I’ve checked and the folders are there, and yes I’ve res-started PlexServer and no different.  I go back in, select Install again and it shows it as installed (check mark) but doesn’t appear in installed channels.  Not sure, I have no problems installing any other channels. 


I DID manually install the very first beta release (as soon as it was published) and was able to see it (but gave me errors for live TV and recorded TV when playing).  So I wanted to try the published version.

I’ve wiped everything associated with Tablo, re-started PlexServer, same thing.

Very odd.  Not sure if something is cached or registered somewhere I’m not aware of that is causing a problem.



#9

@Davidvr - I have a ZIp with the logs from Tablo install on the Plex server after he failed install, not sure how to attach, don’t see an option.


C:\Users\XXXXX\AppData\Local\Plex Media Server\Logs\PMS Plugin Logs\Tablo



#10

This is a great addition! But I would love to have Tablo recordings be categorized alongside my other Plex movies and TV shows stored on my server, instead of having to access it through the app. 


#11

@Davidvr sent you an iMessage, seeing some other issues


#12

I just wanted to take a second and say thanks to @DavidVR, @TabloSupport for picking up the slack in my absence.  I have had some very serious family member surgery/recorvery, etc.  While things aren’t 100% back to normal at this point I am at least at a point where I can start working on things again and fielding questions/comments/support requests.


Sorry all for my absence.  Happy Friday!

#13

No need to apologize @PiX64


Family is always more important. Everyone at HQ sends positive vibes to you & yours. 

#14

Hi, 

I have been able to get a few recorded shows to play, but no live.  Now I am consistently getting the message 

"Cannot load M3U8: crossdomain access denied"

Any ideas?

Thanks!

Bob 

#15

@bromo999 You using a browser remotely?


#16

@Jestep,

Yes, sorry I should have been more detailed.   I was on my work PC using Plex web app in a Chrome browser.   I haven’t had a lot of time yet to try stuff,  like re-installing, etc.  I just thought maybe the error message might point to an obvious thing. ( I have no issue when I’m on my home wifi.) 

I did restart the Plex server once by rebooting my home system, but it seemed not to make a diff.

Bob


#17

@bromo999 Go into the settings for the web click and turn off direct play and direct stream and see if that helps


#18

It does point to a crossdomain.xml file that Flash usually downloads and that appears to be set to not allow crossdomain viewing. I saw some posts about this and not sure it can be fixed via the channel, maybe @Davidvr can answer? 


Try this http://localhost:32400/crossdomain.xml on your plex server replace local host with whatever it is and you will see that:

<site-control permitted-cross-domain-policies=“all/>
<allow-access-from domain="" secure=“false/>
<allow-http-request-headers-from domain="" headers=“SOAPAction,Content-Type/>


I believe this is the issue: <allow-access-from domain="*" secure=“false/>

Mine works remotely, so not sure what the issue is with yours

But you may need to disable the crossdomain check in Chrome.
http://opensourcehacker.com/2010/11/29/disabling-cross-domain-security-check-for-ajax-development-in-google-chrome/



#19

Guys, maybe total pilot error on my part, just realized I’m a release behind on my plex server, updating now will let you know, so sorry for the possible wild goose.


#20

@PiX64 No worries! No need to apologize, that’s what we’re here for. Hope all is well!