NEW - Tablo Windows 10/Xbox App Update (v.1.9.9)

I use Linux Mint 20.2 on a dual boot Windows 10 machine and can use Tablo with Firefox using either. Agree with djk44883,very likely some Firefox extension setting is giving you problems.

1 Like

Humm, my laptop with running Debian works mostly fine. Some problems with CC being in different order.
Looks like I have to dig into settings.

My desktop, where I’m having issues, is my main system for banking and online ordering and such. Spent a lot of time securing the browser.

On my laptop I can connect with
My desktop converts this to

Wonder if it’s that Secure http:
Tips on firefox website as to how to selectively turn that off are not working.

This is very unlikely the issue. Whether or not you start HTTPS, the local connection - the steaming from tablo to your browser is not either way. That’s part of the new issue with Chrome.


Under Privacy and Security you have an option to NOT have Firefox add it… while virtually most all web sites now will redirect you. I turned it off, makes it easier to access my router by name for one. There may still be a site or two without an SSL certificate which I still need/want to visit. I suppose I could/should add an exception.

If you really want to dig into things… about:profiles and restart with Add-Ons Disabled OR Help > Troubleshoot Mode (this used to be called safe mode)

How different are you Firefox configurations between devices? Least ideal choice, copy your working profile to your other systems (although I’ve done this, it’s not something to recommend). Firefox has a sync facility (me, I’ve signed in, sync’d and signed out) It’s a bit easier have different systems set up very similar.

Yea, I have a Windows 10 PC which I have little to no use for but it’s nice to have the same Firefox setup if/when I do use it.

Is there a difference how either of these systems connect to your network?
“securing the browser” ?? in what ways was it insecure? Had you secured anything on the network level? (proxy, vpn)?

The page isn’t redirecting properly

Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

This problem can sometimes be caused by disabling or refusing to accept cookies.

…you gave little clue what specific trouble shooting steps are in progress here :thinking:

Other steps may also include… from the menu choose disconnect
When you see a screen similar to this…

click on the “x” A message will pop up (read it, click ok)
Then go all out and click on the not secure logo (or maybe you have a secure logo) in front on the in the “megabar

a clear cookies and site data… Yea, this may be over-board, but trying to get a complete fresh start. Then ctrl-F5 to re-retrieve the page (not cached data).

Troubleshooting/Save Mode - all add-on disabled

Connected to

Tried disabling HTTPS-only Mode:

I can’t get in, not sure what’s up with your desktop. Did find this From TabloTV

you don’t get an option… since can’t connect it’s unlikely “the problem”.

There are still options and since it works on your other systems there’s a strong likelihood this too will get straightened out!

I have encountered that server redirect message before. I believe I had to change a setting in either DuckDuckGo Privacy Essentials (extension) or AdBlockPlus (extension).

1 Like

I hadn’t seen the message but I could see or tell the page was continuously reloading.

I use openSUSE (currently Leap 15.2, haven’t upgraded yet). I haven’t noticed too many problems with CC apart from CC problems in general (that which affects all platforms).

For Chromebooks (at least as of Version 91.0.4472.167), Firefox and the Android Tablo App both work. However Chromebooks do not support surround Sound.

However as of this article google was considering it. But that was May 2020 so still not yet.

I downloaded the Windows 10 app but I really need to add a shortcut to my desktop. The only options are add to taskbar or add to Start.

I tried to locate the application file on my hard drive to create a shortcut that way but can’t find it.

Any suggestions?

Drag it from your Start menu to the desktop. It will create a shortcut there.

1 Like

Can’t believe I didn’t think of that…THANK YOU

No problem! Glad I could help.

As infrequently as the web app is updated, and tablo runs lighttp it could be installed locally. I suppose “thing is” tablo uses as a pseudo-network discovery.

Users shouldn’t have to know networking to configure lease reservations to be able to access their devices, or otherwise know it’s IP/hostname. You somehow need to easily get to your tablo.

I tried to install the Windows 10 Tablo app on my PC which runs the French version of Windows 10. I used Microsoft Store to do that.
It displayed the name of my PC which I then selected and clicked on Install now. I then received the message We will attempt to install it on the equipment you selected. I typed OK. Nothing happened after that. When I look at the long list of apps of the WindowsApps display, I do not see anything that looks like Tablo. (What should I look for?
At the bottom of the Microsoft Store display for the Tablo App, I see English (United States) as the supported language. Must I conclude that it will not work on my system?

I was able to install the Windows 10 Tablo app on my French version of Windows 10.

There’s probably something else causing this.

the link tablo provides is for en-ca
so presumably it’s not limited to English US… but non-English, IDK

@TabloSupport I don’t want to create a Microsoft account just to use my Tablo. I don’t have Microsoft account for a reason. Will you provide an alternate download for the Tablo Windows app?

It would be great if we could just get a “recently recorded” link on other browsers like Firefox. I only used Chrome for that in the first place and probably wouldn’t miss Chrome support if we had that.

1 Like

On the Windows 10 I do have, it’s a local account, - no MSN or Microsoft account, for a reason, and I’m able to install the tablo app from “the store” with out any hassle.

But then I rarely use my Windows system, well I don’t actually use it for anything actually productive, but it always want’s to update, massive amounts of data need downloaded.