NEW - Tablo Android Mobile App (4th Gen) Update (v. 1.0.4)

Hi folks -

An update is available for the newest Tablo Android Mobile app for 4th generation Tablo devices.

This update has several bug fixes so make sure to update to the latest.

Here’s what you can expect:

Tablo Android Mobile App (4th Gen) Update (v. 1.0.4)

  • Fix for resuming partially watched recordings
  • Fix for selecting playback of a live channel from the channel ID on the live TV grid
  • Fix to remove delay when selecting live TV playback
  • Improvements to Wi-Fi setup connection logic
  • Various bug fixes and performance improvements

As always, if you have any questions or encounter any problems, feel free to post them below or touch base directly with support.

1 Like

Does this mean that WiFi setup will work on a tablet running android 13. Or if it was setup using WiFi 2.4 you can use the app on an android 13 tablet and change SSID.

We’re not aware of any specific issues with tablets running Android 13. The ability to change Wi-Fi connections is coming soon.

It’s the very informative message failure - unknown error. The legacy setup can also have this. It happens when it goes to collect the SSID list. usually with legacy if you retry it enough times it eventually works. but not the gen 4.

And my asus router is old non-mesh and very simple. out of 26 WiFi devices they all collect SSIDs quickly and connect smoothly - except tablo

I had a similar issue with the Gen4, but was on two different FireSticks, a tablet Android app, and a phone android app.

I set up the Gen 4 the day I received using the phone app. All went well; did rescans about 4 times to get best antenna configuration. Finally settled on over 100 channels. Then I attached external drive’ Gen 4 recognized it correctly and formatted it. I installed apps on the tablet and on 2 Firesticks – all worked fine.

Next morning, I tried to access the Tablo but none of the 4 apps could find it. I checked the Gen 4 to find a solid blue LED, tried all the troubleshooting steps, never got a blinking or pulsing light. No device on my network could find the Tablo device. Even tried disconnecting everything and connecting by Ethernet; Network still could not see a Tablo device. Throughout all this, the LED remained solid blue.

Contacted Tablo tech support. Ultimately, they determined there must be an unknown defect in the device; they are shipping me a replacement Tablo Gen 4 and a shipping label to return the defective device for engineering analysis.

Does Chromecast now work?

Yep - NEW - Tablo Amazon Fire TV/Android TV App (4th Gen) Update (v. 1.0.4)

I’m surprised that your old router can handle 26 wifi devices. Almost all have a limitation on the number of devices/streams that they can handle at one time.

Just to experiment, I would disconnect some of the devices and try the gen 4 with the reduced load on the router.

1 Like

Does anyone else have stuttering watching live tv on this new Android mobile app? The screen freezes for half a second to a second, continues on for a less than a minute, and then it happens again.

Yes! Roku, my main platform, doesn’t have the problem. Android 8, 10 and 12 have theproblem

32 WiFi and 32 wired. And that seemed to be the most common limits a few years ago.

I’m having 2 serious issues with the 4th Gen Android phone app.

  1. Watching live TV has frequent glitches, such as audio cut outs, skipped frames, pixelation. Every 10-20 secs or so. Watching recordings later seems fine. During initial setup this lead me to think I was having issues with my antenna. I spent a long time repositioning it and trying a bigger more powerful antenna seemingly to no avail. I eventually tried it on my Fire TV stick, Chromecast with Google TV, and my wife’s iPhone. All worked fine which tells me it it a problem with the Android phone/tablet app. For reference I have a OnePlus 8T phone, but I also tried it on my Fire HD 10 tablet an had the same issues.

  2. I use a third party launcher on my phone called Nova Launcher. Having the 4th Gen tablo TV app installed causes my phone to constantly forget my default launcher an ask which one to use every time I hit the home button even if I tell it to remember the choice. Going into the Nova Launcher settings I got a notification that this is a known bug that some apps have an it specifically called out the Tablo app as causing the problem. Once I uninstalled the Tablo app the problem went away.

These 2 issues make the Android phone app absolutely unusable for me.

1 Like

@TabloSupport @TabloEngineering – Please take note

@Det64 I am having the same issue as your first one. I set up my Tablo Gen 4 using the Android app on a Galaxy Z Flip 5. Setup was no problem, except I made the mistake of connecting to a lower throughput 2.4 gHz wifi network instead of the more efficient 5 gHz network. When I tried out playback of either Live or Recorded shows, I had terrible stutter and freezing – 3-5 sec of video with 8-10 sec pause. I reconfigured my wifi nodes to get one close enough to the Tablo to connect via Ethernet and that went smoothly.

Now, playback on a Firestick or Fire Cube device is perfect, but on my android app I still get momentary video/audio stutter. Happens on both Live and Recorded shows. pauses are now only for half second or so, but happen 5-6 times per minute. Becomes very distracting and annoying.

So I agree, there seems to be a CODEC processing glitch in the Android app.


@Seeker336 Agreed, it sounds like the same issue to me. Especially what you are seeing now using ethernet.

Just to add more info, I have the Tablo gen 4 hardwired using ethernet and my phone is on my 5ghz WiFi.

@snowcat Yes I’m having the same issue. See my post above.

@snowcat Yes, I seem to have had the same experience as you describe on the Android app. See my post above. Note that I also referred that post to @TabloSupport and @TabloEngineering


Thanks. I am sure the developers are working on this issue.

We are investigating the first issue within the player now, and hope to have some news on this soon.

For the second issue, you mentioned the Tablo app was mentioned by the Launcher - can you share this screenshot/dialogue message with us if possible?

@TabloSupport I have tried several times but I can’t get Nova Launcher Settings to give me that message again. Might have been a one time thing. So I can’t get you a screenshot of the right now. I have attached a screenshot of the pop-up I get everytime I hit the home button.

For memory the messages was something like: “There is a common issue where some apps disrupt the default launcher. It is possible Tablo App is causing this issue.”

YES! That is exactly my problem with this version of the Android Tablo app