5.1 Surround sound roku error message problem


#1

After switching on the global surround sound on the tablo, my two roku 2s and my roku ultra were streaming audio to all 3 of my tvs. After the latest roku tablo channel 2.6.3 everything was still working great, shows were recording in 5.1 and playing fine, then yesterday I tried to watch live tv on one of the roku 2s and I get a warning message, "***“Your Roku is not connected to a device that supports Surround Sound. In order to receive audio you must disable Surround Sound in the Tablo Settings screen.”*** also I could not play recordings that were recorded in 5.1. So I checked the TV settings and yes surround sound was enabled, I checked the roku audio settings and yes the audio was on auto and whatever settings I changed on the tv or roku I still got the error message. So I disabled surround sound on the tablo. This AM I switched the 5.1 back on tablo just to check to see if it will work and sure enough its back to working. So obviously there seems to be a problem. I wonder if anyone else has seen this behavior as well?

For now I am disabling 5.1 until Tablo can work out the kinks, cause its frustrating recording a bunch of stuff that wont play back even though my hardware supports it. I just wanted to get this out there so it can get addressed, others should also report this behavior.


#2

Sorry to hear you’re having trouble with the Surround Sound settings on your Roku.

Is it possible that the recordings you were viewing previously were not created with 5.1 sound?

You will only be seeing those error messages if your Roku or what it’s connected to cannot process this sound profile.

You can read more about the warning messages and what they mean here: https://support.tablotv.com/hc/en-us/articles/360001241823-5-1-Surround-Sound-Error-Messages-on-Tablo-s-Roku-App


#3

No. The message was displayed with live TV as well with the global 5.1 on. Remember that according to the supported devices list, rokus support 5.1. Now, I could view programs recorded in stereo just fine, just not in 5.1, even though I could the day before and the day after.


#4

Yes - all current Roku devices have the capability to pass 5.1 Surround Sound through to your TV.

But your Roku MUST be connected to a device (aka a television) that supports 5.1 passthrough, and that the Roku must also have the correct passthrough settings (HOME > SETTINGS > AUDIO).


#5

Ok, so after 5 days, I can confirm that my TV is surround sound compatible, I have switched on the SS setting on the TV audiio. I can also confirm that I don’t get this error message every day, it is intermittent. When the message is not there I can watch a show that was recorded in 5.1, when the message is there it doesn’t give me the option. If audio were allowed I believe it would behave like the web app, it would play the video, with the web app if not 5.1 compatible it just has no audio, although that never happened on my tv cause it is compatible: however, it doesn’t give me that choice, it just doesn’t allow the video to be played. I’m sure now that the message is mistakenly blocking me from playing 5.1 video, I wish there were a way to manually turn off the error message.


#6

It’s not your TV, it’s your Roku. The Roku’s audio setting must support surround sound, or you will get that error message playing live tv. (unlike the web and phone apps that just won’t play sound, the Roku won’t play at all)

I did a test where I switched my Roku’s audio to “stereo”, and I received the message. I have seen in the past where a Roku strangely changes the setting on its own, though it hasn’t happened in a year or two.

If you encounter that message again, just check your Roku’s audio settings, and fix as necessary.


#7

Since I first posted, the error message has come and gone nearly on an every other day basis. It is true that if I switch the roku audio to stereo I will get the message, otherwise it is on auto or dolby d, and with that setting I DO NOT get the error message and the audio plays just fine. When I did get the error message I changed the roku audio settings to dolby d and it made no difference. I’m not sure why it’s displaying the message but if Tablo could allow you to try and play the video I’m sure the audio would play just fine. The problem is that the error message is preventing the playing of the video despite whether the hardware is compatible.


#8

That’s interesting, my new Roku Ultra did exactly the same thing two days ago after running fine for about 2 weeks. My two older Rokus (4200X I think) are still working fine and when I hooked my MiBox to the same setup, it works fine with surround sound.

Maybe @TabloTV has the answer??? Need help here pls.


#9

Thanks @totheuser86 the problem is solved. Mine was set to “leveling” which also screws up SS on Tablo - this audio setting must be set to OFF for Tablo to work in SS. But finding that setting on my Roku was not easy because you cannot access it from the menus - you can only get to it during Playback. So I will post official Roku instructions below. Hope this helps someone else.

What devices support volume modes?

To help determine if your Roku device supports volume modes, you need to know the software version and device model. To find this information, go to the home screen on your Roku device and select Settings > System > About .

In Roku OS 8.2.2, support for volume modes is available during video playback when Roku TV™ Wireless Speakers are connected to a Roku TV. In Roku OS 9, support is added to the Roku players listed below, as well as select Roku TVs whether paired or not to Roku TV Wireless Speakers.

Device Model
Roku Express 3900X
Roku Express+ 3910X
Roku Streaming Stick 3800X
Roku Streaming Stick+ 3810X
Roku Premiere 3920X
Roku Premiere+ 3921X
Roku Ultra 4660X, 4661X

Roku OS 9 has rolled out to Roku players, and is expected to roll out to Roku TVs early next year. It is expected to be completed in Q1 2019.

  • Note : Information on the Roku TV models that will support volume modes will be available in early 2019 when Roku OS 9 begins rolling out to Roku TVs.

Enable volume modes during playback

When streaming a movie or TV show, or watching content from another device on your Roku TV (e.g., cable set-top box, Blu-ray™ player), you can enable Automatic Volume Leveling or Night Mode from the options menu as described below.

  1. Start playback.
  2. Press the Star button star button on Roku remote on your Roku remote.
  3. Select Advanced sound settings .
  4. Use the directional pad to switch Volume mode to the desired setting. The directional pad is plus-shaped and is in the center of your Roku remote.
  • Off : Volume modes are inactive and content volume is unmodified.
  • Leveling : Enables consistent volume across different types of entertainment so you do not have to change the volume every time you switch channels or a commercial comes on.
  • Night : The volume of soft sounds like whispering is increased while the volume of loud sounds like explosions is decreased, making it easier to hear your TV at night without disturbing others.
  • Note : In some streaming channels, the Star button star button on Roku remote is assigned a different function meaning it will not open the options menu as described above. In these cases, you must launch a different channel, such as The Roku Channel, and follow the steps above. Once the volume mode is switched, the setting will remain when you return to the original channel.