5.1 Surround sound roku error message problem

Any one of the three from the bottom row here:

The 3810R and 4661R will future proof you for a while - especially the 4661R.


The 3500 has “Dolby audio pass through via HDMI” so it should work with Tablo app. See the link below.

It’s likely your Audio settings on your Roku aren’t configured properly.

Is your Roku 3500 directly connected to an AVR (audio video receiver) or HDTV?

My Roku is plugged into the hdmi port of my tv. You’ll have to excuse me but I am 80 yrs old technically challenged on these matters. How do I change the audio setting?

What is the make and model of your HDTV? It should support Dolby (AC3) audio over HDMI unless it is a very old HDTV.

It’s a Panasonic TC-32LX85

I can’t see anything on it that says Dolby sound except manufacturer licencen by dolby and that it is an LCD tv

Your HDTV has only 2 speakers for stereo sound. Why do you want to run the Tablo in 5.1 Dolby audio? Just let the Tablo convert the audio to 2.0 AAC stereo audio.

Also see page 42 of the manual for your HDTV (link below). Your HDTV is too old to support Dolby audio over an HDMI input. It also supports PCM audio via HDMI. So before you get a new Roku, get a new HDTV.

“Audio settings can be made on the “HDMI 1 in”, “HDMI 2 in” or “HDMI 3 in” menu screen. (p. 22)
Applicable audio signal sampling frequencies (L.PCM): 48 kHz, 44.1 kHz, 32 kHz”.


Thank you for all your help. I will take your suggestion about getting a new tv. Any suggestions as to what would be compatible with my Tablo and my OTA? I think I saw something about certain TVs not compatible.

Thanks again!

The real question is “do you need 5.1 audio”? If you’re happy with stereo audio, save your money.

Also if you want true 5.1 audio, you’re going to need an AVR (audio video receiver) and 5 speakers + a subwoofer. TV speakers aren’t true 5.1, even on new HDTVs.

If I do get a new tv, do you recommend a smart tv? I presently have a Roku and also Chromecast on my tv.

Have been tripping, stumbling, grumbling, and falling over this for a couple of months. Three entertainment stations with Rokus and a Tablo server. Two work fine with enable surround sound, one won’t .

Sound leveling on the Roku was the culprit! 30-second fix.

Thank you, thank you, thank you very much!

I have three Roku 3800x, all purchased recently. Two out of the three of them have not shown the “surround sound error message. All are set up correctly on “surround sound-compatible” TVs. One of them had the error message and I changed the “volume mode” setting on the Roku to “ off” and that solved the problem. That was yesterday. Today, when I turned this same Roku on and tried to playback a program that worked fine yesterday, it returned the “ surround sound” error message again when I tried to receive local TV or play a recording. I went back and checked the status of the “ volume mode” setting and it was still set to “off.” (There are no children in my house, so I don’t suspect foul play.) How many others are also experiencing this error on an intermittent basis with a correctly-configured Roku “volume mode?” I hope that Tablo will share more information about this intermittent error and can advise all Roku users about a permanent fix.

Further information to the post yesterday on my three Roku 3800X Streaming Sticks all with “volume mode”=off: These first two have functioned normally without the “surround sound” error message in Tablo (1) Software version 9.1.0, Build 4091 (2) Software version 9.2.0, Build 4106. My third 3800X, which I’ve done a factory reset for, but it still returns the “surround sound error” when Tablo Surround Sound is “on.” When I set Tablo to “surround sound=off,” it will allow audio to pass on Live TV, but, of course, still returns the error when attempting to play a show that was recorded with surround sound “on.” (3) Software version 9.1.0, Build 4919. My first two Roku sticks don’t behave like the third one. Does anyone see any pattern here that might help?

Same problem here. Hopefully they will figure it out.

I discovered the same problem. I have 4 Roku’s on 4 TVs Only my new Roku Ultra 4670X 9.2.0 4806-46 is having this issue. Older Rokus with same settings work fine, The 3 older Roku’s are 4630X 9.2.0 4806-29 (2 ea) and 4660X 9.2.0 4806.46 I have moved them around and only the new one has the surround sound issue no matter where it is placed. The other 3 work wherever it is put. Setting are the same. I have spent hours testing this problem with no solution except to leave the Tablo set on Surround Sound OFF. No problems on any other apps running. Hope a solution is coming soon.


I picked up the latest Roku Ultra on Black Friday and I’m not having any issues with playback of 5.1 recorded content.

We have some guidance here (and there’s also a link to Roku’s user guide) to choosing the right settings for your Roku: https://support.tablotv.com/hc/en-us/articles/360001241823-5-1-Surround-Sound-Error-Messages-on-Tablo-s-Roku-App

It’s worth noting that those who enabled Private Listening or Sound Leveling experienced issues with Surround Sound compatibility.

  • Go into Netflix (or another app)
  • Pause
  • Press *
    • Advanced Audio
  • Turn off Leveling

To turn off Leveling mode or Night mode on a Roku:

While something is playing on the Roku, it is hit Pause, then hit *, scroll down to “Volume mode” and change it to “Off” using the left or right arrow keys.