Tablo Tools - Bulk Export/Delete on Win/Mac/Linux

TLDR; Yes, Virginia, there is a list

I finally did some organization yesteryay.

Of most interest to y’all, when I talk about issues being/going on “the list”, it did exist and from now on you can find the Backlog here.

I also tried to start some semblance of a Roadmap. No dates, everything subject to change :slight_smile:

Hopefully anything missing/broken that you care about is in the Backlog or Roadmap. If not, let’s talk here or through opening an issue.

For the more bored and adventurous, I also started taking my relevant notes/info and tossing it onto the project wiki.

0.2.0 is looking good, but a few things I noticed. I got the symbol in the upper right corner (on 0.1.9 - hopefully 0.2.0 does not use same link) that a new version was available, but clicking on it took me to a 404 on GitHub.

Also, when trying to click on the Movies/Shows button or Search button a magnification box pops up that mostly blocks the buttons.

I’ll check out the new version notification links.

I know the zoom menu covers things up, but I felt it went away enough… if you go down. I’ll probably play with that more at some point.

Prior to v0.2.0 there were some complaints about Bulk Exporting “just stopping” or hanging. I just left a Bulk Export running for about 1/2 an hour without issues and am still going to run an overnight one.

I probably missed someone, but a quick search showed @japzone and @TabloInTheCity had that issue, so I’d love to hear if that works as expected now.

FWIW, I believe that was the out-of-memory error I’ve seen. While I didn’t directly/purposefully fix this, I’m pretty sure replacing the guts indirectly did.

Read the changlog/what’s new, acknowledged it’s a one time deal, got this -

issue, GO BACK doesn’t do anything. I guess because I didn’t really come from anywhere? Clicking another toolbar option worked as expected. Just an initial shocker… of course I have records “<1 MINUTE OLD” yet.

Appears to have no real impact on function.

1 Like

I’ll get it in the next release - should’ve put this here, too.

1 Like

@jesse am running v0.2.0 and was prompted in the app that there was a new version available. Clicking on “download v0.2.1” got a 404.

Someone else mentioned that and I didn’t pick it up. I’ll get to it next.

Also, when browsing recorded Movies I see the movies, but clicking on the thumbnail/icon does nothing. When browsing TV Shows clicking the icon brings up another screen with more options. (same behavior in v0.2.0)

I don’t know of anything to show if you click on a Movie or Event since there’s only one of either. What would you expect it do?

When I click on TV Show, like “This Old House” I get a screen like this where I have an option to play or download the recording.

When I click on a movie in Browse Movies I would have expected a similar screen to appear with options to play and download just like TV Shows.

If I use the Search function to find the movie, then I am presented with the various options. On the Browse Movies screen all I can do is see the icon for the movie. Clicking or right-clicking the icon does nothing.

Very good point, thank you!

I just put out v0.2.2-alpha.1 which is meant to let people play with and give feedback on the interface for creating export file name “templates”.
It does not yet save whatever you come up with (Ctr/Cmd+C to copy yourself) or apply it to exported files.

Here’s what it looks like right now…

I can cipher through the “fixed” variables and the Object.oriented values.

these both yield the same results… (disabled context menu - PITA)

{{episodePath}}/{{showTitle}} - {{episodeNum}}.{{EXT}}
{{episodePath}}/{{showTitle}} - s{{lPad episode.season_number 2}}e{{lPad episode.number 2}}.{{EXT}}

If you could make this “user firendly” airing_details.datetime I’m looking for a fail-safe for the occasional show on the sub-networks which don’t get properly scheduled with a season and episode title.
Tablo will list each these as ShowTitle - s00e00 - <blank. So every episode will likely overwrite each other.

wrapto checks for Title and uses tablo’s ID if there’s none. It’s not a common occurrence, but it only needs to happen one to irritate someone. Adding the recording Date and/or time might have other niceties for some reasons.

As is, I believe tablo’s time is UTC and works things out via timezone… so as is, it’s something, but little meaning as most of us use 12hr time in our local zone :slight_smile:

Stuff due to it being a pre-release…

  • I know those two things yield the same results - lPad is a helper to modify variables. I was trying to show what can be done to modify the variables when playing around before I write better/obvious documentation.

  • I’ve added some date/time shortcuts (that can be further manipluated like above). That included doing the TZ conversion.
    Screenshot from 2020-06-27 14-41-01
    The “fail safe” will be part of these Export Controls - feel free to chime in if I missed something.
    Also, where are you getting recordings without titles? Are you trying to use showTitle outside of Series/Episode?

And since there’s a good reason now, I’ll look at adding a context menu for copy/paste.

I haven’t recorded any recently to export a list. Of that screen shot - “Other Season” will show as s00e00 it tablo’s DB and there is NO title per episode. Here’s a shot (both from the same show) with Season one
image image

Season one has episode number and episode title. Due to some scheduling issues, not all of the episodes have complete data - so they are listed as “Other season”. Here, they show just show Channel info note void of episode number an episode title. using
{{showTitle}} - {{episodeNum}}.{{EXT}}
“NameOfShow - s01e17 - One Wedding and a Baby.mp4”
“NameOfShow - s01e18 - Shootout at the Comedy Corral.mp4”
“NameOfShow - s00e00 - .mp4”
“NameOfShow - s00e00 - .mp4”
“NameOfShow - s00e00 - .mp4”
“NameOfShow - s00e00 - .mp4”
[edit] this isn’t completely accurate as I didn’t include {{title}} in my template

Well, this is past experience. As is, the last 4 would just over write each other, or something or nothing. wrapto checks for a null title and substitutes the tablo ID, it’s also included in the template if you know you have these episodes. tablo ID is somewhat meaningless, other than unique to each episode.

Adding a recording date - time would also provide some uniqueness and sequence.

I do understand this is very much a work in progress, and export/naming is near the top…

As “more than 2 is probably silly” I stopped at 2. It show one file / filename …not any indication of the second. Of course it’s likely in the same location with a similar name.

My cart is empty. I chose to remove all recordings, yet one is still listed. So then it’s still selected for exporting? Likely until I change screens.

Same issue for me - for programs without series/episode numbers (such as What’s My Line?), exporting multiple episodes just writes over each previous one. The cure probably is one I am very eager to move from Alpha: custom file output naming. In this case the date of recording could be used.

(Interestingly there is some kind of internal program identification serial number attached to the broadcast with cases like What’s My Line? because Tablo knows when one is a repeat of an episode already recorded and skips it even though there is no identifying info displayed in the program guide.)

As it is, I’m eager for the custom file naming in order to capture the episode name (not just series and episode number) which is so often present. It’s a shame to strip that off at present. And, much less important, I want to change the convention on the year of movie files to parentheses in the format which Plex uses.

Bug report: When I play an episode from within the Search list of episodes and then X click out of it to watch another, if I go back to that previously partially played episode and press play the episode will not play. Can’t go back and play the second one I clicked out of, and so on.

Apparent bug: When exporting and I click the “Delete when finished?” button nothing actually happens when the exports are finished - the files remain on the Tablo and I have to go back to the Search window and then select Delete from the cart dropdown at the top of the Search window. (I presume the files are meant to be deleted automatically instead.)

Tablo Tools continues to be immensely useful and valuable!

1 Like

It may (maybe someday) have an option to have a naming template per-show. One show you want s00e00, this one it’s pointless, maybe date/time instead.

Me, most “current” ones are watch and delete. Some, you may archive, or what ever reasons, Seinfeld or Friends - the episode title, you know exactly what it is.

My point, with the flexibility, there’s different reasons you might want different naming conventions for different shows. Also incorporates path.

v0.2.2-beta.1 + release notes are out now and Filename Templates are “working”. You can add/edit them. There are full previews.

Of great import, there’s a context menu to cut/copy/paste now.

With obligatory screenshot: