Tablo Ripper - Automatically download new recordings

An asterisk at the beginning of the file name indicates the recording was “incomplete”, and most likely not the full show. There’s a setting on the “configuration” table to “skip incomplete” and it’s likely you have that option selected. If you deselect that option you’ll be able to rip your shows, but you may not like what you get.

Gotcha, thanks

Wouldn’t it have been helpful to have added something like (*=incomplete) near the listing… :poop:

a note along with these. I’m not entire sure as to these settings, I have incomplete recordings (signal excuse) - showing in other 3rd parts apps as 0 or 1sec in length and/or no size. They do have a seg.ts but incomplete playlist.

If it’s dirty and/or unfinished… it just isn’t there beyond an “entry” or it’s unlikely possible there was an attempt to export these and it was unsuccessful. tablo’s UI show’s a single failed instance.

Hope all is well with you and your family. We are doing fine up here in the great white north… :slight_smile:

I am replying in this thread to see if anything has been implemented for customization. And, where the latest version may be found.

Best Regards,

The OP link is still the right place to start.

Stay warm up there.

I can’t get Tablo Ripper to run. I’ve been using 2.4.1 for quite some time now. Its been fantastic. Yesterday it hung up and eventually crashed. I rebooted and now the program won’t start. I uninstalled and reinstalled and still can’t get it to run. So I down loaded 2.4.3, uninstalled 2.4.1, and installed 2.4.3. Tablo Ripper still won’t start. Strange behavior. BTW, I am running Win10 Home on a laptop. Any thoughts.

What we, aka users, consider “uninstalling a program” isn’t always synonymous with what Windows, other OSs or developers consider a program to be uninstalled.

When a program is uninstalled it’s likely “traces” of it are lift behind, such as configuration data and other personal settings not created my the installer. (It’s not always like this, but most often - not deleting something the “installer” it didn’t explicitly create)

If you believe there’s something that’s flubbed up Tablo Ripper, you may consider digging through and wiping out anything it leaves behind – maybe :frowning:

Thanks djk. I feel that Tablo Ripper left behind a configuration file or a database that is corrupt. But I can seem to find them. They are not in the Program File folder. I keep looking. I just fired up Tablo Ripper on another computer and hope the log file might shed some lite.

Process of elimination… if it works on another PC, then your tablo works, and (not doubt) Tablo Ripper works as designed.

I’m not really a Windows user, but I believe configuration “stuff” is usually saved in the user profile under some burred, probably even .hidden :frowning: it’s like

C:\Users\[username]\AppData but it may follow it’s own strategy for local configuration data.

…then again, it may be related to something entirely different, you just asked “Any thoughts” - I was just thinking, about stuff :neutral_face: Hope things go well!!!

Thanks again djk. AppData was one thing I did not check. Just went there and didn’t find any thing obvious. But I am beginning to think it is something like this. Tablo Ripper seems to be creating a database of Tablo recordings. It was during a refresh of recordings when it hung up. I think if I can find that database and delete it, Ripper might re-create it. But I’m just guessing. Thanks for ideas, one of these will pan out.

1 Like

Try ProgramData\TabloRipper.

Thanks Nilex. I was hopeful when you posted this. The ProgramData\TabloRipper directory has a lot of cache information. So I removed the directory. Uninstalled TabloRipper and reinstalled. No help at all. I double click on the program and nothing happens. Strange indeed.

First question to ask is: what changed?

@Nilex is correct, uninstall TabloRipper and delete the files in that folder and you’ll get a completely fresh install next time.

When “nothing happens”, does a log file appear in program data?

Thanks for responding Cycle J. When I deleted the Program Data folder, uninstalled Tablo Ripper and reinstalled, a new Program Data folder was created, but was empty. I tried to start Tablo Ripper by double clicking on the program on the start menu. Nothing happened that I could detect. The program data folder is still empty. No log file. I’m going to try again, this time with my fire wall and anti virus off. Maybe??? Thanks

I just tried again. No Firewall, no Antivirus (other an Windows), Uninstalled, Installed. ProgramData folder was created. Ran Tablo Ripper and nothing happened. No log file in the ProgramData folder. Something really strange is going on here. Thanks for the help!

Windows :expressionless:
I got out my (only) Windows PC running 10, had to wait while it did “stuff” until I could use it. My version of Tablo RIpper was dated, fresh installation of newest version, left what ever configuration intact.

New install left cluttered desktop icon - double-click and it stared and began to sync believe. When checking settings/configuration I got a Windows Security warning about Controlled Folder Access !?! huh? I allowed Tablo Ripper access to my controlled folders.

Switched between tablo1 and tablo1, updated/sync’d each time without issue. Exported a recording (well it takes a long with on a wireless network, both ways, but it’s looking good).

C:\ProgramData\TabloRipper looks like plain text xml files. But I have seen show descriptions have extended characters that create a bit of a hassle in other 3rd party apps. (just a messages, them moves on mostly) It would/should be logged, but it would have to start first and be reading data from the tablo and/or file I image.

New install, over old version is working on my sluggish Windows 10 system
It did create a tmp folder to save the mp4… only to rename it later - the temp folder lingers.
It ask Output Folder: I enter V:\ when I can’t find my recording, the log says it’s in V:\TV Shows\ – but that’s there’s nothing saying my selection isn’t where it’ll actually be saved ?

now I’ll leave this sit for a bit and let Windows Update :clock12: :clock1230: :clock1: :clock130: :clock2: :clock230: :clock3:

I hear you djk on firing up an old Windows computer. My travel laptop often sits for months at a time. When I fire it up, it can take days to stop doing Windows Updates. If it weren’t for a couple of programs, I would have moved to Linux a long time ago.

I’ve installed TabloRipper on two other laptops today. Both installed perfectly, and from the same install I used on my main laptop. So its not a corrupt download.

Good luck with your Windows Updates. Thanks for the help.

V: ???

I’m assuming that’s a mapped network drive? If so you could have a permission problem with TabloRipper’s background service. Unless it’s running as “you” the drive mappings won’t be there same. Try ripping to a local folder.

Obviously something weird going on with that laptop. Makes no sense it won’t even start.

I agree CycleJ. Something really weird going on. Windows has done that to me before. Might be time for a fresh install. I just tried to install the 32 bit version with the same results. Its strange that TabloRipper would run just fine for many months and then just stop like this. Its almost like a permission problem or something is blocking it. Thanks.