Tablo Ripper - Automatically download new recordings


#1150

Perfect, got it to stick! Now will tinker with the settings. Thanks.


#1151

Just rode in to work on the train this morning happily watching my half size ripped episode. Going to play with changing the resolution now to shrink it ever further as 1080 is probably not needed. Been playing with different Android players and have found MX Player to be a good choice in terms of quality (UI & Video), customization, and most notably it saves position. Using the free copy with ads (that aren’t too bad) but if goes well will grab the ad free version. Thanks again!


#1152

That’s wonderful! Perhaps you’ll share your parameters (and for which device) once you’re happy with the results?

I’ve used MX player (a good choice) and also VLC (also a good choice). But moved on to Plex since it’ll play all local media types in addition to my remote server files.


#1153

I gave Plex (and VLC) a try but it didn’t seem to remember the last watched location of files I moved to my device manually. Meaning if I move to device, watch, stop, watch, it starts over. Not that I expect it to transfer last watched from the Tablo or my PC. I don’t subscribe to Plex Pass but I imagine if it did the sync for you it would. I also checked out streaming from my PC but the data usage, even at a really low server bitrate setting, seemed pretty high.

The file I am watching today on a Nexus 5X (Oreo) was encoded with “-c:v libx264 -preset veryfast -crf 23 -c:a copy”. It trimmed about a GB off the file size from about 2.3 to 1.4 for an hour long show. Will try to play with the resolution settings tonight as I want to aim for a GB or less. When I was doing it in Handbrake I could get satisfactory video at about 650 MB but the audio was getting a hiss added to it.


#1154

I ripped several different CRF speed settings last night and tried them on the way to/from work today. This seems to be my favorite balance of quality and speed. Not sure if this is standard but for some reason veryfast was smaller in file size than fast and faster. I was also off about my original compression. It was closer to 3 GB to 1.4, In any case this setting went from about 3 GB to 540 MB so a great savings. I will say I could notice the downgraded quality but it was infrequent that I noticed. Maybe 3-4 scenes in an hour.

-c:v libx264 -preset veryfast -vf scale=1280:-1 -crf 25 -c:a copy

I also wanted to note that the % complete in the app was way off when I adjusted the coding settings. I think the rip took about 20 min and when done the complete reported like 20%. I didn’t watch all the way through to the end but I did see it saying 14% complete even though looking at the log showed about 50 min out of 1:05 done.


#1155

Thanks for experimenting and sharing your results. I’m sure that’ll help the next person that’s interesting in taking their show(s) on the road.

The percent complete is calculated using the reported tablo recording size and current output file size. Even with the normal ‘copy’ settings it’s a rough approximation. But with compression, well all bets are off.


#1156

I have recently been getting an error on Tablo Ripper when I try and to rip a selected recording from Tablo to my PC. I get an error that says " Exception - The remote server returned an error: (503) Server Unavailable." I have downloaded an older version on another PC and I get the same error. What do you suggest I do to solve this error. I am a novice at tech support, so I am sorry if this question has already been asked and answered somewhere in your posts.


#1157

Does that show play normally (not using TabloRipper)?

If so, please enable logging on the configuration tab, try to rip it, then send me your log file (you can open it using the link inside TabloRipper, then select all, then edit copy) using a private message.

I’ll create the message thread for you so you’ll just need to paste your log into your reply.

We’ll get you going!


#1158

Were you able to successfully implement a remote solution? I am very anxious to do the same thing!


#1160

Thanks for your quick reply. I am new to Tablo and Tablo Ripper, however I have read this entire TR thread and, like so many others, I am so impressed and appreciative of your efforts on all of our behalf!

TR works just fine on a workstation sitting next to the Tablo box. However, I have not been successful yet in connecting the remote TR to the Tablo. I know that both routers are talking to one another because I have it now set up so that the router web pages can only be accessed from my remote TR located network. I first set up the Tablo side router with 8885 mapped to 8885 for the Tablo TV. Within the remote TR system, I used the external IP address of the Tablo system and 8885 as the port and got the following error message within TR: “Exception: Invalid URL: Invalid port specified.”

Here is what the port forwarding looks like on my Tablo side router:

I believe the first two Tablo TV entries were created by Tablo, so I tried making the “Port Range” 21052 through 21055 with all mapped to “Local Port” 8885 and got the same error message as above.

What do you suggest I try next?


#1162

With https, the link times out. When I drop the s, it produces the following (small sample of total page):

Index of /pvr/

Name Last Modified Size Type
Parent Directory/ - Directory
11067/ 2017-Sep-19 07:06:33 - Directory
11069/ 2017-Sep-20 03:06:43 - Directory
11070/ 2017-Sep-20 04:06:38 - Directory
13707/ 2017-Sep-21 05:15:08 - Directory
13709/ 2017-Sep-21 17:05:58 - Directory
13720/ 2017-Sep-21 14:36:00 - Directory
13753/ 2017-Sep-21 10:07:48 - Directory
13761/ 2017-Sep-19 03:06:39 - Directory
13764/ 2017-Sep-19 04:06:35 - Directory
13774/ 2017-Sep-19 08:07:56 - Directory
13910/ 2017-Sep-19 14:12:15 - Directory
13913/ 2017-Sep-21 14:06:02 - Directory
13924/ 2017-Sep-22 09:41:28 - Directory

Really appreciate your timely help on this . . .


#1163

Hey CycleJ, Been trying to move movies and TV shows off my Nvidia Shield TV to my computer or my NAS. I have the USB Tablo (Tablo-63BA) Its directly connected to a USB port on the back of my shield TV. Everything is fine except when the file completes it just creates a “tmp” folder with nothing in it. Everything is up to date with latest version. I enabled the log file and will paste one of the transfers to see if you can see something I don’t. Tanks.

10/22/2017 11:43:14 AM btnStartSelected_Click
10/22/2017 11:43:14 AM SyncTabloRecordings_Selected
10/22/2017 11:43:14 AM InitTotalCount
10/22/2017 11:43:14 AM Total item count = 1
10/22/2017 11:43:14 AM SyncTabloRecordings
10/22/2017 11:43:14 AM recList.Length=32
10/22/2017 11:43:14 AM newCompletedList.recIdList.Length=32
10/22/2017 11:43:14 AM RemuxRecording
10/22/2017 11:43:14 AM FFMPEG : C:\Program Files\TabloRipper\ffmpeg.exe
10/22/2017 11:43:14 AM TempOutput: \JZ-CLOUD\Public\Shared Videos\tmp\Foreground_rip.mp4
10/22/2017 11:43:14 AM Output : \JZ-CLOUD\Public\Shared Videos\TV Shows\Judge Judy\Season 22\Judge Judy - s22e30 - Baby’s Ashes Stolen!; Daughter’s Bad Be.mp4
10/22/2017 11:43:15 AM InvokeApi
10/22/2017 11:43:15 AM JSON: {“token”:“01bc2da6-16f1-4b09-a936-3cdca572a957”,“expires”:“2017-10-23T16:43:12Z”,“playlist_url”:“file:///data/user/0/com.nuvyyo.engine/tablo/int/rec/7485/segs/rec.ts”,“bif_url_sd”:null,“bif_url_hd”:null,“video_details”:{“width”:1920,“height”:1080}}
10/22/2017 11:43:15 AM Options: -y -i file:///data/user/0/com.nuvyyo.engine/tablo/int/rec/7485/segs/rec.ts -codec copy -strict -2 -c:a aac -threads 0 “\JZ-CLOUD\Public\Shared Videos\tmp\Foreground_rip.mp4”
10/22/2017 11:43:15 AM Running as user: “C:\Program Files\TabloRipper\ffmpeg.exe” -y -i file:///data/user/0/com.nuvyyo.engine/tablo/int/rec/7485/segs/rec.ts -codec copy -strict -2 -c:a aac -threads 0 “\JZ-CLOUD\Public\Shared Videos\tmp\Foreground_rip.mp4” in C:\Program Files\TabloRipper
10/22/2017 11:43:17 AM Complete - 00:00:00
10/22/2017 11:43:17 AM All done.
10/22/2017 11:43:17 AM GetRecordingList_Selected
10/22/2017 11:43:17 AM GetTabloList
10/22/2017 11:43:17 AM Using static IP
10/22/2017 11:43:17 AM GetTabloRecordingList
10/22/2017 11:43:17 AM InvokeApi
10/22/2017 11:43:17 AM JSON: ["/recordings/movies/airings/7345","/recordings/series/episodes/7449","/recordings/series/episodes/7448","/recordings/series/episodes/7447","/recordings/series/episodes/7444","/recordings/series/episodes/7363","/recordings/movies/airings/7537","/recordings/series/episodes/7486","/recordings/series/episodes/7485","/recordings/movies/airings/7352","/recordings/series/episodes/7362","/recordings/series/episodes/7484","/recordings/series/episodes/7483","/recordings/movies/airings/7513","/recordings/series/episodes/7361","/recordings/movies/airings/7442","/recordings/series/episodes/7360","/recordings/series/episodes/7509","/recordings/movies/airings/7432","/recordings/series/episodes/7482","/recordings/series/episodes/7481","/recordings/series/episodes/7359","/recordings/series/episodes/7358","/recordings/movies/airings/7526","/recordings/series/episodes/7480","/recordings/series/episodes/7478","/recordings/movies/airings/7438","/recordings/series/episodes/7357","/recordings/movies/airings/7455","/recordings/series/episodes/7354","/recordings/series/episodes/7530","/recordings/series/episodes/7474"]
10/22/2017 11:43:32 AM Running as user: notepad.exe C:\ProgramData\TabloRipper\TabloRipper.log in C:\Program Files\TabloRipper\


#1164

You’re not seeing a popup error message? Copy the “running as user” command and paste it into a command prompt window. You should see an error message that’ll help debug the problem.

“C:\Program Files\TabloRipper\ffmpeg.exe” -y -i file:///data/user/0/com.nuvyyo.engine/tablo/int/rec/7485/segs/rec.ts -codec copy -strict -2 -c:a aac -threads 0 “\JZ-CLOUD\Public\Shared Videos\tmp\Foreground_rip.mp4”


#1165

Hey I’m not exactly sure which or all commands i need to copy and paste into command prompt. So i just did a bunch of different commands that are after the “running as user”. The only command that would go through correctly would say “The system cannot find the path specified”. I also did “C:\Program Files\TabloRipper\ffmpeg.exe” and pulled up all the config stuff with no errors. I did one last command line can copied all of the command after “running as user” and the error message was “file:///data/user/0/com.nuvyyo.engine/tablo/int/rec/7485/segs/rec.ts: No such file or directory”


#1166

I haven’t played with the Shield version of Tablo (I don’t have one), but it sounds like your PC can’t access that “file:” location. Which makes sense since it’s not pointing at your Shield (there’s no IP address), just a file stored on your Shield.

Can’t really help you get there from here, but maybe someone else can chime in?


#1167

That’s kinda odd that tablo ripper can still pick up and find all the videos and movies that I have recorded to the shield internal memory, but just can’t move the shows over to another file location via computer or NAS. The Tablo device does use the IP address of the Shield itself, so that might be a problem. Anyways, I really appreciate the help you have provided me with and will continue to jig around with it a bit. Also, I have tried Tablo Exporter as well and still not able to move files to another location. I am thinking your right as well, something with the Shield when it saves to the internal memory it can’t be accessed or moved in a traditional way.


#1168

Perhaps this may help?

http://nvidia.custhelp.com/app/answers/detail/a_id/4172/~/how-do-i-share-shield-tv-folders-with-a-pc


#1169

TabloRipper uses the Tablo API to get your recording list, and then gets a direct link to each video you want to rip. Normally (not the Shield) that’s a URL (including the IP address).

I suspect the hint provided by @eherberg might help if you can figure out how to make that file path map to a network location. Let me know of you get it working and I’ll add it to my FAQ.

If not, then if you can figure out what needs to change in the Tablo file reference (for example, replacing “file://” with a drive letter that you map to your shield) I’ll consider making a beta version you can test. The key phrase is “that you can test” because I can’t test it without the same setup you have.


#1170

@eherberg - I do have the Shield Internal Drive mapped to my PC, and I do see a com.nuvyyo.engine folder, but the folder is empty i mean 0 bytes total, and no hidden files as well. Also, went through the whole Internal folder that is mapped on my PC and the shows/movies are nowhere to be found. I think that the Shield is storing them in an inaccessible folder.

@CycleJ - I tried to replace the “File…” with the appropriate path that should have been the folder that the movies/shows were stored in, and the error that was given was “Permission Denied”. So I went into the Tablo Engine app itself and they even have a permission setting, was only Location and Storage that was able to turn on. After I Turned them both on and even restarted app, still said “Permission Denied”, Even though the folder is empty, lol. Also, I know that the Movies/Shows are stored somewhere in the app itself, because after every recorded show/movie the app will grow in size. I’m thinking that, as of right now, its pretty much impossible to get these movies/shows off the Shield. I really wish Tablo could put an option in the GUI settings on the Tablo device where I can choose where to store the files, and wouldn’t even need Tablo Ripper. But thanks all for the ideas/help. Will continue to troubleshoot, and if I find a solution I’ll post on here. Thanks again all


#1171

I did a quick test last night and basically ran into the same issues @JZPro. In fact, on the latest Shield TV firmware I appear to be missing the option to see the Shield TV folders from my PC. In Storage I no longer have the ‘Access SHIELD folders on PC’ option. That complicates the situation even more since it would effectively be preventing access to the Shield TV from the PC leaving Tablo Ripper with no way to even see the files to begin with.