Tablo Ripper - Automatically download new recordings


#1127

love the app. I would love to help work on it if you need any help. I am a software developer with over 25 years experience.


#1130

So far I’ve gotten about 3/4 of all 1TB of shows ripped. I have 1 episode that is not ripping completely. When I am watching the window there is a large section that comes through with multiple colors, so I know its wrong, but I can’t read what it says, it goes by way to fast. Is there anyway to get the whole episode over?

Thanks


#1131

I’m not sure, but let’s try something. Enable logging, then rip just that one recording. That’ll write the correct ffmpeg command into your log file.

Grab that from the log and try it at your own command prompt, see what ffmpeg says. Hopefully you’ll get an error message you can look up. And with luck, maybe there’s something you can do to get around it.


#1132

Just want to make sure Im following. I had tried to rip that one by itself. So I just take that long part and paste it into a new window at the c:> (that last log?)


#1133

No, that’s not the ffmpeg stuff. Use a PM ( private message) to send me your log and I’ll dig it out for you.


#1135

I’ve just downloaded and installed the latest version, 2.3.3, and it works great out of the box. The videos look and sound fantastic in my first tests.The only issue I have is closed captions, they’re not there. I’ve googled multiple times and I keep getting the same results. Use CCExtractor etc. but the problem is when I analyze the MP4 with VLC or MediaInfo they show no Closed Captions in the file.

I’ve verified that CC are present in the file when viewed on Tablo.

Since I haven’t seen this reported in this thread I assume I just have something set wrong. Or maybe not.

Edited to add that I was updated to the new Tablo version 2.2.14. I don’t know when it occurred but it looks like I installed the ripper post Tablo update.

Any help would be appreciated.

Fred


#1136

I’m traveling so I can’t look right now, but there’s at least one other guy that’s using ccextractor successfully with TabloRipper. He had me add an option to specify a post-processing file, which he points at ccextractor. TabloRipper passes the file name when invoking it, so it’s automatic.

Haven’t tried it myself, but if you dig around you’ll probably find his post before I do


#1137

I’ve dug around and found those posts. The problem is the CC text files are not in the ripped MP4. There’s nothing to extract from the ripped file.


#1138

Not a TabloRipper user, but SurLaTablo used to try to put the ccextractor subtitles into the mp4, but it was spurious… only sometimes working, for example, with Plex. So now the option always drops a .srt file alongside the .mp4. My point is that even if you try to embed the subtitle as a stream in the mp4, you may find it doesn’t work well.


#1139

Thanks for the 411 @cjcox. I never use captions, so it’s not something I can help with. But my understanding is that you’re right on track😎


#1140

I am having problems with an FFMPEG timeout and TabloRipper is not continuing with the rip. It is not successfully ripping files. This has been going on for a long while now. I have Tablo Ripper 2.3.3. I have even reinstalled Windows thinking it was going to fix it. The rips end up failing.


#1141

There is a FFMPEG timeout setting which will “give up” after a while if TabloRipperr sees no progress. Sometimes FFMPEG just can’t rip a particular recording. So let’s take this offline (I’ll send you a PM to kick things off) and figure out what’s causing your issue.


#1142

Hello. I downloaded and installed the Tablo Ripper (64bit WIndows) to my Windows notebook computer. I figure the next thing to do is to connect it to my Tablo, right? I’m not on the same subnet as the Tablo. So “select Tablo” does not do anything – there is nothing in the drop-down list.

I do however have the static (routable) IP address of the Tablo.

From my notebook computer I am able to use http://my.tablotv.com/ to connect to the Tablo. I am able to play recordings and do live streaming. This tells me that the Tablo has a happy connection with the firewall router at its location.

So I type in the static (routable) IP address of the Tablo. I click “refresh”. There is a brief popup “load recording list” and then nothing. The “Tablo recordings” window is empty.

For the Tablo Ripper to do its job, is it necessary that the Tablo ripper be on the same subnet as the Tablo? Is it impossible to use the Tablo Ripper from a different subnet?

I spent quite a bit of time clicking around the “configuration” section for the ripper and the FAQ and messages in this community forum, and was not able to find the answers to these seemingly simple questions. I’ll be grateful if someone can point me to the place where this is discussed.


#1143

I run mine on a separate subnet, so it’s possible. Assuming you’ve entered the correct IP for your Tablo, TabloRipper should connect and obtain a recording list.

Enable logging, try to connect using the refresh button, and send me your log file using a PM (private message). We’ll figure it out.


#1144

Thanks for putting this together! I’ve been waiting for the feature to come to the Tablo stock implementation, but this is so easy, no reason to wait.

Can anyone direct me to someone good options for ffmpeg extraction for my phone? I have been ripping then using handbrake but looks like I could just rip to a lower format. I’ve seen several posts in here about it but I don’t seem to be able to get it to do anything except direct copy. I tried to use the vcodec 264 and a crf of 24 but it seems to ignore my settings.

Thanks.


#1145

Thanks for the kind words😎

Ffmpeg is constantly evolving and has a lot of (sometimes confusing) online support. The trick is to find options that work well with your particular phone. I recommend you start here and experiment. You’ll want to enable logging in TabloRipper and watch the ffmpeg output to see what’s happening.


#1146

Most of the examples I see have input and output defined. I assume I don’t include that as your app must be subbing that into the command based on the selections in the UI? I think I’m struggling with the format I should be putting the options into settings.xml. For example in the page you linked it gave this as an example:

ffmpeg -i input -c:v libx264 -preset slow -crf 22 -c:a copy output.mkv

Would I enter this as the equivalent in the settings.xml file?

“-c:v libx264 -preset slow -crf 22”


#1147

Good assumption on your part. You can’t change the input or output, but you can change everything else. TabloRipper combines your parameters with the other bits.

Enable logging on the configuration tab, rip a video, then use the link in TabloRipper to display the log. You’ll see the full ffmpeg command that’s issued in the log.

But to answer your question, try “-c:v libx264 -preset slow -crf 22 -c:a copy”.

I’d have to try it myself to know if it works…


#1148

Aha, getting closer. So looks like I didn’t have a format problem, but looking at the log, it seems I can’t get the App to pick up the settings. When ever I open the app it seems to revert the settings xml back to its original state. If I alter while its open it sticks but doesn’t seem to use the updated and saved settings. Looking at the log it looks to use the default settings regardless of what I update to. Suggestions?


#1149

Since you need to edit the settings file directly (C:\ProgramData\TabloRipper\Settings.xml), you’ll want to ensure the TabloRipper service has been stopped and the GUI is closed. Then make your changes, and restart the service.