Tablo Ripper - Automatically download new recordings


#1107

@cyclej - Thanks for the adding the new email notifications for schedule conflicts and if my Tablo appears off-line. :clap::clap:


#1108

I did something to make Tablo Ripper delete all of my stuff, but I’m not sure what. If you put an extra “.” at the end of the list of shows in the “Auto-Delete after X episodes” box, would the program delete everything?

My “Delete after ripping” box isn’t checked and I hadn’t ripped most of my shows that got deleted anyway.


#1109

Use a PM to send me contents of your c:\ProgramData\TabloRipper\Settings.xml file and I’ll see if I can figure it out. Ok?


#1110

It’s a bug (now fixed and released on GitHub). Turns out an extra “comma” creates a filter matching ALL recordings. And as you found out, that’s not a good thing for AutoDelete.

Thank you for working with me to figure out what was going on.


#1111

What actually starts and stops it then? I just installed over the weekend and it works great in the Foreground but I can’t get it to pick up anything automatically. All users have fully access to the output folder so that’s not an issue. Thanks!


#1112

When you install it, the installation asks for “admin” rights so it can install/start the background service. It’s like any other Windows service, and you can see/control it using the control panel. It’s configured to run automatically, so normally there’s nothing you’d need to do.

Try clicking the “New?” option in the GUI recording list. Anything in the list? If so, that’s what the background service will rip for you - automatically.

If you have “new” recordings, and you’re not seeing any results, please enable “Logging”, let it run another 10-15 minutes, then send me your log file (use a PM since you won’t want to share it with everyone).


#1113

Yeah it’s running as a Service automatically. Oddly enough the one recording in there didn’t show up when I clicked “New?”. I’m not sure why though as it was never processed and just recorded recently. I’ll record a show this morning and see if it works on it. If it doesn’t I’ll send you the log. Either way I’ll update the thread.


#1114

You can right-click on your one recording, and mark it as “new”. Then see what happens.


#1115

Brand new recording, didn’t get processed. It’s sitting in the Recordings in Tablo Ripper but if I click “New?” it disappears. Not sure why it wouldn’t be considered new. Thoughts? Sent you a PM about the log file too.


#1116

Interestingly I’m having a very similar issue. I did upgrade to 2.3.1 around the same time the problem started it looks like. I didn’t notice it until today I opened Plex but it appears Tablo Ripper hasn’t been processing new recordings automatically overnight for the last several days.

I had a problem long ago where the log showed the service didn’t have rights to my NAS so after we worked on that and got it figured now after every install I go into the Service and specify the necessary credentials and that has always worked. That also wouldn’t seem the problem now because the log doesn’t show that rights related error at all.

I tested by recording a random show this morning and configuring Tablo Ripper to run at a time starting a couple of hours after that show stopped recording. The show does NOT show up when I click New? even though when I right-click the show the only option is Mark as ‘NOT new’? implying it thinks it’s already flagged as New.

So it’s almost like it’s not actually seeing it as new when scanning to determine what to process.

I’ll PM you the relevant portion of the log. It looks like it logged the show as new according to the flags, it just didn’t process it.


#1117

I had a similar issue this morning as well. I updated TR to 2.3.1 yesterday morning and this morning TR did not process any new recordings.

When I select the “New?” filter from the TR UI, it does not filter any of the new recordings.

I was able to rip them in the foreground with no issue.


#1118

@TheFivePack @Nilex @tickko Doh! You guys are the “rip everything” bunch, aren’t ya? My overzealous attempt at fixing the AutoDelete list broke the “select filter is blank” use case.

Version 2.3.2 is on it’s way up to GitHub now.

Thanks for the quick poke-in-the-eye. Should be all better now.


#1119

Haha rip everything, yes. I watch it all in Plex so I don’t record it unless I want to rip it. So far so good, first one worked perfectly!


#1120

Hey now, don’t judge. Just because your stellar app is the perfect solution to getting EVERYTHING in place automatically in Plex there’s no need for hatin’! :wink:

2.3.2 working great here now as well when tested on the show I recorded this morning. Thanks for the quick response, I’ll give it a full test of all my automated processes tonight.

EDIT: Everything back to normal. All overnight processing worked as expected.


#1121

I just recently installed Tablo Ripper and started it running. Now that it’s ripped several hundred shows (but with hundreds left in the queue), I’ve changed my mind about where to have them ripped. I see three possible ways to do it (in the order that I would prefer to do them, if they work):

  1. Stop the service, move the files, update the settings, and restart the service.
  2. Stop the service, delete all of the files, update the settings, and restart the service.
  3. Wait until it finishes ripping everything, stop the service, move the files, update the settings, and restart the service.

Would #1 work? Would it pick back up where it left off?


#1122

Go with a slightly modified “option 1”. You can change the settings using the GUI, then restart the service. It’ll pick up your changes when it starts and pick right up where it left off.

Then you can move your existing files while its busy on the new set.

Let me know if you run into difficulty.


#1123

What will happen to the file that it’s in the process of ripping? I assume it’ll go to the new location? (Or maybe the old?) But it won’t be left abandoned?


#1124

It’ll clean up by itself. You’ll have a tmp file sitting in the old output folder. You can safely delete it, and because it was interrupted, it’ll be the first one ripped when you restart the service.


#1125

PS: By ‘restart the service’ I mean using control panel, not the TabloRipper GUI.


#1126

Congrats to CycleJ - 1,000 POSTINGS TO THIS THREAD!

That’s an amazing testament to what a contribution he’s made to the Tablo community (and company). The steady, thoughtful parade of incremental improvements to Tablo Ripper has been a model of software development, and the dedication to fixes for the most arcane use cases - from a volunteer no less - is inspiring as well as phenomenally generous.

The longevity of this thread is only matched by CycleJ’s unstinting dedication and gift to all of us. Tablo Ripper has made my enjoyment and use of the Tablo indescribably better (and removed anxiety about hardware reliability and technology obsolescence).

THANK YOU 1,000 TIMES - and congratulations!