Tablo Ripper - Automatically download new recordings


#81

First off, your IP address is NOT a secret that needs guarding. Every server you connect to on the net logs your IP and request URL and is present, unencrypted, in every packet sent to/from your PC. What everyone connected to the internet needs to worry about is covered by the GRC link I posted.

Jestep, please stop spreading FUD. Not helpful.

BobW graciously diagnosed the problem for me using your information, so it’s no longer needed. I received another useful PM suggesting that if you enable external access, the missing values are populated, working around the problem until I get a chance to post the fix. They also mentioned that once enabled, you can immediately disable external access again and it continues working.

Haven’t tried that workaround myself, but do give it a try. I’ll have the api code updated sometime this weekend.


#82

Your external IP and the port is in that API return. Be careful :wink:


#83

The beta version has been replaced with a new release version. Let me know if you bump into any issues.


#84

Success. TR found the Tablo immediately, did a five hour Tablo recording in18:23 on an i7 computer. Output looks perfect. Thanks, CycleJ


#85

Would it be possible to run Tablo Ripper from a flash drive rather than installing it?


#86

I haven’t tried it, but this should work just fine:

  1. install as usual
  2. copy the installation folder to your flash drive
  3. uninstall
  4. run TabloRipper.exe from your flash drive

Let me know if you run into any issues. But the installation is a convenience, not a necessity. One caveat, the configuration and completed list are stored in your application data folder. So if you’re going to move the flash drive between pcs, you’ll have to configure the program on each one. Not a big deal, but I thought I should mention it.


#87

I love the new interface… was able to select and download a recording, that I’m going to try burning to a DVD. On my PC though, the quality looks really good.

There are a few issues I ran into though. On startup, I received about 9 “Exception:Object reference not set to an instance of an object” messages in the status window. Also, a number of recordings I have on the Tablo weren’t displayed in the Your Tablo Recordings window. As far as I can tell, these are shows that have been watched and not protected from deletion, and shows that have been watched and are protected from deletion. Could be the exception messages are related, but there are more shows that weren’t recognized than I have Exception messages.

Hope this helps.


#88

Thanks - that really does help! #1 knowing there’s still a problem with “nulls” in the response, and #2 your description was perfect.

I’m starting to believe you really can’t count an any of the JSON response attributes to be populated. And although I’m deserializing all of them I’m only using a handful. So I’ve done this:

  1. add null checking to all “used” response attributes
  2. add the JSON response to the exception message displayed within the program
  3. uploaded a new version with those changes

Please bear with me while I get this resolved. When you have a chance, please install the latest version and try ripping again. Those same recordings should show up (they’re not counted as “completed” unless the download is successful). And with any luck they’ll work this time around. If not, they’ll display some really ugly JSON strings in the status window.

Please copy the strings and send them to me (I suggest using a PM if you’re concerned with the content, but that’s up to you).


#89

Thanks! I used it to convert some shows and watched them. If I burn the MP4 to a DVD, will it play on a DVD player or only in a computer?


#90

That will depend on the DVD player.


#91

Hi Cyclej, my easy/dumb question for the day- is it still required to remove old copies of Tablo Ripper via control panel or does your official 1.0 release now install over top old copies?


#92

Progress:

  • @lkahhan helped me debug an issue where certain “episodes” don’t include either the season or the episode (go figure).
  • @imtheguy convinced me to repackage the installer as an MSI file (instead of EXE). Once you install version 1.0.0 (I had to restart the version numbers), subsequent installations won’t require uninstalling the old version before installing the new one.

Keep those suggestions coming.


#93

Thanks for the mention… it’s working BEAUTIFULLY now. I went to check for your latest version and picked it up about 30 seconds after you uploaded it. This application should be of tremendous value to any Tablo owner who wants to pull recorded programs off onto their computer for later viewing or burning to DVD, as it’s extremely easy to set up and use. Thanks for all your efforts to make this happen.


#94

Also good for anyone who wants to save recordings prior to swapping hard drives.


#95

Absolutely… early on, I had to do a factory reset on my Tablo, and lost all my recordings because it reformatted the drive. Sure would have been nice to have had this tool back then.


#96

@CycleJ

WIN 8.1

Hello

Wanted the current install to fix the episode numbering.

I uninstalled my current ripper: setup_1_15_07_35

Downloaded the TabloRipper_1_0_0.msi Size 860,160 bytes

Clicked on the msi file to install and immediately got the error popup box: “Error Executing Program”
(Downloaded the msi file twice in case there was a download error the first time)

Thanks

Chas


#98

I know if I right click on an “exe” file, it gives me an option to run as an administrator, no such option right clicking on an “msi” file. Error came up right away without giving me an option. Will post screenshot in short while , desktop is busy at the moment


#99

@CycleJ

ALL Is OK

Went to capture a screenshot of the error, but before I got there again…

When I first double clicked on the msi file to install, Windows grays out and pops up with a message, that it has prevented this file from installing since it doesn’t recognize it, but there was box to choose “Run Anyway”, which I did and it did install.

Sorry for the false alarm.

Chas


#100

@CycleJ. Just thought I would give you some feedback. First off, great app, works great. One thing that may or may not be an issue. I converted Late Night with Seth Meyers but the file name was too long for MCEBuddy to convert. MCEBuddy would not start. I had to trim the file name to Late Night with Seth Meyers-s02e147. I realize that MCEBuddy may or may not be part of your equation but wanted to bring this to your attention.


#101

Just uploaded a new version to limit the file name length. Thanks for the feedback!