Tablo Ripper - Automatically download new recordings


#53

Looks like it doesn’t want to download Tablo content, unless I’m missing something. Ended up uninstalling and then reinstalling the prior version. I do like the new interface though.


#55

Hello CycleJ,

Downloaded your app a week or so ago and gave it a try. Seems to work very well, but have only looked at about half-dozen so far. Nice programing and very quick. Took about 20 hours to grab what was on my tablo drive – 750 titles in all. Now I have 2 more disks worth backed up on my Qnap server left to do. I will have to restore them one at a time to another hard disk and connect it to the tablo to rip them. All totaled there should be about 2500 or so titles.

Now, as to comskip and MCEBuddy, I have been trying to use both for over a year now with my MCE content and although MCEBuddy works well, I am not very impressed with either the comskip (donator version) or show analyzer for MCEBuddy or the paid version, Show Analyzer Suite. Tried so many ways, ini files, and a bunch of recommendations found on the web and still only get a small portion of titles commercial free without hand editing.

Good job and thanks for helping me get my titles off tablo and into PLEX.

-Rodger


#56

Just downloaded version 1.15.7.31 and I see there are now “selection filters and exclusion filters”. This is a major improvement in a bunch of ways. I can now be selective gathering a series at a time. After I rip them, I can delete them from Tablo. This adds space to my HD and keeps only non-ripped titles on the HD, which will no doubt keep more order and less confusion over time. Another advantage is, the ripped season is in it’s own folder on my system, so I can tune comskip as needed for that particular station/network the season came from. What that means is less work overall as more accurate cuts will be done automatically. Fortunately, most cutting mistakes leave commercial content, rather than cutting programing content away. So, I could say “good enough” and just keep the cuts as done, or if really necessary, I can manually re-edit as needed.

Good job CycleJ!

-Rodger


#57

Any thoughts towards creating a Mac OS X version?


#59

You might also search this community for tablo2go I am running the Python script on my macbook pro under Python 2.7 with great success.


#60

Does Tablo Ripper support closed captions?


#62

@CycleJ

My Setup WIN 8.1
I successfully installed and used Tablo Ripper earlier this week, downloading selected files and seeing them converted to mp4s. (Also converted them using MCEBuddy ok).

This AM, I started the Tablo Ripper and saw this error:
Exception: The remote server returned an error: (404) Not Found.
Exception: The remote server returned an error: (404) Not Found.
Exception: The remote server returned an error: (404) Not Found.
Exception: The remote server returned an error: (404) Not Found.

I then went into my firewall, found all references to the Tablo Ripper and ffmpeg and changed the tag from “Low Restricted” to “Trusted”

I then restarted Tablo Ripper (same 4 Errors as above), moved a file(s) to the selected area and clicked on START.
It said “ALL DONE” Immediately, but nothing actually happened.

Any Ideas ?

Thanks Chas


#64

Running the setup_beta_test.exe


#65

Had a 404 problem with the first beta, but fixed it right before I left on vacation. Try installing the beta again after downloading a fresh copy. If all else fails, revert back to the released version. Let me know what happens…


#66

ok

Thanks


#67

OK,

Installed the current BETA and ran it, the one I was using did have a different file size, so I knew this one was different.

ALL is proceeding OK… converting in progress.

This is awful disturbing you on vacation… cudos to you !

Chas


#68

Although TabloTV works great on the network (two PC’s using Chrome browsers and two Roku’s), Tablo Ripper is unable to find it. The “Your Tablo” window of Tablo Ripper is blank, the status messages are: “Exception: ValueType ‘System.Int32’ cannot be null. Exception: No Tablo selected”

I have recordings on the TabloTV, have ticked the verbose logging box, pressed restart, but get the message “Please select some recordings first”.

When I open the Windows Network window, the PC and router are listed, but there’s no listing for the TabloTV hardware.

What have I missed here in getting this cool software to run? Next step suggestions? Thanks.


#70

version 1.15.8.10
All on the same local network (that is, TabloTV, Roku’s, PC all running thru one router joined by ethernet cable). Thanks for the quick response!


#72

[Post edited]
Yes, the ‘private ip’ response at https://api.tablotv.com/assocserver/getipinfo/ matches the server host IP setting found on the settings page of the my.tablo.tv “site”. The full response I get back from https://api.tablotv.com/assocserver/getipinfo/ is:

Complete response was removed as Jestep indicates that posting it is a security risk. I’ll send it to CycleJ when he returns from vacation if he requests it.
Thanks for your help


#73

That all looks good. Does your Tablo appear in the ‘your tablo’ drop down list? Next thing to try, install the release version instead of the beta. Better? Or the same?

PS, my working theory is that you’ve got a null in the response where I’m not expecting it. I’ll have to wait until I’m home to compare your response object to mine.


#74

Just a FYI, not a good idea to provide all that here…


#75

CycleJ,
I just compared my Tablo response to the above response and I have no null values. I have the following where he has nulls. “http” : 21040, “ssl” : 0, “slip” : 21042, “roku” : 0
I hope that helps your trouble shooting some.
Bob


#78

I’ve installed both the beta and the release versions with the same result. In neither version is there a Tablo listed in the drop down list, the box is empty.

I didn’t realize I was creating a security risk for myself by posting the complete response to the link above. Is there anything I can do at this point to nullify the risk? I’ve removed the paragraph with the complete response details.


#79

Thanks for the heads up, Jestep.


#80

No worries, I think you are fine. But if people know your IP and then can guess the ports they could try something. I doubt hackers are doing that here, but you never know now a days :wink: