Tablo Ripper - Automatically download new recordings

You have been successfully using Tablo Ripper for about a year on the new computer, with the Realtek NIC? and suddenly things quit working?

The problem has always happened on this computer and yes the brand/type of NIC is irrelevant but I brought it up in case others find this down the road. I was just pointing out I’ve not had any issues with TabloRipper with included ffmpeg and surround up until I swapped ffmpeg to a newer version hoping that was causing the NIC on this new computer to fail (it was).

… does the “old” perform the same when set to not process the surround sound?

Sorry I don’t understand fully the question but if you’re asking if there are audio problems when ripping stereo content with the new ffmpeg the answer is no. With the “included” (old) ffmpeg all the tablo ripping works fine even with surround - except on this computer with this NIC due to the reasons I described (which is to say it still works, until it breaks the computer). Yes, it’s weird, but that’s what it is. And this 2.5gbe NIC apparently has problems, so I’ve spent months of tweaking drivers/settings to try to fix this issue on that side and no luck.

Many of the Tablo devices only have a 100Mbps connection… so 1 or 1.2 isn’t going to gain for steaming.

I use 2.5gbe with two NAS’s and other items I do, so I’m ultimately saying it’s undesirable if simply not an option to use the other ethernet port on this computer.

Have you found any issues related to ffmpeg causing issues with network hardware? If this is actually what’s going on, you may consider reporting a newly discovered bug

I can’t submit a bug report on an old version of ffmpeg. If anything I was wondering/hoping someone else had swapped out ffmpeg versions and already solved this issue.

CycleJ is right and I found the ffmpeg config details in the FAQ, so I will go that route. If I fix it I’ll report back. Thanks


I’ve been using TR for some time quite successfully but ever since I stood up two tablos and tried to point TR to one vs the other, I get FFMPEG time out errors. I guess the questions I have are:

  1. is there anything inherently wrong with two tablos on same network and pointing TR to one or the other?
  2. does table have the concept of “new” separately depending on the tablo it is connected to?
  3. what does FFMPEG have to do with native h.264 recordings?
    4, my particular issue occurs only on one specific tablo, which I have rebooted (along with rebooting the external disk). the Tablo itself has changed from a duo to a quad (disk transfered fine) and I can record and play shows on the offending tablo, vi roku. I just can’t TR from it
  1. No, but I never actually had two Tablos on the same network to do my own testing.

  2. TabloRipper separates the metadata for each Tablo, so “new” is relative to each one.

  3. I suggest you enable logging, rip one show, and extract the command line that runs FFMPEG. Then run that command yourself in a command prompt window and you’ll see exactly what’s going on.

  4. Troubleshooting TabloRipper is the same whether you have one Tablo or ten. Enable logging, restart TabloRipper and look at the log file to see what error you’re getting. Obviously, focus on the Tablo you’re having problems with.

You kind of have to have them on the same, well, it’s not like consumers are going to have multiple home networks. Yes, multiple co-exists on the same network.

I don’t use Tablo Ripper routinely, not sure how it IDs tablos - a device does not change it’s self, it’s one or the other. Each tablo had it’s own SID_XXXXXXXX, although a user may see it as the same, Tablo may not have seen it. I use 2 other 3rd party apps which use the SID to store and ID the data from each tablo.

Since you swapped drives, which saves the SID in the DB to transfer, don’t know, maybe Tablo Ripper isn’t recognizing you have “new” tablo? Or if the disk swap transferred the SID (settings, manage my subscriptions) then, well maybe deleting the configurations, not uninstalling, might help.

I’m just tossing some trouble shooting suggestions. 2 devices on the same network shouldn’t be a hassle.

ok I’ve been doing some more experimenting and believe that the issue might be related to a particular recording on the source tablo. when the problem occurs I get 404 timeout errors in the logs, and since the logs identified the show itself i was able to delete said recording from the source tablo and that cleared things up . for a while. My next learning was to observe the timeout when launching a foreground rip of ‘new’ recordings – based on my keyword list. but in this case I get the timeout entry in the logs before the show/recording itself is even identified. So thats exciting :slight_smile:

So I’m proceeding still with the hypothesis that it is one or more faulty recordings on the source tablo and trying to find out which ones by manually moving shows from the left pane to the right pane and launching a foreground rip. so far it has crunched away all last night with no issue, so I haven’t learned much yet!

Using either Tablo Tools or APLTablo can help you identify recordings flagged as “Dirty” by Tablo. It could be a “Dirty” recording that is causing your woes.

1 Like

TabloRipper puts an asterisk next to incomplete recordings and has an option to skip them automatically, but I suspect @Dlleno is dealing with a corrupted database.

So no fsck lol

If a file has an internal, it doesn’t mean the filesystem is corrupt.

e2fsck checks for errors on ext filesystems.

It’s possible for your Tablo’s internal metatdata to get out of sync with your external hard drive. The symptoms sound a lot like what you’re seeing, and AFAIK the best solution it to delete those recordings (they’re not accessible anyway).

Good luck.

Thanks yes I think thats the prudent approach. I can find out experimentally which ones those are; already identified one, and early indications are that there are not many, so I’ll just keep ripping until I find them!

1 Like

Apologies if this has already been covered - searched but didn’t find…

I’ve noticed that sometimes the Tablo Ripper process gets stuck in a loop. I can see it creating a background_rip file in its tmp directory, but when it finishes, it starts over on the same file. I looked at the log and realized I already had the episode it was trying to rip (I hard recorded it a long time ago apparently, but because I delete them from Tablo once I rip to Plex, Tablo doesn’t see it as a duplicate recording).

Anyway, my question/request is this: it would be great if there were a setting to tell Tablo Ripper to overwrite existing recordings. Or even better:

If [episode to be ripped] already exists in [destination], then delete [episode to be ripped] from Tablo.

Hope this makes sense, and thanks for such a great utility!


If you’re getting a loop where a recording is constantly being ripped, it’ll be related to an error that occurs before the process is complete. TabloRipper only marks an episode as “not new” after it’s successfully (and completely) ripped. It’s persistent like that.

You should be able to see the problem by looking in your log file, or bypass the loop by right-clicking on the offending episode and marking it as “not new” manually.

Thanks to @djk44883 for pointing out that since I stopped TabloRipper development a while back (~3 years), it’s pointless to request new features.

1 Like

You had the “delete after ripping” option selected under “configuration”. Using the Sync option will do everything. I found this out by accident. You might want to turn that off. Tablo Tools and much better option. You can delete as a function and and part of exporting. I usually do the export then the delete separate. It also detects of their was a failure (of any kind) to save the moved show. I just wish it had audio encoding options and not just Stereo AAC LC which is lossy and degrades the audio instead of leaving it alone.

Users of Tablo Ripper shouldn’t have to “find out by accident” how to use options. @CycleJ has a Configuration Guide · cyclej/TabloRipper Wiki · GitHub.

Includes all check boxes and advanced options, Delete after ripping | AutoDelete filters


Fantastic program, Nice work! :slight_smile:

1 Like

I use Linux and installed Wine and then installed Tablo Ripper for Windows.
The program works very well for me. No complaints!

I can use avidemux to edit any files if needed. Don’t need a commercial skip program.

Great utility.


Has anyone had any issues lately? It shows a progress bar like it’s working then it just fails with no error. It’s always just worked before. I haven’t changed any settings. I’m on the latest version of Tablo Ripper. My Tablo is a 4 tuner on 2.2.38.

As always, enable logging, try a rip, disable logging and look for an error at the bottom of the log file.

If the problem isn’t obvious, let me know what the log says.