Tablo for Plex - Now available in the Plex Channel Store


#325

Same here. :frowning:

Worked great for me all night then work up this morning and getting the can’t find Tablo error. Working on applying the fix now.


#326

Fix applied and working again!

and all is right with the world again…


#327

First let me thank everyone, especially Bryan_Johnson, for their hard work on this. On my Plex server, it appears the Tablo channel is found and loading as it displays the Live TV, Shows, Sports, Live Recording, etc options. However, when I select Live TV, it tries to load then times out with the message “This channel is not responding”. I might add that selecting Recent Recordings displays 0 when there is at least one recording stored. All testing so far has been through my in house network (not remotely). Tablo responding perfectly on Roku and iPhone (same network) Since this channel is working for several of you, it is obvious the problem is on my end. Any suggestions?

Tablo Quad
Plex Server version: 1.4.3
Installed latest patch manually after deleting previous one from server
IP address inserted into IP override in settings


#328

Bryan_Johnson I installed the patched channel last night and it worked great when I tested it on my network to my Windows 10 PC and my Roku. Today at work I tried it on my work Windows 10 PC and got this message “Not enough bandwidth for any playback of this item. Cannot convert to below minimum bandwidth of 259kbps.” So I tried on my android phone and it worked fine. I also tried streaming a show from my Plex server and it works fine. Any thoughts? Thanks


#329

Brian,

Thank you so much for posting the update late last night. It cleared virtually every problem I was seeing on my Android tablet. Still seeing some problems with Windows 10, and I have not yet begun testing the new version with the Roku boxes.

SETUP:

Tablo upgraded today to 2.2.13 firmware
Tablo hardwired to gigabit access point, which connects to TP-Link C7
Plex server (Win 10) running version1.4.3.3433, hardwired to C7 (main router).
Tablet & Android phone running Android 5.0, via wifi (2.4 & 5 gHz modes)
Tablo recording at 720p, 3 mbs. Playback devices are set to the same (no transcoding)
Win 10 machines are all up to date, with most recent MS patches.
Tested on Windows using only the latest Chrome browser.
Windows machines tested in both wired and wifi modes (no differences noted)
Tablo HD has about 300 programs recorded on it.

ANDROID:
Slight hiccup on video every 4.5 to 5 seconds (of less than .5 second) when streaming either live or recorded program. Does not affect the audio, and is barely visible in most program content.

Recent programs shows programs in reverse chrono order, as expected BUT the most recently recorded program (and all titles in that series) are missing. (We record “Young & Restless” every day, and keep the last three. This was the last program recorded; none show up in the Most Recent list). If accessed via “Shows”, the Young & Restless episodes are available. It would be great if the “most recent” list showed only the last 10 or 20 programs.
[UPDATE: it appears that most recent does include the most recently recorded. Doing more testing as to why Y&R, a daytime program, is the only missing one.]

FF and REW behave correctly in Android as does the “timeline”, unlike Win 10. Timeline shows correct times (running time/total time). The “jump buttons” (-10 and +30 seconds also work correctly on the Android version.

Old channels from a previous address show up on the live screen. This is consistent with Win 10 behavior, and may be localized to my setup. Could this be cached somewhere on the Plex server? The current channels show up with the currently running programs, the old channels from former market simply show up with an icon and the station’s call sign / channel .

WINDOWS 10:

General playback is great, with only the slight hiccup as seen on Android video present. Video hiccup does not carry over to audio. (This hiccup is NOT present, in either Android or Windows for other content from the Plex Server.)

FF and REW fail, as do the jump buttons EXCEPT is the jump is a period of less than 10 second or so. Program just stops cold and attempts to restart results in being kicked back to the channel or main menu. Sometimes an error message is returned first: “There is a problem playing this item.”

Timeline shows correct running time, but total time (right hand of timeline) shows 0:03 all the time.

About 50% of the time, in Windows only, a request for any service (live, recent programs, shows) is greeted with “This Channel is not responding”

Recent show behavior is similar to that of Android. Most recent recording (and others in that series) are missing.

The “About Your Tablo” always responds with “This channel is not responding”.

Stations from my former city show up in my Live TV menu, as in Android.

Will test on Roku units tommorrow. I am very impressed with the tremendous progress you’ve made on the project and appreciate your willingness to take this on for the community. THANK YOU!

Roku units work GREAT! No problems noted at all. I second an earlier request for more date info.


#330

@jimzix, thanks for all the testing info. FYI, this plugin really only makes resource links (Tablo video playlist urls) available to plex server, and does not handle playback directly. So whatever differences in playback you may be seeing are due to plex server/client setup.

Sorry to be a downer, everyone, but I don’t have the bandwidth to properly maintain this plugin, so I won’t be able to address any feature requests, etc. I just wanted to make available the basic patch I made to the channel that corrects the outdated Tablo API URLs. Hopefully seeing so much interest in this thread will encourage @TabloTV to produce an officially supported Plex plugin!


#331

But in all seriousness, thanks so much for your efforts Bryan. Official support for this would be ideal but I have a feeling not anything that the Tablo folks will be considering any time soon.


#332

Bryan,

Thank you so much for taking it this far! Hopefully the gurus at Tablo will see the level of interest in the community for a Plex connection, and can pick up the ball!

Thank you from my wife and me.


#333

I also appreciate the help…maybe Tablo can help us along now that so many are interested…


#334

Guys, I think you’re barking up the wrong tree asking for updates to a Plex plug-in by Tablo. Try as they might, Tablo has too few people for too many app offerings. By the way, I have Plex. But I use Tablo Exporter to get my stuff from Tablo to Plex. Requires manual operator intervention to be successful, but works.


#335

@Davebhc71, not sure I agree. The Tablo app on Plex is no different then an app on AppleTV, iPhone, Android or even an LG TV. It’s just one more avenue for users to enjoy using the Tablo device and enjoy the “TV Anywhere” experience. With that said I do agree that there is extermely little chance they will support it unfortunately.

Along those lines I am doing the same thing as you (extracting my Tablo content to my Plex media server) with the SurLaTablo script. It works but it would be so much better to just simply not have to worry about it and be able to just browse Tablo content and watch it from the unit where its recorded. Then if you like it and want to keep you can always use an application to copy it to your Plex for long term enjoyment.

Just my $.02.


#336

Guys, i’m really sorry I haven’t had time to work on this but life is busy when you have a ton of kids and honestly I’ve invested in LG TVs that are fully supported with Tablo so I have less incentive. I open source the whole thing though so that it could be collaborated on and future people could make fixes. I’m glad to see that someone is working on it all they need to do is push those changes back into my repo and I can push them to plex


#337

Thanks so much @Davidvr for doing this in the first place and giving us a toehold! I’ve submitted PRs to both your repo and the Plex “official”.


#338

Plex has merged my fixes into the “official” channel - anyone who has installed the patch manually can now safely remove it and install via the plex channel store.


#339

I will have to try this out.


#340

Still cannot get beyond the 6 option buttons dialog, with PLEX giving me the “This channel not responding” message after clicking Live TV. Looking at the Plex tablo log, it appears that it is downloading the channel ID’s (a series of 6 digit numbers separated by commas, and then a long body of un-decipherable characters, but I never get any channel listings on the screen.

Any help or direction would be appreciated… I really want this to work! Also, does Tablo require JAVA to be installed? Thanks in advance!


#341

Patch version worked great on my Apple TV, Roku’s and iPhone / iPad, for live TV and for all show types. Did not work on Browsers running Plex for Live TV, but that was ok because I did not watch much TV on a browser. Just installed the Official Version and works exactly the same. Absolutely AWESOME!!!

Thank you all very much for all your effort and personal time!


#342

Bryan_Johnson I uninstalled your Tablo channel and installed the PLEX version. The PLEX version works within my home network but will not connect outside of my home network. So I uninstalled the PLEX version and reinstalled yours and it works Inside and outside my home network. For now I’m staying with yours. Thanks


#343

Bryan -Yup, uninstalled patch, installed ‘official’ channel and BINGO. Connected instantly. Thanks so much for all your efforts!!!


#344

Bryan- got home to the main server and installed new Channel and wow–works great so far- Thanks for all your help