Tablo for Plex - Now available in the Plex Channel Store


#285

You are right too it would be great to see Tablo themselves make a plugin for Plex. If they did I would hope they would do a better looking one though :slight_smile:


#286

I had started researching this option before that update was posted. I did not check again last night before purchasing.

If the ripper is still working - and I can still stream from the DVR to the various clients in my house (and that works well) - then I may still keep it. It’s too late to cancel it, anyway, so I can play around with it before deciding whether to return it.


#287

Very true. I have a first gen iPad that can’t run the tablo app, but it can run Plex - and sure enough using the Tablo for Plex channel in the past I’ve been able to fire up live TV on the iPad. It kind of felt like a hack, but it worked. I second the vote for an “official” Tablo for Plex channel.


#288

Looks like the original developer has moved on. I’ve submitted basic fixes to match the updated Tablo API to get this channel working again- hopefully plex will accept the fix shortly. If you’d like to install manually, you can access the patched bundle here: https://github.com/dbjohnson/Tablo.bundle


#289

Thank you so much Bryan_Johnson for your hard work! I can’t wait to try this out!


#290

That’s awesome! I’ll give it a try tomorrow! Thanks a lot!


#291

Thanks, Bryan…will try it out on Monday or Tuesday.


#292

Thanks- I will try it out in the AM


#293

No flames please but does someone have a step by step on how to install this manually?


#294

Here you go @Spunky03. This link will walk you through it.

https://support.plex.tv/hc/en-us/articles/201187656-How-do-I-manually-install-a-channel-


#295

Got it and thanks. That will teach me to check my Google searches better. Caught by my own fat finger, ugh…

Anyway, I got the app installed but it’s giving me an error saying that it can’t find my Tablo unit. Screen capture of error below.

This is installed on Plex Media Server 1.3.4.3285 running as a plugin on a FreeNAS box. Plex, FreeNAS and Tablo are all on the same class C subnet.


#296

Have the same response on my Plex…Will keep checking…


#297

@Spunky03 and @road3682, try setting your Tablo IP address manually in the plex web interface: click the gear icon below the channel, or at the top right of the channel’s main page.


#298

I should have mentioned that in my post. I tried that. I get the same error if the IP is specified or not.


#299

What does this return? https://api.tablotv.com/assocserver/getipinfo/


#300

I lot of really personal stuff that I don’t want to post on a public forum so I’ve sanitized the information below. Needless to say though it gives me the IP that my DHCP server assigned to my Tablo and the IP that I am putting in the app config.

{“cpes”: [{“http”: null, “public_ip”: “my public IP”, “ssl”: null, “host”: “tablo-quad”, “private_ip”: “192.168.1.101”, “slip”: null, “serverid”: “my tablo ID”, “inserted”: “2016-03-22 00:46:36.043533+00:00”, “server_version”: “2.2.12rc1629814”, “name”: “My Tablo Name”, “modified”: “2017-03-13 18:18:45.100234+00:00”, “roku”: null, “board”: “quad”, “last_seen”: “2017-03-13 18:18:45.096743+00:00”}], “success”: true}


#301

Yep, just wanted to make sure that endpoint was reporting health - thanks for sanitizing. Okay, I’ll have to take a further look when I get home tonight. If you get a chance and are okay with sharing, please pull the plugin logfile (com.plexapp.plugins.tablo.log) and PM to me.

Thanks,
Bryan


#302

PM sent.


#303

@Bryan_Johnson - Thanks for working on this! Very much appreciated :thumbsup:


#304

I’ve been chatting with @Bryan_Johnson and might have a solution. Stay tuned.