Tablo Exporter - Export Tablo Recordings


#911

It is something we did not know they did in the API, the URL for watching is only cached for a certain amount of time. I need to go back and make some changes. Give me a bit of time


#912

Ok http://jettsoft.com/test/tabloexporter.zip has been updated to get the URL only when you pick to record. Hopefully this should fix issues with the URL timing out


#913

Cool thanks… Ill give it a try.


#914

ignore


#915

I need some help getting this installed. Not sure what I’ve done wrong. Installing under macOS Sierra 10.12.6 in a Fusion VM. Downloaded Tablo Exporter yesterday (2017-07-24) to have the most current. Downloaded ffmpeg-863838-gdd4b7ba yesterday as a .dmg file. And download Oracle Java jdk-8u141.dmg

Ran the Java installer, everything looked good. Drag copied the ffmpeg file to a directory and unzipped Tablo Exporter. Either double-clicking in the finder or from the terminal gives me an error and nothing happens. Don’t know where to go from here. Have included an excerpt of the log file from the terminal invocation. It wouldn’t let me post the compete log or upload it.

Thanks for any help!

— Begin excerpt of Logfile “hs_err_pid1805.log”

–#
–# A fatal error has been detected by the Java Runtime Environment:
–#
–# SIGSEGV (0xb) at pc=0x00007fffa0c01c3d, pid=1805, tid=0x0000000000004703
–#
–# JRE version: Java™ SE Runtime Environment (8.0_141-b15) (build 1.8.0_141-b15)
–# Java VM: Java HotSpot™ 64-Bit Server VM (25.141-b15 mixed mode bsd-amd64 compressed oops)
–# Problematic frame:
–# C [libGL.dylib+0x1c3d] glGetString+0x1c
–#
–# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try “ulimit -c unlimited” before starting Java again
–#
–# If you would like to submit a bug report, please visit:
–# http://bugreport.java.com/bugreport/crash.jsp
–# The crash happened outside the Java Virtual Machine in native code.
–# See problematic frame for where to report the bug.
–#

--------------- S Y S T E M ---------------

OS:Bsduname:Darwin 16.7.0 Darwin Kernel Version 16.7.0: Thu Jun 15 17:36:27 PDT 2017; root:xnu-3789.70.16~2/RELEASE_X86_64 x86_64
rlimit: STACK 8192k, CORE 0k, NPROC 266, NOFILE 10240, AS infinity
load average:3.71 2.37 2.21

CPU:total 2 (initial active 2) (1 cores per cpu, 1 threads per core) family 6 model 69 stepping 1, cmov, cx8, fxsr, mmx, sse, sse2, sse3, ssse3, sse4.1, sse4.2, popcnt, avx, avx2, aes, clmul, erms, lzcnt, tsc, tscinvbit, bmi1, bmi2

Memory: 4k page, physical 2097152k(21980k free)

/proc/meminfo:

vm_info: Java HotSpot™ 64-Bit Server VM (25.141-b15) for bsd-amd64 JRE (1.8.0_141-b15), built on Jul 12 2017 04:35:23 by “java_re” with gcc 4.2.1 (Based on Apple Inc. build 5658) (LLVM build 2336.11.00)

time: Tue Jul 25 04:28:05 2017
elapsed time: 1 seconds (0d 0h 0m 1s)


#916

You need to install ffmpeg

A lot of people make the mistake of just getting the source. You need an already compiled ffmpeg for mac


#917

Thanks for the help! Already had the compiled ffmpeg. Not sure why it wouldn’t work. Gave up getting it to work on under macOS. Spun up a new Ubuntu Zesty VM and had it working in no time!


#918

Oh wow, only issue I know for sure was that Java that comes with MacOS is not the Java that will work.

But glad you got it working


#919

I’ve had this working in the past with ubuntu. Have done some major upgrades, new pc, etc. Now cannot get this to run. I am runing on Ubuntu 16.04.3, with openJDK 8. Here is the error I receive:

$ java -jar TabloExport.jar
Error: Could not find or load main class tabloexport.TabloExport


#920

You have to give the full path to the jar file


#921

Oh and OpenJDK does not work well with this


#922

Same error with full path. I’ll try Oracle…

Oracle Java 8 worky!


#923

I had a power outage during a recording, now even though the recordings after are there and complete I cannot extract them. Besides reformatting the entire hard drive is there anything I can do?

Log:

Loading Data for UzupisTablo (Firmware Version: 2.2.16 build: 1717113) (Model: Dual tuner)
Opened database successfully
Total Shows: 86
Time in seconds: 0 seconds.
Time in minutes: 0 minutes.
Time in hours: 0 hours.
DB Connection Closed!
Done Loading Data for UzupisTablo (Firmware Version: 2.2.16 build: 1717113) (Model: Dual tuner)
Tablo : UzupisTablo (Firmware Version: 2.2.16 build: 1717113) (Model: Dual tuner) - 192.168.0.188 - 800903
http://192.168.0.188:80/stream/pl.m3u8?Gz18z7y6_Q-KpOumVTmHTg - The Voyager With Josh Garcia - Episode 6 - Alaskan Gold.mp4 - OS Mac OS X
Start Time:3:00:05 EDT PM
Unable to create directory structure!
Canceled Processing!
End Time:3:00:05 EDT PM
Total minutes processed 0
Not Completed!


#924

Gave up and reformatted drive. Lost 5 shows that I couldn’t extract but didn’t want to lose more by leaving it as is.


#925

Hello, I’m trying to use TabloExporter, getting a “failed” error on both OS X 10.11 and Windows 10, Tablo is running on a ShieldTV. Here is the terminal output:

Java Version; 9.0.1
Tablo Exporter Version 0.07a build 129

Request packet sent to: 255.255.255.255 (DEFAULT)
Done looping over all network interfaces. Now waiting for a reply!
Tablo Info - Name: Tablo (192.168.1.193) - Firmware Version: 2.2.16 build: 1722913 - Model: Dual tuner
Timeout reached During Discovery!!! All good!
Loading Data for Tablo (Firmware Version: 2.2.16 build: 1722913) (Model: Dual tuner)
Opened database successfully
Created Table Recordings!
Total Shows: 46
Time in seconds: 8 seconds.
Time in minutes: 0 minutes.
Time in hours: 0 hours.
DB Connection Closed!
Done Loading Data for Tablo (Firmware Version: 2.2.16 build: 1722913) (Model: Dual tuner)
2017-11-18 13:26:00.213 java[19012:609647] Ignoring request from Finder Sync Extension to register for file:///Library/
2017-11-18 13:26:00.233 java[19012:609647] Ignoring request from Finder Sync Extension to register for file:///System/
Tablo : Tablo (Firmware Version: 2.2.16 build: 1722913) (Model: Dual tuner) - 192.168.1.193 - 10033
file:///data/user/0/com.nuvyyo.engine/tablo/int/rec/10033/segs/rec.ts - ********************.mp4 - OS Mac OS X
Start Time:1:27:34 PM EST
Error code received was 1
End Time:1:27:34 PM EST
Total minutes processed 0
Not Completed!

Any Suggestions?

Thanks,
-Chris


#926

I have never seen those errors. But, it looks as though you are using Tablo Engine? If so, we need to ask @TabloSupport if this would even be supported for Engine


#927

Hey Chris, I got a response from Tablo Support, it is not supported for these tools currently.


#928

You know, since Tablo Engine (not the streaming Tablos) records to straight ts files on accessible media, you can just pull the files yourself and concatenate them. Up to you if you want to transcode afterwards. Just saying.

We (tool guys) had to write programs to help because the files on the streaming devices aren’t (easily) accessible.


#929

Thanks for the response and follow up. Not a surprise. Here is what I had just prepared to reply:

__
I’m guessing you are right, export may not be supported with Tablo Engine. I also tried TabloRipper with no success, spending way too much time in the whole process.

Combined with still being in Beta after announcing their Live TV rollout and still no manual recording option, this convinced me to uninstall Tablo Engine and use Plex, which finally seems to work and seems to use storage that is not locked in a proprietary, inaccessible directory.

Tablo has a nice interface, but locking away my recordings is a deal breaker for me.
__

At least, I’ve not figured out how to access the files. On Shield TV, they seem to be hidden within the Tablo Engine app, and uninstalling/reinstalling the app deletes all of the recordings…

Thanks again,
-Chris


#930

I just assume that might be a big enough hint. Still could be somewhat cryptic to figure out. So maybe this is still a bit too painful for the average user.