Tablo Exporter - Export Tablo Recordings


#871

Thanks. I figured it out after I posted. I saw someone else’s comment about re-installing and I tried that and it worked. Though I had to wait forever for the dvr to load of course. :slight_smile:

Thanks for your help!


#872

Quick update in case this is affecting others. I have been migrating a lot of content over to Plex via Tablo Exporter. I have had several instances where all downloads start to fail. So far, the fix (other than a re-install) is to delete the .db file. Of course, that file plays a large part in shortening the load time for the java app so I have to wait for a long load when I do that. But am usually able to download recordings again once I have done so. Since i’m moving a lot of content and deleting it off the dvr once downloaded I imagine there is a correlation. Just FYI for others and perhaps maybe there is a code tweak that can fix that. Or maybe a smaller tweak I can make? I can try running in debug mode next time as well.


#873

How often are you seeing this?


#874

I did update to cleanup the DB file so give the new version a shot, see if that helps with your issue.

I am assuming you have a ton of recordings


#875

ok I’ll give it a go. And yes, I have a ton of recordings. Just upped the space on my plex server so have been moving a bunch over and have been experiencing this at least once per day over the last few days. Finishing up one now but i’ll try the new version out with next set of of downloads. Thank you!


#876

Hey Jestep. Just a quick update that so far, so good. Whatever change you made to the db file seems to have done it. At a minimum, this is the farthest i’ve gotten without an issue so if I do encounter one it’s still an improvement. Thanks as always for making this tool. It’s mega useful!


#877

Did you install the test version or regular version?


#878

I believe it’s the regular version. It’s the one on Jestep’s product page.


#879

Both the test and current version are currently the same so wouldn’t matter right now :wink:


#880

That seemed to help. I was getting an error with A Charlie Brown Christmas for some reason. Now it worked flawlessly.

It still takes awhile to load the recordings though.


#881

What speed PC do you have? That is the only thing I can think of or maybe hard drive speed?

Did you run debug mode? It should spit out some info on the DB work


#882

FYI, I spoke too soon on this. I still get the issue where recordings suddenly fail. In at least some cases I have figured out it may be due to a guide sync or running into a time period with a block of recordings happening so my tuners are busy. But others are difficult to determine. It has happening less now than it was. FYI mostly. I’m managing through it.


#883

I just had a bunch of recordings fail last night. I deleted the database file and opened it up again. That fixed it. I didn’t run any logs.


#884

Busy tuners don’t make any sense as an issue as the Export does not use the tuners. However, when the Tablo is busy it will slow things way down. Maybe that is an issue … Hmmm.


#885

Yea, that makes no sense either, the DB just holds the recordings to allow it to load faster.

I am wondering if your Tablo was really busy when it happened?


#886

Newbie here, also on a Mac (Yosemite)…I’ve got everything set up to where tomkali was here, in 2015, no errors so far, pointing at the dl’d ffmpeg file, output folder, etc. In my case, I’m administering (and watching) the Tablo through the web interface (using Chrome) from a Mac on the same network, connected via ethernet. The Tablo itself is plugged directly into my router (and has been working fine for the week that I’ve had it).

My problem: Exporter seems to see the Tablo on my network, but doesn’t display any recorded programs (I know there are a few, at least). I’ve quit and launched a few times, but nothing’s getting populated. I even tried putting ffmpeg in the same directory as Exporter. Still no love. Any suggestions?


#887

False alarm! Sorry, Jestep. When I posted this as a reply to tomkali’s thread, I somehow (mysteriously?) didn’t see the entire year’s worth of other comments on the same thread…until I hit Reply. Then I started reading further, and found others with the same issue…all’s working (list getting populated) now. All I needed to do, apparently, was double-click the 2nd line beneath ‘My Tablos’…sheesh, thought I’d done that earlier. As others have said, thanks so much for coding this utility!


#888

I am running the .jar on Ubuntu 16.04, with oracle java. I am having problems with many videos failing to export. It appears to start, then a few seconds later, I get a “Failed!” status. I have tried several different shows/movies, and cannot seem to find a pattern. Is there an error log to investigate?

I ran via command line:

“java -verbose -jar TabloExport.jar”

The output when I selected one particular movies was:

[Loaded sun.reflect.GeneratedMethodAccessor9 from __JVM_DefineClass__]

[Loaded sun.reflect.GeneratedMethodAccessor10 from JVM_DefineClass]
[Loaded sun.reflect.GeneratedMethodAccessor11 from JVM_DefineClass]
[Loaded sun.reflect.GeneratedMethodAccessor12 from JVM_DefineClass]
[Loaded sun.reflect.GeneratedMethodAccessor13 from JVM_DefineClass]
[Loaded sun.reflect.GeneratedMethodAccessor14 from JVM_DefineClass]
http://192.168.0.28:80/stream/pl.m3u8?RGf9ugfZi48XqWxQaLrqDQ - You Know My Name - 20161015 600 PM.mp4 - OS Linux
Start Time:10:28:29 AM CST
Error code received was 1
End Time:10:28:34 AM CST
Total minutes processed 0
Not Completed!


#889

Hi. I really rely on Tablo Exporter and am running the latest 7a from the website. (Windows 7) I decided to archive a bunch of recordings from my Tablo and it’s weird. None of my recordings prior to 2017 will download. They all fail. (They do come up in the gui list though.) The older shows do play fine on the Roku and my phone.

I don’t know if this is related to the current Chrome issue I’m having where I don’t see my older recordings when I use the web browser. I rarely watch on the computer so I haven’t researched that one.


#890

I wondered if this was related to my problem. So I started queuing shows/movies. It appears that I cannot export anything prior to 12/22/2016. A few programs from the 22nd would export, but most would not. Everything I’ve tried on the 23rd and after does export. Nothing I’ve tried prior to the 22nd will export. Granted, I have not tried every show.