Tablo App keeps shutting down while watching

The buffering on the 1080p box makes a little sense. I believe those can only connect to 2.4ghz networks. Are your Tablo and other Rokus connected to 5ghz or 2.4ghz?

I just purchased my 4th Gen this past weekend and have been having the same problem with live TV. Can only watch for a few minutes before Tablo kicks out

The Roku TV and cheap Roku are on 2.4, but the 4k is hard wired and it’s as bad as anything. The pixel has this happen a bit. I just pause it once for a second and the problem goes away.

I’m now starting to see Roku Tablo App crashes on my Gen4 Tablo too.

I’m using a Roku Ultra 4802X with Roku firmware 12.5.0 Building 4178-C2. Tablo App is Ver 0.8.300 and the Tablo Firmware is 2.2.47.

The Tablo App crashes occur while watching live TV and appear to be randomly happening (in my case) and are not a set time like others have reported. But the result is the same - the Tablo is now unwatchable!

My guess is this problem is a result of the Roku 12.5.0 Firmware change and the Tablo App is not working well with this new firmware. As I have stated many times, the Roku 12.5.0 firmware upgrade has created lots of problems. And it looks like it’s getting worst based on the number of folks posting about it.

So let’s hope the Tablo Software Team can get tis figured out and issue an update… the sooner the better…!

I was having the same issue and read someone’s comment referencing their USB memory stick. I removed the USB memory stick, restarted the TV and Tablo app is now working properly on my Google TV.

It looks like Tablo rolled back the Tablo 4th gen app on Roku and I can watch Live TV again. Glad the Tablo team was quick to take action. It would be nice if they setup beta testers as I wouldn’t mind test on one of my two 4670s.

I been having the same problem as everyone else with the Roku product and Gen 4. Works fine on a android phone and tablet, I have an open ticket and was told they are going to release a firmware update soon but did not give a date. Currently the device is just unusable with my three Roku streaming media, and it does seem the Ultra Roku has the most problems maybe just because it is used the most.

Welcome @Knox

My new 4th gen 2 tuner closes out every so often. Sometimes it will happen as I scroll through the guide and sometimes it happens in the middle of watching a show. It happens on different TVs with both old firestick and brand new firestick so I rebooted everything but it still happens. I’ve noticed that it doesn’t matter if recording is going on or not. Can’t seem to figure out what causes it. When it is about to happen everything seems to slow down and get choppy as if it’s having some type of processor or memory issue with the Tablo and then everything freezes and the screen goes black for about 10 seconds and then the Tablo blue screen comes back on and I can go back to watching the show or ota program again.

I know everyone here is talking about Roku and Tablo but it’s not just happening on Roku. I have an old and new 4K firesticks and have had similar problems. Last night my Tablo 4th gen 2 tuner lost connectivity from all devices. I checked my internet and it was 750Mbps download and upload. Every other app worked fine. I was just watching H&I channel and it got choppy and then went out. I checked my antenna directly from the tv and all ota channels were working fine so I went back to see what was going on with my Tablo. I have no external hd yet (that’s coming soon), so just using internal memory.

I rebooted and after restarting, Tablo app on my iPhone couldn’t find the device at all from iPhone or firesticks. I rebooted my phone and the firesticks but didn’t help.

I unplugged Tablo next and waited a couple of minutes and still no Tablo device. I rebooted a third time and my old 4k firestick found the Tablo device and it took a couple more minutes and my iphone finally found it also.

I still think there’s an issue where Bluetooth stability is triggering something within the Tablo viewing app.

If I don’t use the remote for a while I think it goes into sleep mode and the app reboots. If I pick up another device’s Bluetooth remote, sometimes that will cause the reboot. (Which for me is usually an app restart, and another restart when I press a button on the viewing device’s remote!)

I have this issue on my AndroidTV, FireTV, and Firestick app. I don’t use the Roku version enough to know if the same thing happens with it.

I haven’t found a solid solution to this issue yet, but the less devices I have on (including Bluetooth speakers, TVs, etc) the fewer the issues. (2 hours of viewing today and not a single app restart yet… just me, my TV, and my laptop.)

I think that the 1.1.1 version had a lot more stability when it comes to app reboots, but since I believe something in the emergency Android 1.1.2 fix has triggered this issue again.

This has been going on all day, and 4 times in the last ten minutes (make that 5). As of right now, I can only speak for the AndroidTV version since FireOS has not offered a 1.1.2 upgrade.

Maybe it would help to let you know that if this occurs while watching a recording and doing NOTHING else, the picture will freeze, and the contrast seems to jump up by about double. Then the app reboots – usually twice if I try to use the remote within a few seconds of the first restart.

Edit: It seems like there are nonstop buffering issues as well. (Tablo is on 5g as is the TV.)
Edit: I can’t guarantee the Tablo is on the 5g since I can’t split the SSID. But the TV definitely is.

To summarize the 50 previous entries it would appear Gen 4 owners hosting their TABLO on either Roku or fire stick all have the same problem, in most cases while watching either live OTA or FAST channels and that support is aware of the problem and are working on it. Presumably some Gen 4 owners must be happy with their boxes so it leads me to believe that a number of us have received bad units. I too have submitted a problem report to Tablo over a week ago and have heard nothing. The solution to all this, I’m going to return my Gen 4 for either a refund or exchange, haven’t quite decided yet and revert to my old ChannelMaster unit.

1 Like


This issue only seems to have started after I added an external HD (generic housing HDD, WDCaviar 500GB).

1st day ownership, set everything up per instructions, no issue

2nd day of ownership, add external HD via USB, no issues

3rd day of ownership, first day of problems at lunch
In the morning, when I turned on the tv/roku/tablo, I was able to watch my morning news just fine. Turned off the TV (SAMSUNG), went to work and came back at lunch to find Tablo crashing back to the Roku screen. Tablo had been working great on tablet while at work, working fine on phone, crashing on TV. Turned off external HD on housing, hard reset Roku, everything works.

4th day of ownership, same problems at lunch
Again, everything works in the morning, recordings still going to internal HD. Using Tablo on my tablet working while at work, working on phone, at lunch I turned on TV/Roku/Tablo → crash.

Try to hard reset Roku, unplug Tablo for 10min+ … unplugged usb HD from Tablo… plug Tablo back in, set back up Roku, add Tablo, start Tablo… crashes back to Roku after < 10s


I am NOT going to try to record anything and see if I am still operational at lunch tomorrow. If I can maintain a normal operation for a week, I will try to record to the device again. If that continues to be stable I will then attempt to connect an external HD again, if that fails, then I think we know a possible culprit - EXTERNAL STORAGE SOMEHOW AFFECTING NORMAL OPERATIONS

When it’s not working on the Roku, does everything still work on the tablet?

Kinda random questions, but maybe helpful: Are you exiting the Tablo app when turning off your TV, or continuing to let live TV stream? Also, do you have the power setting turned off for “data saver” or whatever it’s called so it stops streaming after 4 hours?

You have very good descriptions of what’s going on and how you’ve been trying to problem solve them.

The Roku app is buggy in general right now, but there’s hope of a new version right after the new year (it was postponed due to Roku’s time constraints.) You’re using a rolled-back version that was known to have issues. Continue trying other devices (Android/Fire/Phone) and see how things compare.

RE: When it’s not working on the Roku, does everything still work on the tablet?

FLAWLESSLY In fact, I was looking through the settings on my phone (iPhone12Pro), while watching the Tablo tablet(iPad Pro) app, screen shared to my TV (Samsung) and not through Roku while reading this thread on day two.

RE: Are you exiting the Tablo app when turning off your TV

I would just hit the power button on the Roku remote (no exiting or closing of anything, just red button power) as it turns on/off the TV now.

RE: Also, do you have the power setting turned off for “Data saver” or whatever

4 hour data saver is “On” - However, I turned off the Samsung at 11PM via the Roku remote pwr and then back on in the same manner the following 6:15AM → Roku App Boots → Select Tablo App → choose my channel, without issue, turning it off at 7:00AM and turning it back on at 12:15 where it would have todays crashing issue. That’s a 7 and 5 hr gap respectively. During the 5hr gap, I was using the Tablo app on the tablet almost the entire time.

I appreciate your quick response/questions/additional information. I’ll update my post as I find my results.

Okay. Let us know what’s going on. Maybe quitting the Roku’s Tablo app in the future might help with stability.

Thank you for your quick reply!

I originally connected an old external 500GB seagate drive initially to my Tablo and had similar issues and I contacted support and they made it clear that the 4th gen Tablo works with 1TB minimum only. The Tablo initially even recognized my 500GB drive but after formatting Tablo didn’t work properly with the drive attached and had all kinds of weird stuff happening with that drive attached. I wound up disconnecting the drive and picked up a 2TB drive and that has worked since.

Thank you for this update/info. At least we tried to reuse what we had.

@SmackyTheFrog - I knew there was chance it wouldn’t work but figured why not give it try since I have 2 - 500GB drives and 2 - 750GB drive that I’ve used for years and so reliable but not for use with Tablo. Good luck and Have a happy new year!

Same thing with mine ugh

I’m having the same problem on 4th Gen. I’m still within my month return window. We like so many features on it but there are some shortcomings.

We are going to continue to use it a lot this month and decide if we want to keep it.

Anyway, yeah, I have a new Roku streambar - still a problem: very frustrating.

Let me if anyone has any suggestions.