Tablo App keeps shutting down while watching

Good question! From the few that have commented with this problem, everyone has been using the Roku 4670X. You don’t have issues with the 4660X and I’ve used a Roku 4802X without any problems either.

To add more mystery to this problem, I just realized that I have one TV using a Roku 4670X that IS working normally on the Gen4 Tablo app. This Roku is connected to a newer Samsung 4K TV which is located in a bedroom and is used infrequently.

For all the TV’s that I have the Roku 4670X on, I have them all Ethernet connected and they are all using the 12.5.0 Build 4178-46 firmware. The only difference is that the TV’s that have the Tablo app crashing are on older TV models.

1 Like

Just received a Tablo firmware update and the issue appears to be fixed. Tried watching live on one of my two Roku Ultras 4670 12.5.0 that was kicking me out after 3 or so minutes and the problem is no more. Watched live TV for about 30min without any issues. I’ll be testing my second Roku Ultra later this evening. The Tablo firmware updated to 2.2.47. It was a 3 step update that didn’t require me to do anything but launch Tablo from the Roku Ultra and it automatically started the update. Took about 3min to run and all is good. Let me know if anyone else with this issue received the update and if it resolved your problem.

Great to hear! I’ll be able to test my setup later this weekend.


Last night, I upgraded my 4thGen Tablo (up to this date, a paperweight) to Tablo firmware 2.2.47. I was not expecting much, since the upgrade said it was a “hotfix for WiFi setup”. I thought “meh” but what the hell…

My Roku Ultra 4670X 12.5.0 can now stream OTA channels for more than 3.5 minutes! Wahoo!

I’ve tested it streaming a 1080 OTA channel (Kelly Clarkson Show) for almost an hour, no issues…

While crossing my fingers, toes, and other appendages - I factory reset the 4th Gen, installed the 2TB Seagate USB drive, did the stupid “scan for channels, delete all but one FAST channel, save it, let it update the guide, contemplate its navel, rescan the channels, add the OTA and FAST channels I really want” malarkey.

And the little white puck seems to be behaving.

I still don’t “trust” it yet, need more testing time. And I’ll stay nervous until the 4thGen Tablo App on Roku gets another upgrade (a version number less than 1 is unsettling, feels like Beta.) And I’ll also be on eggshells the next time Roku rolls out an OS upgrade.

But I hope this brings you “tidings of great joy” for this weekend.

Party on, Tablo users! Cutting that cord is so refreshing…

1 Like

I reinstalled my Gen4 Tablo and updated to the 2.2.47 Firmware. I can verify that Roku Tablo App is now working properly on my Roku 4670X. Thank you Tablo Engineering for fixing this bug!

Jsut joining the thread because I just started having the issue of Tablo crashing after 3 minutes of OTA live TV.

I have a 4th gen Tablo running through my Roku Streaming stick and it worked great for the first 3 weeks I had it running. Then tonight I added a new Roku Express to an older TV and connected it to my Roku account. The new setup did not work well (latency and pixalation issues) and as i started going back and forth between my original (previously working) setup ane the new one, the original setup startes have the 3 minute crash issue.

I’ve read through this and a couple other threads and dont know what to do. My roku firmware is 12.5.0 and the Tablo is 2.2.47. I don’t have much time to troubleshoot and I’m super frustrated to have a working system that now crashes. Perhaps its a coincidence that it startes when it added the new Express, but it worked fine last night. Ive since removed the Express and am just trying to get back to where i was. Thanks to anyone who has thoughts.

Brownmc - Sorry to hear your having this issue with the Tablo Roku App crashing after 3 minutes of viewing. The new Roku 12.5.0 firmware has caused all kinds of problems and my guess is the Tablo Roku App is just not playing well with it. When I updated the Tablo firmware to 2.2.47 it fixed it for me and it continues to run fine.

The only issue I’m having is with a brand new Roku Ultra LT. The unit causes my HDMI Arc to stop working on my TV so my sound bar doesn’t work. This is a Roku issue not a Tablo issue. But it’s another example of how the new 12.5.0 firmware is causing problems. I switched back to my original Roku Ultra and the soundbar works.

Like others have done, you could pickup up a Firestick as one way to get past this issue and just wait until more firmware updates come out for Roku/Tablo to make the Tablo Roku App more stable.

Brownmc: I see that Tablo has released updated Roku App (Ver 0.8.3). Try the update and let us know if that fixes the Tablo Roku App crashing after 3 minutes of viewing problem.

I have Tablo Firmware 2.2.42.
I just checked for a firmware update, and it says that the Tablo firmware is up to date.
How did you get 2.2.47?

Thanks, gatorgogo. The Roku App (Ver 0.8 Build 300) is what I have been using. Still 3 minute crashing.

Cliqueofone, I’m not sure why, but when I got to the Tablo App on my phone under settings is says “2.2.47”

Mine was working fine until late 12/5/2023. Drops out after just a couple minutes since then……I have tried everything I have researched here etc….,funny thing working right now on my iPhone…iPad etc but not on Roku Tv, Sony TV nor Samsung TV.

Update…….works fine on iPhone iPad Pro and my Google Tv………got to be a problem with Roku Tv (fairly new TVs)

This just started today for me. Roku ultra newest version 4800x12.5.0 build. Tablo is up to date also. What us the fix?

Back again with issues. I had posted a month ago I was experiencing problems with my two Roku 4670RW units and then 29 days ago I posted that the update by Tablo fixed the 3 min crash out of the Tablo app. Now there have been more updates and I’m getting kicked out of the Tablo app on the Roku again after watching live TV for 8 to 9 min. It appears the Roku units have been updated from 12.5.0 build 4175-46 to build 4178-46. The Tablo version remains the same one that was updated 27 days ago at firmware 2.2.47. I don’t know if I should be mad at Roku for pushing these updates that break Tablo or for the Tablo app that isn’t able to handle the Roku app updates. I’m at a loss with this craziness of it works for a month then it’s down for a month, works again for another month then it’s down again.

1 Like

My Roku Ultra 4670X is running 12.5.0 Build 4178-46. I also updated the Tablo Roku App to the 0.8.3 and the Tablo Firmware is 2.2.47 So far the Tablo App continues to run properly for me (for now).

As reported earlier, if you Google “Roku 12.5.0 Problems” there are lots of other systems with problems. I saw one post showing that Users of the Plex App are reporting similar problems with the App crashing when displaying live TV. So it’s not just Tablo having problems.

Apparently the Plex Software Team just released a Plex “Preview” App that Users have reported fixes the Plex App crashing problem.

The Tablo Software Team might want to look closer at what was done to the Plex “Preview” App that fixed the problem.

1 Like

Same issue here. Started yesterday, 12/6. App closes after about 1 minute of live tv. tried, smart android tv, smark roku tv, roku stick plus, older roku le. all up to date. restrted all devices, factory reset tablo. nothing. Live tv only works on my android phone (tested for 30 minutes). Tech supposrt hasn’t returned my call yet. (looks like hours changed today , were 8:30 am to 2 am, now 9:30 am to 5:30 pm). although website still states 8-2. Loosing faith in tablo as a reliable company.

I just got the new Tablo as well 3 days ago and having the same issues with live TV cutting off and returning to the home screen. I contacted Tablo support and they are working on a fix, but who knows how long this is going to take …
I am going back to my old Tablo unit until they can fix this issue.
Roku 4800X 12.5.0 4178-C2

Not holding my breath for a fix. I just ordered a fire stick 4k, hopefully tablo will work with that.

Just started having this problem a few days ago bought my new 4th a few weeks ago. My old tablo is not having any problems.

Also a friend had just purchased the 4th gen as and just started acting up a few days ago.

Both are using external hard drive for additional storage, and roku for access to the table app.

4th gen Tablo is crashing when used with the Roku app. It’s happening on every Roku device I own. There are other minor things like it seems to have a buffering problem. I have to hit pause and wait or it keeps going on a play pause cycle. I removed my external storage to see if that helps. Factory reset. Rebooted my router. We have a Roku TV a Roku ultra 4k, and one of the cheap 1080p boxes. The picture starts to get pixelated and it then crashes the Roku. Some times it happens when I hit a button on the controller. No problems on my Pixel 8 so far. That app works. Seems to be Roku specific. Wasn’t a problem last weekend so something changed in the on last update. Hope they fix this because I want my DVR back.