Tablo App keeps randomly exiting back to Roku home screen

Tablo App on Roku keeps randomly exiting back to Roku home menu when navigating in the app. Not a problem during play back or watching live. This seemed to start after the last update. I have tried restarting the Roku and Tablo. This happens daily. This frequently happens when a episode ends and I try to select the next episode. I always seems to work OK after it exits and I go back in and try the same thing that caused it to exit.
Serial # LD-B065478
Firmware 2.2.38
Roku Model 4630X
Roku Channel Version 2.17.0

You will need to roll back the firmware to the previous version (2.2.36) to resolve this problem.
The method may be posted somewhere on this forum (I haven’t personally seen it) or you may need to contact Tablo support and they can access your unit and roll it back for you.

This issue is not caused by the .38 firmware, it is the Roku OS update to 10.5 that caused it. Immediately after the Roku update to 10.5 while still on the .36 firmware it started happening, thus nothing to do with the new Tablo firmware. Can you please tell me how to rollback the Roku OS and prevent it from updating?

3 Likes

You had mentioned that your issue started to occur after the last update and also specified 2.2.38.
It was a reasonable assumption that you were referring to the last Tablo update, not the last Roku update. You weren’t specific about this in your OP.
There have been various problems mentioned here that occurred after others updated to 2.2.38.
I’m not having this particular problem but it’s possible that it could vary depending upon the specific Roku model (as mine is different).
Unfortunately, I can’t advise you as to how to roll back the Roku.
If this is a possibility, there should be further guidance online (unless someone here is familiar with the process).

Weird Roku issues can often be addressed by clearing the Roku cache. There are several websites and videos available to show you multiple ways to do it but the easiest is when the Roku is powered on and on the home screen you can press home 5 times, press up arrow once, press rewind twice and press fast forward twice. This will cause the menus to scroll then pause and a few seconds later the Roku will restart. This will not remove anything from the Roku (other than clearing the cache) and will not change any settings or remove any credentials you have entered. It’s basically a deeper restart with the clearing of the cache. If this method doesn’t work then search the internet for the other methods.

1 Like

Sounds to me like the Tablo app for Roku needs some attention. Which, appears long overdue, anyway.

My Roku Ultra works fine with Tablo. No random exits ever. But when we’re navigating YouTube and push the right direction button it exits, makes a funny sound, and goes to a screen to install the Hulu app. Always Hulu. I’m guessing it’s something hinky with the remote but we have been living with it. Happens maybe once or twice a week.

1 Like

A couple of things I would try…
As mentioned above, try clearing the cache memory of your Roku, I do this by going into the Setting Menu and selecting System Reset (NOT Factory Reset). Your Roku will go through what looks like a power-up process.
For me, the Roku System Reset fixes the problem with Tablo’s thumbnails disappearing during fast forwarding and also fixes issues with YouTube whenever it starts acting erratic.

If this doesn’t solve your problem, I would then try removing the Tablo app from my Roku and re-install it. I’ve seen this fix some problems after a Roku OS update.

After this newest update, and even after I dumped all the recordings, my Roku app constantly disconnects from the TABLO whereas I have no issues with my Apple TV app. What gives?

What version is the Roku system software?

I’m having the same issue with Tablo. If I try to watch a recording it backs out the first time, but not always, and when I go back in, it plays fine. It also backs me out almost religiously if I change live channels. Watch one, go to another and it backs me out. These are really frustrating. Never really had the issue until last few weeks. Before was pretty intermittent and couldn’t repeat. But just repeated several times today on me. Just got latest Tablo update 2.2.38 and on Roku 10.5.0 build 4167-04

2 Likes

Some have had problems with the Roku 10.5 software version. This thread talks about how to rollback to V10, might be worth trying.

If they had, casually informing someone they need to roll back their firmware seems reckless.

New Roku build today. 4174

Issue remains.

Try clearing your Roku cache - see my post above for instructions.

Can confirm for me as well. Running a new 4800 Ultra. I think it relates to the 10.5 Roku OS upgrade and not the 2.2.38 Tablo firmware update though hard for me to say for sure since up until a few days ago I was running the previous generation Ultra. I tried the secret menu reset mentioned in this thread above with no difference. For now my fix has been I’m using my Firestick 4k to use my Tablo as it does not suffer the issue (leading me further to suspect it is the Roku 10.5 OS that is causing this).

I am still on Roku 10.0 (upgrade not available yet for me), and no issues. Making me think twice about applying the update.

With Tablo you have a choice whether to upgrade or not, AFAIK there’s no way to stop the Roku auto-update! :confused:

Not at all reckless, since others have complained about the same (or a similar) problem after “updating” their Tablo to .38…and rolling back the firmware wouldn’t do any harm.
“Reckless” would only apply if reverting back to .36 would cause a problem.
.38 seems to be problematic for some, so it’s a good option for troubleshooting purposes.

According to Roku, there is no way of clearing the cache on their units.
Anything that’s done in an attempt to clear the cache will either do nothing or simply reboot the unit (which actually may resolve certain problems).
All that’s required is a “system restart”.
From the main screen: “settings”, then “system”, then “system restart”.
As per Roku, this is all that’s needed (and functional) to “clear the cobwebs” that may exist.