Constant Buffering After Firmware Update


My Tablo Quad OTA DVR updated to the latest firmware 2.2.38 and continues to buffer making it unusable. I did not have these issues prior to the update. The Live TV plays for less than 5 seconds, and then buffers for about a minute.

I have tried rebooting the Tablo device, but it. still continues to buffer. I have disconnected the HDD, and rebooted and it still continues to buffer.



It looks like you just created your forum account. Have you opened a ticket with Tablo to see if they can review your logs and isolate the problem?

Make sure it isn’t a network issue. If you have a mesh network, ensure the Tablo is connecting to the closest satellite router. If no mesh, double-check that the Tablo didn’t connect to the guest network instead of the main network.

I’m telling you this because my Tablo did the exact same thing and then I figured out it was using a bad network connection.

Thanks for the tip. I do have a mesh network, so I ran a CAT5 cable to the Tablo and rebooted. I’m still getting a lot excessive buffering.

I have lowered the Live TV/Recording Quality to HD 720 - 3Mbps, but Tablo plays for a seconds and then buffers for minutes making TV unwatchable.

Thanks for the suggestion I’ll try that.

Are you noticing this behavior on a Roku by chance? I am recently noticing this same issue with the latest firmware. I am not seeing issue with Live Channels on the Windows 10 app, but seeing the issue on a Roku. It buffers even with a low stream quality.

Have you tried uninstalling/reinstalling the app?

Yes, I am experiencing these issues on a Roku app. I contacted Tablo Support and their response is below.

Performing a bank rollover has resolved my issue.

Thanks for contacting Tablo Support.

I recommend resetting the firmware on the Tablo to the previous version with a bank rollover.

To perform a bank rollover:

  • Disconnect the power supply from your Tablo
  • Hold down the reset button
  • With the reset button held down re-connect the power supply
  • Let go of the reset button as soon as the Tablo’s LED starts to flash

Once this is done please try using the Tablo on the previous version of firmware before accepting the update back to the most recent version.

I rolled back my Roku from 10.5 to 10 and the Tablo seems fine now. You could try that Did you try to see if you could rollback? Press Home 5 times, Fast Forward (>>) 3 times, and Rewind (<<) twice to get to the “Secret Screen”. If it’s possible, it will offer version 9.3 when you choose “Update software”. When you hit Update Software it picked the older version and installed.

These steps would have reverted you to the previous version of the Tablo’s firmware. If this didn’t resolve the issue, it’s unlikely the firmware is the cause (it’s also worth mentioning the most recent update didn’t make any changes that would cause this kind of problem).

Is the Roku itself on WiFi? If so, have you tried hardwiring the Roku?

Roku OS 10.5, where did that come from. It seems like they just pushed release 10.0 out the door.

It’s only a performance improvement only if it works or is super fast at not working.

Performance Improvements - Roku improves the streaming experience with every automatic software update. With OS 10.5, users will experience faster channel launch, home screen menu, and return to home screen, plus smoother video playback. We’ve also continued to improve our proprietary automatic Wi-Fi® network detection technology to identify and connect devices to the best wireless networks to ensure smooth streaming experiences for Roku users.

Rolling Tablo back to the previous version of the firmware has resolved my issue.