Tablo 4.0 doesn’t work!

My Tablo 4.0!!!
It gets to 99% loading the channels and then it loses connection!!!

This device su**s getting ready to take it back because it doesn’t want to setup!!

Very frustrating device. Why do they sell something that doesn’t work!!!

I am sorry you are having issues. I would encourage you to call Tablo support or create a trouble ticket.

The Tablo 4.0 absolutely works, but some people have had setup issues.


I tried the new Tablo out for 3 days and took it back. It just has to many bugs. Maybe in time Tablo will get all of them worked out and I may try it again

I would see if there is an update as I got one a week or so back and its been next to flawless since. Best Tablo ever made I think, never been one so fast and snappy.

1 Like

Mine has that and also a lot of other problems I was going to get the 4.0 but not from what I have read.

I agree that there are too many issues with the Tablo 4.0. Perhaps more specifically with the FireTV app. I have had numerous bugs and am ready to return my Tablo. On almost every recording I try to watch, as soon as I try to play, it says “Failed to Decode video”. If I just continually hit “Retry” it may, MAY, eventually play. If it does begin to play and I fast forward through a commercial, when I press play, I again get “Failed to Decode video”. When I attempt to play these same videos from my iPhone or iPad, the recordings play back flawlessly, no issues, which is why this bug appears to be with the FireTV app and not with the recordings themselves. Tried calling customer support and after 20 minutes holding, hung up.

@mkilo67 I truly feel your pain. I record one show from the 10-11 am time slot M-F for playback in the same evening. About 3 days out of 5, I get the same issue – Failure to Decode or some similar version. Multiple tries to Try Again followed by an immediate FFWD or REWIND sometimes get me into a viewable portion of the show, but boy it is a HUGE pain in the ___!

My experience is also on the FireTV app, playback on a FireTV Cube device.

@TabloTV @TabloEngineering Are you looking into this issue at all?

Could it be that the firetv device doesn’t support mpeg-2. As an example, I think the 2017 basic firetv stick may not support mpeg-2. When and if the original mpeg-2 is converted/archived it is probably converted to h.264 which almost all devices support.

Thank you for the reply! The recording will play, I just have to either keep pushing “Retry” over and over until it plays or go into the FireTV app manager and force close the app and clear the cache, then it will play. Obviously, that is not ideal. Also, I may have mistakenly said FireTV stick, whereas I am using FireTV cube. ty.

TY Seeker! Yes, sounds like the same issue and perhaps you identified the culprit. I too am using a FireTV Cube (not stick, I may have previously said stick) so maybe the issue is specific to FireTV Cubes.

P.S. Like Seeker336, I am using a FireTV Cube (not stick) so perhaps the bug is specific to the Cube. Would really appreciate @TabloEngineering @TabloTV looking into this.

keep going. there are 3 generations of the cube. maybe the problem only exists for one of them.

Thank you. Actually, I moved from a Tablo Quad to the Tablo 4.0. Both utilizing the same FireTV cube. This was not an issue with my Tablo Quad at all, which used the Legacy FireTV app, which is why I believe the issue is specific to the new version of the Tablo App when using a FireTV cube.

The legacy quad records using h.264. the gen 4 is mpeg-2.

Thank you, Zippy. That is good to know. The issue though isn’t that the Gen 4 recording won’t play on my FireTV cube, it’s that it initially will say “Unable to decode video” with a “Retry” button. If I continually press Retry, it often will eventually play, if not, then if I stop the app and clear the cache it will play. However, if I am able to get it to play but fast forward or rewind then press play, I will again get “Unable to decode video”.

One generation of the cube uses hardware acceleration for mpeg-2 and two generations probably use software libraries for mpeg-2. So which generation of the cube are you using.

Thank you. I am using the 1st generation cube from 2019. @Seeker336 which FireTV Cube are you using? I tested with my FireStick 4K and it had no problems, as it doesn’t with my iOS phone or tablets, so the issue, at least in my case, seems specific to the FireTV Cube.

I have the 2nd Gen FireTV Cube, the most recent version, and I keep it updated about once a week.

CORRECTION: I DO in fact have the latest version of the FireTV Cube. Turns out mine is the Gen3 Cube, not Gen2. It has been in service about 6 months and I check for/install updates at minimum once per week, sometimes daily. So it is up to date with FireTV updates.

I went back to check the recording of the show I made on my 4th Gen Tablo on Friday. This time, I accessed it via the Android TabloTV app on a Samsung ZFlip5 phone. As expected, the recording was broken into 4 separate segments, just as I had found when I accessed the show for playback Firday evening using the FireTV TabloTV app on an FireTV Cube. This tells me the Tablo itself did the segmenting of the program – segments varied from 3-4 minutes to 19 minutes in length.

During play back on the Android app, there was also some pixelation, though not as severe as on the FireTV app. I did NOT experience the “Failure to Decode” blue screen with “Try Again” or “Reload” on the Android app. On the FireTV app, I had experienced those interrupts multiple times during each recorded segment.

@TabloTV @TabloEngineering @mkilo67 This suggests to me that there is a dual issue here: the Tablo apparently is not holding onto the signal to complete a one-hour show recording and the FireTV app (at least on the latest version of the FireTV Cube) might have some difficulty playing back the recorded show segments.

Hope you are able to isolate and correct the issue. Cheers.

Probably 4 days ago, I had the same segmenting fluke happen to one program (out of at least 20 recorded by that time). But that was it. Nothing like that since. Playback was Roku Ultra.