Roku and "Loading, Please Wait" (lets be honest)

I’ve been through this forum many times and searching for a solution to this problem.

Even typing in this post, the forum bot is showing me may items that are similar to this post as I type it.

Can we all agree that this is a problem with Tablo and not Roku?

We need an actual solution and definitive answer from Tablo on this problem as too many people are experiencing the issue. The Roku 3 is their recommended streaming device and yet all I see are post after post about “LPW” issues.

The device works great on my iPad and its spectacular even when I am at work accessing my live TV remotely… but I need this to work as advertised on my home streaming device or I will be forced to return everything (the wife is not going to go through hoops to watch OTA TV).

Can we please get an actual answer tom Tablo on this, asap?!

We definitely needed another thread on this.


It is mine and a great many others experience that this was fixed with the Roku 9044 update.

If you are still having the LPW issue, I suggest you open a ticket with @TabloSupport

While I agree with your sarcasm… the problem is there are so many threads about this issue maybe its time for them to actually address the issue.

Already did, three days ago and I’m still waiting to get an initial response.

I received the Tablo last Tuesday, updated to the latest firmware immediately upon setup. The Roku is also new as of 3 days ago and was also updated to 9044 almost immediately.

I would place a call to @TabloSupport today before the Holiday.

Isn’t it interesting, that after a period of quiet here, because the major problem has been solved, a new poster (joined hours ago), turns up with the problem that doesn’t exist for anyone anymore… He goes from thread to thread to ensure that his message is spread out across the forum strategically.

It is in the nature of people to give others the benefit of the doubt. To try and help them first. And how does he repay others? By sarcasm when someone else asks for help as if to cut off any discussion about purchase choices and buying decisions.

In the age of corporate politics, why is there no suspicion about this guy? Just shows up at a time when everything is quiet… He “just happens to have this problem” :wink: “Let’s be honest…” LOL

I have fix, just get a Nexus Player. You’re welcome :smile:


Actually no I don’t agree because I see exactly the same performance on Roku and the Nvidia Shield. It’s the nature of the technology. I do not get random LPWs. Just the initial buffer build up then it is solid.

Some do still get LPW screens but those are largely network related now.

  1. I came here to make a single thread so it stops being posted all over the place.
  2. My biggest problem is the lack of official support here. Users attempting to help other users by offering workarounds is not a solution. Tablo needs to actively engage people having issues. My post to the “should I buy” poster was me honestly telling them to set their expectations correctly before purchasing. At $200+ I expect it to work as advertised.
  3. Suspicion about what? Do you think I am lying? Do you want me to take a video of me experiencing the issue and send it to you? You are being completely ignorant if you think this problem is resolved. Just because you are not experiencing it doesn’t mean others are not.

Grasping at straws trying to accuse me of something because of the age of my user account here is ridiculous. Maybe the reason I recently joined was because I didn’t have a reason to post until I started to experience a problem.

My Tablo experience was excellent when accessing it via my iDevices. I only experience this problem with my brand new out of the box Roku 3 (recommended model per Tablo).

I don’t even understand what you’re trying to accuse me of.

Actually the Tablo folks are pretty responsive, even without formal tickets. I’ve been pretty impressed with their forum involvement and wish other vendors would do the same.

With that said, keep it up Tablo folks!!


But it has been 4 hours and the problem hasn’t been solved through an unofficial channel!

@SkydiveGuy - I assume you have rebooted the Router, Tablo and Roku (in that order)?

The direct phone number is 1-844-TABLOTV December 31st - 10:00 .am. - 4:00 p.m. ET (Closed tomorrow)

Is the Tablo Wired or Wireless?

Where I hope he finds good Tablo-like support. Although, Tivo folks (no offense Tablo-ites) seem to be pretty happy folks. I tend to like the “new guys” on the block with the newer ideas… all I can say is Tablo support has been pretty good in making things better on their 1st gen product. I know some will disagree with that, but I’ve been around the block a few times and can’t remember another vendor trying as hard to make things right. What does the future hold? I’m hoping that all the work the Tablo folks have put in will make their products better and better and easier and easier. Only time will tell, but I think, in general, Tablo is off to a good start. And I know I’m looking forward to what they come up with in their 2nd gen product (no announcement has been made, could be years away).

Your issue has been fully addressed by Tablo directly. Please read this entire thread, specifically post #1 by the CEO.

1 Like

Post is old. The problems period was after that post was made. Tablo’s changes alone didn’t fix, required both an update (and there were several, and some not so great) from Roku in addition to Tablo’s changes.

Six hours is old? Wow do things age out quickly these days.

A Message from the CEO of Nuvyyo is from Nov 2.

“Official Support” comes from support tickets. This is user community.

Tablo is more responsive on this “community forum” than MANY tech companies.

Your problem is undoubtedly real, but if solution is your goal, some time on the phone with the folks that can fix it will be the best way forward since your problem seems to be somewhat unique to you at this time.

If your goal is to just goad Tablo, then continue the frequent posts to various threads.