Random deletions of not-so-kindness

Is there a reason that a 4th gen Tablo would delete entire sections of recordings, or is it just bored?

Is there a time limit on how soon we have to watch our FAST recordings before they just up and disappear?

Had nearly two complete seasons of a show recorded, plus some other stragglers as I waited for S2E1** to record. It recorded yesterday, but then by today everything except for what’s recorded today has been wiped off the machine.

Okay, cool. This is the fourth time this has happened in the month I’ve had them. Now, two different machines have wiped shows within a 48 hour period. Is this something to do with the 2am system maintenance thing?

I should note that this has happened when using both internal and external storage (in this example it was external).

Looking at future episodes of the show, it’s going to be a pain in the butt to set up the recordings. It’s only marking those previously not recorded “REC”. Apparently, it thinks I’ve watched the others and I don’t want them any more, and despite 100+GB* left on 256G drive, it has decided to remove them.

Yes, auto delete is on, but I’m nowhere near short on drive space – would turning it off do any good? Should I go in and Protect every episode of every show I ever want to watch? Would that even make any difference? These were all marked New and had not been watched!

IDK how you all do it. I give you all the credit in the world. Appreciate any advice – thanks in advance.

[*Edited to correct 100MB to 100GB]
[**Edited S1E1 to S2E2, changed other spelling, grammar, past/present tenses of words.]

I think it’s auto deleting because you’re keeping the drive too full.

See this about auto delete

Per that a dual tuner should be keeping 2x 2 hrs of recording space free. That would be about 16 GB on a 4th Gen dual.

So, you think it’s possible that out of a 250G drive, the Tablo needs over 100G at all times in order to record new things? Also, that would be in a weird order of deletion since A) they were not the oldest recordings and B) I have other (older) recordings that have been marked Played and are not checked Protected.

It’s a very informative article, but even when using the internal drive, and taking in 50hrs for the 128G, that’s 2-3GB per hour (which on my other PVR is about 4g an hour…) If we give it a nice even 10G, that leaves over 90G extra. About 9 hours were scheduled to record yesterday, and I would have skimmed through/deleted most of that before much of it were to record. :confused:

I’d left auto delete on because I’d been working with a smaller drive previously, but I will turn this option off on both Tablos and keep you posted

TY for your reply and I really appreciated the reminder/link about auto delete. I still think there’s something fishy w/ FAST recordings. These are the ones that seem to disappear on me.

Your post said you had only 100 MB left. If you have 100 GB, then auto delete shouldn’t be touching your recordings.

1 Like

Hi there @269587 While we don’t recommend using external drives that small (we suggest a minimum of 1 TB) we would still like to take a peek at the logs on your Tablos.

If you’re willing, could you put your Tablos into remote access mode? You can do this by hitting the reset button on the bottom three times quickly.

You’ll know you’ve done it correctly if the Tablo starts blinking in a heartbeat pattern. If the LED goes back to solid blue, you haven’t done it correctly and will need to try it again.

Thank you. I had not noticed my typo. I will adjust this in an edit.

Is there a certain time I would need to do this? Can it be done between recordings, and how long does it take? Will it affect anything scheduled during that time or shortly after?

The sooner it’s done the more likley we’ll be able to see what we’re looking for in the logs.

It takes less than a second and it won’t affect anything you’re trying to do after you enable it.

If you accidentally reboot the unit while you’re recording something, it will affect that.

And if I press the button 3x while it’s recording, it will not affect that either?

[Edit 1]
Both have supposedly been done, but only one seems to have recovered. The other has been “heart-beat” blinking for quit a long time. Do I reboot and try again? Next recording is scheduled in 10 min.

Rebooted, connected, hit the button 3x. It’s still “heart-beat” blinking, but it seems to be responsive and playing OTA/FAST stations ITMT. I will check back in a few hours to see if anything has changed.

TY in advance for checking into the logs, and I wholly understand that I’m not using your recommended drives or sizes. Still hoping to get this working well enough that I WANT to spend that kind of money on them.

Keep me posted!

How long is this light supposed to be blinking like this? It’s been going for over 2 1/2 hours!

The light will stay blinking until the team looks at the logs and/or your Tablo reboots.

If it’s making you twitchy you can turn the LED off in the SETTINGS for now.

Thank you for letting me know this. I was worried something went wrong since the other one only did this for a short while.

As an update to the difficult process of recording these “missing” episodes and only non-viewed ones being marked for recording, I thought of a little trick. In the Tablo viewing app I marked the show to Record None, exited the app, then told it to Record All episodes again. I did this a few hours after my first post here, but needed to make sure it was working. So far, I’ve got 6 episodes recorded again – let’s see if they stay until we get back around to where I started!

At least one more recording has disappeared within the last day – I believe at some point today. Did you ever discover anything from the remote the last time this happened?

Do certain shows just “time out” after a certain period? Today is 15 days after its recorded date.

Also, I have turned Auto Delete Recordings Off on both of my devices, but looking at the settings right now, it’s back on. Regardless, there is 135G available!

[Edit: I turned Auto-Delete off on my mobile app. And I had to turn it off again on my FireTV. And then I had to turn it off again on my Firestick. I am beginning to think this is app-specific, when it definitely should not be.]

Is this Gen 4? On legacy, the “recent” listing will only show 2 weeks. You have to go into “All” to see older recordings. That fooled me the first time, as I thought I had lost a recording, but did see it with Tablo Ripper.

Yes, a gen 4.

IDK how the Legacy devices worked, but for the 4th gen, the only difference in All Recordings is that it shows your TV Shows, Movies and Sports all in one grid, versus splitting them up by category. Good idea, but it brings up the exact same information as clicking on TV Shows and is not there, either.

I have stopped using my Tablo for many shows that I have to record out of order because this has happened so often. In this case, it was in order, on the CW, and two weeks old (yesterday being day 15 is why I wonder about time limits.)

I appreciate your input and it was certainly worth a try. I wish it had worked!

Even though this has happened with both internal and external storage on this (2nd) Tablo, I’d still like to switch back internal again or try a new external drive – I just don’t know how to take the drive out safely so that the machine will disregard those recordings and start recording on the internal again. (I’ve had nonstop issue with this second Tablo and my return window is closing very soon!)

I just noticed another show in my Library missing episodes. I think there’s some miscommunication between two of the settings.

Under Settings > Storage Options > Auto-Delete Recordings, you get the option of ON or OFF. This is still set to OFF.

Then, when you are in your Library and looking at Scheduled > Series Recording Options > Keep … there are other options available. Both of these series were set to Auto for a limit here, as well (which is the default setting).

Regardless, with 58% available, the files should be there. I KNOW that 3 of them have been deleted since yesterday. Now I am left with the two latest episodes. Again, anything older than TWO WEEKS have disappeared.

Both of these shows were on the same channel (CW). What is going on, @TabloSupport ? Why have internal storage of 128 if it can only save 2 weeks? External storage (where these were) is a joke if I can never fill up the internal memory!

I have now changed both of these shows to keep All Episodes, but I doubt it will have any effect. (Auto-deletion is off, so nothing should be deleted anyway!)

(Two other episodes from MeTV have also been removed since yseterday, also leaving me with two episodes, which are only two weeks worth, just like the others.)

I have now gone in and manually set all of my future recordings to Keep All. I shouldn’t have to do this, but at this point I’m willing to try anything!

We believe the root cause of the issue you’re seeing is due to the size of your drives.
We recommend drives sizes be minimum 1TB.

If you’d like to switch back to internal storage, all you need to do is remove your external drive and reboot your Tablo. It will switch back to internal storage. Keep in mind, the auto-delete feature works differently when using internal storage. You can learn more about this here.

Keep in mind, Auto-delete is a global feature for the Tablo, regardless of which client enables or disables it. When comparing Tablo apps and this setting, try to give it some time between checks - it may take some time for each application to display the most up-to-date status. And of course, keep in mind that when using the ‘Keep All’ setting on multiple shows at a time, this will of course cause the drive to fill up faster.

Thank you for getting in touch.

What you’re saying is inconsistent with what is going on and maybe throughout this long discussion has been overlooked. This had been happening on the less than 1T internal flash, too. There seems to be a two-week time limit on certain shows or stations, period.

As for turning off Auto-Delete, while setting up each Tablo I have selected this option. I also ensured this was the case when starting this topic. Perhaps the firmware updates forced Auto-Delete back on – I did not check this when I updated to 2.2.48 twice.

Thank you for letting me know how easily it is to return to internal storage. I will try this again, but as stated before, this has been happening on external and internal storage.

[Edit: With a return date of the 13th, even removing or replacing the external drive will not give me enough time to test this theory.]

[Edit 2: The oldest recordings were not the ones to be removed first. They were the oldest of that show, but not on the drive. Your site states that: “Drives at a size of 750 GB or less will always keep 2 hours per tuner (based on your recording quality) free at all times.” – so less than 1T will work, and is well above what my 2-tuner 4th gen would require available. (And is noted that is not recommended.)]

Also: your link to compatible storage is WiFi setup instructions. (And every page I find links to the same instructions.)

While I only recorded 5-6 hours overnight, I am once again missing another ton of shows!

You CAN’T tell me that there’s not a piece of software saying “delete anything over 14 days” … because even though everything is set to NOT delete automatically, things that were not protected content are gone. Almost 2 seasons of a show disappeared – now everything before December 23rd is gone!

I don’t buy the excuse that it’s my drive! It needed space to clear off, what, 10gig, so it could bring me up to 138gig??? Something’s not adding up here. I have unprotected files going back to late NOVEMBER. It seems to be the same channels over and over again that delete the files… (OTA: Laff, CW, MeTV, FAST: Laff More, True Crime). There are likely others, but these are the ones I’ve noticed. (Since these stations play things out of order, I generally wait to have at least the beginning of season 1 recorded so I can begin to watch them IN order.)

Again, this was also occurring on internal flash memory. On both Tablos. As for the drive size theory, I don’t seem to have had less issues on one of them SINCE putting the drive in.