Problem setting up Remote Access

I’m trying to set up Remote Access to the Tablo. Unfortunately, the automatic setup didn’t work so the Tablo website tells me that “your router requires manual configuration.”

The set up provides 2 public port numbers to forward to private ports. It also provides the private IP address of the Tablo.

The problem is that my router’s port forwarding settings don’t appear to allow me to enter an IP address that matches the private IP address provided for the Tablo.

My router is a WRT54G v8.0.

The private IP address for the Tablo is 1–.—.-.-- but in the port forwarding settings for the router, I can only assign an IP address that begins with 1–.—.-.? where that question mark is the only variable that I can adjust in the IP address in the port forwarding settings.

Is there some way I can establish remote access to the Tablo with my router?

Is your Tablo directly connected to your WRT54G? Either via WiFi or Ethernet?

For the Tablo to be on a different subnet, it sounds like the Tablo is connected to something else. Like your ISP modem, or another router.

I’m not sure what the Tablo is connected to, I think it’s the WRT54G router. I set up the Tablo via WiFi and gave it the credentials for the WiFi network that runs through the WRT54G router. Is there a way to check if the Tablo is connected to something other than the WRT54G router?

Everything else with setting up the Tablo has gone fine. I have a number of devices that interact with the WRT54G router (most over WiFi, one with ethernet) that can all play live TV through the Tablo.

Log in to the Linksys WRT54G, under the status page what does the WAN IP of the Linksys WRT54G start with? It should be an IP in the external IP range.

If the WAN IP of the WRT54G starts with 192.x.x.x, or 10.x.x.x then it is getting an internal IP from your modem’s DHCP server.

What is that make and model of your ISP’s modem?

First of all, thanks for your help with this.

I looked into my network setup and realized I had 2 routers running. There must have been a reason for that when I set up the network maybe 5 years ago, but I can’t remember why. So I removed the WRT54G router from my network connections. Now, I’m just using a Technicolor C2100T modem/router.

Unfortunately the automatic connection for setting up remote access to the Tablo didn’t work directly with the C2100T router either. So, I have tried forwarding the 2 ports that Tablo suggests I forward to establish remote access but the interface for the C2100T tells me “the port range is invalid” when I try to forward the ports.

I am trying to forward port 21740 to port 8887 and forward 21739 to 80.

Show us the screenshot of the port forwarding page on the modem.

IP address for the Tablo and ports that need to be forwarded changed from what I mentioned in my earlier post because I was messing with some other settings. Now the ports to forward are 21096 to 8887 and 21095 to 80

  1. Why is the “Enter IP Address” set to That is not the Internal IP address of the Tablo. The internal IP of the Tablo should start with 192
  2. It appears your combo modem / router cannot do port translation (which is forward an external port to a different internal port), which is what the Tablo needs. This is a limitation of very old modem / routers. You can only forward external port 8887 to internal port 8887 for example.
  3. Your C2100T does have a UPnP page, go to it and turn UPnP on. Then try having the Tablo do the port forwarding automatically (go to the Settings page in the Tablo and turn off and on the Tablo Connect feature).

See thread below.

The 174… IP address is what Tablo tells me is the private IP address for the Tablo when setting up remote access.

UPnP has also been turned on for the C2100T and the WRT54G (when it was connected) the whole time I have been trying to establish remote access to the Tablo. But every time I get the message that my router requires manual configuration and the details on which ports to forward.

Something is definitely wrong with your network setup.

The IP address is an external IP address. For an example, I see you have ports 6700-6751 forwarded to, so the internal IP address of your Tablo should be 192.168.0.xx

What device is the IP?

Have you placed the Tablo in the DMZ? Check the “DMZ hosting” page.

Trying to setup port forwarding manually while also having UPnP turned on never worked for me with Tablo. If you have UPnP turned on then, as theuser86 said, turn off Tablo Connect feature on your Tablo and turn it back on and let Tablo automatically set it up for you.

1 Like

Thanks for your replies.

I don’t know enough about network stuff to know what device is the 1–.—.-.-- IP. The only thing I have in my network now is the C2100T which is a modem/router combo. The Tablo connects to that through WiFi (maybe going through LAN/ethernet would have avoided these problems but I wanted to put the antenna in a good location and unfortunately that’s not near where the router is).

I did try placing what Tablo says is the private IP address for the Tablo unit in the DMZ but that didn’t help make the connection to remote access, even after physically resetting the router.

Separately, I have switched UPnP on and off through the settings for the C2100T but Tablo still says my router requires manual configuration when I try to setup remote access.

Contact Tablo Support directly with a support ticket and see if they can walk you through the port forwarding settings then.

Thank you for your help. Just wanted to let you know that I finally got connected to remote access. I interacted with tech support from Tablo and my ISP but they couldn’t figure it out.

What finally solved the problem was this advice: Manual configuration of Tablo Connect

So in the Tablo settings, you set it to External Port 8887 to Internal Port 8887, and External Port 80 to Internal Port 80?

Most people do not recommend this because it opens up port 80 on your router to the world.

But like I said it is a limitation of your combo modem / router which doesn’t allow port “translation”.

Yes to your question. And I set those same specifications in my router: Forward 8887 to 8887. And forward 80 to 80. Given that, am I opening up myself to problems? (I know nothing about port forwarding.)

Short answer is yes.
TCP port 80 is the default web server port, and knowing this, hackers scour the web to see what access they can obtain from every known public IP address on TCP port 80.

Tablo’s default public TCP port assignments for Tablo Connect are purposely set to nonstandard ports to obscure their purpose.
Security thru obscurity.
It’s not a foolproof defense, but helps.

Tablo Connect is a feature that increases your Tablo’s flexibility.
Increase flexibility, in this case, means decrease in security.

Choose your poison.

That is 100% true…which means that setting it to 80 has 0 impact on security…sharing a port in the internet is a security risk…it doesn’t matter what the port is…so, being 80 simply means that most people know that it’s a web server…but in this case, the 80 isn’t actually the port that’s used for streaming remotely anyway…

So…while it’s not typically ‘recommended’, it’s no less secure than the recommended way.

In my opinion, no, no more than other port forwarding configurations…a port is a port, the security of that port doesn’t change based on which port it is…so, if you trust Tablo to make that port available on the public internet, it doesn’t matter which port is shared on the internet, it’s either secure or not.

What IP address did you end up using in the settings on the combo modem / router? You were saying the Internal IP Address of the Tablo started with 174 (which is not an internal IP).