Player Error - Could not play live stream

Would help to know which player you’re using.
Looking back on your previous posts I see you mention a Roku, but not which one.

If it is a Roku, I have no Live TV issues with the Roku 4 (hardwired), Roku 2 (2015) (wireless-g), and Roku 3 (wireless-g).

I haven’t found a complete fix yet. I recently bought a new router in hopes it would fix the problem but after trying it today it was really odd. Initially the stream worked but it was very slow due to my slow cellular connection. I live on the border and I sometimes get a better connection to a mexican cell tower using T-Mobile’s North American Plan. After I switched it wouldn’t play. But I tried to play about 5 different channels and when I got one to stream I go back to the initial one I want. I’ve found It to be very finicky and unreliable.

No it works fine on my roku after I got the largest antenna that I could find. This issue is with remote streaming to my devices. Specifically in this case an iPhone 6. Tried different streaming speeds, on wireless, on LTE, opened recordings, tried different channels. All to no avail. I get the error message above every time.

@Jmyler We’re still tracking this, most of the reports we’ve received about this mention the mobile apps - specifically while remote. The behaviour and reports we’ve tracked mostly mentioned this as intermittent; but it sounds like it has never worked for you on the iPhone app - is that right? Have you tried uninstalling and reinstalling the app?

Was having the same problem. When I changed it to stream in full quality it worked. Seems like anything less than full quality gives an error.

I have the same error. Was able to stream though when I bumped quality to full but does buffer constantly since I don’t have the upstream bandwidth to carry that size stream. Does this on my android and on a PC using chrome. Almost seems to be the tablo is not able to process the compression on the fly in the lower settings. I know it used to work but don’t recall if this was just prior to the version upgrade I did recently.

Which apps were you guys using? Feel free to send us the details directly.

I am having the same issue live streaming. I’ve been able to stream recorded shows but when I try to live stream I get the error.

I was streaming at 1Mbps and getting the error. I switched my streaming to Full Quality and it works perfectly.

Fortunately I have the bandwidth for this. But I’m not sure I always will…so hopefully they resolve this.

Any fix to this? I’m new to Tablo and find this extremely frustrating. I to can only connect remotely if I stream at “full quality,” but it buffers too much for that to work. Anything less than “full quality” and I get the “Player Error - Could not play live stream” error.

This is one of the main reasons why I bought a Tablo. Very troubling…

What playback device? And are you using work WiFi or your cell company’s LTE?

Samsung S7 Edge on T-Mobile LTE. I have a 50 meg upload connection at home as well.

If I reboot my phone, sometimes I can get the first playback and a reduced rate to work, but not subsequent ones. As mentioned, switching to full original quality allows it to work albeit with the normal problems associated with 4G/LTE.

I have the same issue connecting remotely via a new Amazon Fire Stick. I get the “could not stream error” on the Fire if upload set to anything except Full Quality. However, this creates a LOT of buffering. With the same settings on the same remote WIFI it works fine on my iPhone 6 with no buffering.

Anyone find any creative work arounds for this as it a Tablo-killer for me and will have to return if I can’t get a viable option.


You can try starting a recording on the program you want to watch and go back into the recording section and start playback from there. But yeah I’m with you. I’m so frustrated at this point as soon as there is something else that can do a similar function I’m switching.

Interesting idea. I changed my recording quality to 720 and gave the Sunday night football game a 5 minute headstart. After some initial buffering, it seemed to work. I will test out a few other scenarios and see if I can generate consistent results. I also am setting up a VPN to see if that will work for watching TV while we are at “the cabin”

This is a repeatable problem…there isn’t a “magic formula” that fixes this. My guess is that you’re not trying to do remote live streaming using a reduced rate… it just doesn’t work reliably (well, it might work once, but change channels… it’s pretty repeatable).

Interesting…let me know if you figure something out. I find it hard to believe that Tablo can’t fix this. I use Plex for my home media and I can stream that from my home PC anywhere in the world, flawlessly. This shouldn’t be any different.

It used to work “ok”… doesn’t anymore. Can’t say what caused this.

We managed to track this down, and we’ll have a fix available in our next beta, which is coming soon. If you’re not already on the beta list, and want to be added to it, send our support team a ticket.


Thank you. I hope that does the trick. I’m requesting to be added to the Beta list now.