No connection, no blinking blue light when I turn on device


I had got problem with my device Tablo last week… I can’t connect to my device either with my computer nor with my phone. I looked to my router and the device does not connect to it. It looks bad…

I’ve tried everything. turn off router… turn off device, turn on router, wait few minutes, turn on device, reset device… nothing! The light does not blink when I turn on device. The blue light is on… always on. I’ve tried to connect with Ethernet cable behind device. No light blinking behind device… It looks like the network part of device is broken. Am I right? Am I alone? Is there other thing that could be done?


Disconnect the Tablo’s hard drive, and see if it works without it.

If the Tablo works without the hard drive connected…

  1. The hard drive might be bad.
  2. The USB hard drive cable might be bad.
  3. The Tablo USB port that the hard drive connected to might be bad.

To see if it’s the Tablo USB port that is causing the problem, try plugging in the hard drive into the other Tablo USB port.
To see if it’s the hard drive USB cable, if you have a spare just like it, use your spare USB cable.
To see if it’s the hard drive, connect another hard drive to your Tablo.

I know, I don’t have a spare USB hard drive laying around either.
However, I bet you have a USB flash drive, like this one:

Not recommended to use a flash drive with the Tablo all the time, because they tend to disconnect and go offline, but it’ll work for testing purposes.

I have already done this before. I’ve tried on an other hard disk. The device Tablo does not connect at all to my router with or wtihout hard disk.


A few people had their Tablo power brick go bad.
Tablo sent them a replacement.
Could also be the Tablo itself.

Open a support case:

As a last resort try holding the reset button as you plug in power to the Tablo. This will do a factory reset, losing any recordings you may have.

@SLeclerc Were you able to submit a ticket? Let us know how this is going!

I’ve also tried this… nothing… blue light is on and does want to flash at all.

I submited a tichet yesterday. I had an answer. Reset device to the factory default. I did but le problem still there.

@SLeclerc Make sure you let our team know; if you did the factory reset and you’re still having issues, we’ll be able to see the logs on our end.

Well must be contagious. My 4-tuner is doing this now. Last time it worked was Dec 21. Power cycle and solid blue light. Not the drive since I can mount it fine under Ubuntu. Its was running 2.2.12. I have a support ticket open from a lockup a week or so ago.

Still could be the drive.
See if your Tablo works without the drive connected.
Live TV will be the only thing that’ll work, but at least you’ll narrow down the issue to:

  1. The hard drive.
  2. The USB hard drive cable.
  3. The Tablo USB port.

Disconnect the hard drive, power cycle your Tablo, and see if it comes up okay.

It does not power up with ethernet harddrive and antenna disconnected.

Several users found their power adapter stopped working properly and Tablo replaced them.
Let Tablo Support know your Tablo doesn’t come up even with everything disconnected.

1 Like

Does it power up with no HDD and no antenna connected?

Appears to be the power brick. Temporarily wired it to a 12V lithium rechargeable. And it powered right up.

1 Like

My device is not working well either with HDD et antenna nor with no HDD et no antenna. I can’t reset device to default factory. Blue light is always on… Tablo will send to me an other power adapter. I’m still not convinced that it is the problem, but I hope so.

they already know!

My symptoms were the blue light comes on and never starts the blink pattern that shows it is booting. No lights on the ethernet port.

This morning I dug out an old external USB power supply that has 12V @2 amp. That also fixed it for now. At least until Tablo has time to respond to the support case. Sometime after the Holiday.

So if you have an old power supply hanging around and a soldering iron and multi meter to make sure you get the polarity correct you might be able to get it working. But has to be 12V 2amp minimum.

Mine is also 2.5 years old so the warranty has expired.

Might note that in 2+ years running 24X7 this is the first issue beyond a few minor software glitches that were quickly fixed.

Exactly the same problem. I bought my 4-tuner device in pre-order… mayby 2.5 years ago. It was running 24 hours / 7 days. I will try a new power supply soon. Thank you for yours comments. Happy Holidays.

Is the connector a 2.1mm x 10mm? I think mine may be going bad after 2.5 yrs. Amazon has quite a choice. Thxs