NEW - Tablo Firmware Release 2.2.38

It can take a few minutes after updating for the storage to be re-mounted. Next time around just wait a bit and a reboot won’t be required.

1 Like

If you routinely reboot to fix, instead of trouble shooting to eliminate, are you actually fixing something?

Routine maintenance vs a stable system, 3rd party firmware on my router easily goes over 2wks without issue. I have no “regular” timing for tablo reboots – have no issues with them. My Linux based HTPC suspends nightly but has uptime for a couple weeks — without issues.

Rebooting so you feel good about things may be great, rebooting, believing it fixes “things” may be misleading.

I only reboot as a last resort. My router maybe 2 or 3 times a year. And that’s always because my laptop decides to stop connecting to it. Tablo, hmmmmm, haven’t rebooted it since I moved it from one end of the basement to the other over 2 years ago. Oh wait we did have a power failure about a year ago so of course everything was rebooted then.

1 Like

Good fix, don’t have to hit reset button as often…

I tried using an Apple TV after doing the update on the Tablo and it fixed an issue where I couldn’t play any recordings remotely, live TV OK, recordings nope. But I’ve now noticed a couple new problem, when I return the Table to the local/home network it still acts like it’s connected remotely and is streaming at the speed setting for remote playback. Plus any recording which says commercial skip is available doesn’t skip commercials. If I change the remote speed to full speed then things are OK, but change the remote playback speed to something lower and no commercial skip and picture quality reduces. Also found if I uninstall/reinstall the Table app on the Apple TV things are OK again until I try using the AppleTV remotely and then problem is back. I’ve sent in an e-mail for support on this.

Hmmmm more thinking… I don’t think I’ve ever used the reset button on Tablo in 6.5 years. Just a few power cycles here and there. Always made sure nothing was recording or accessing the hard drive.

Update to 2.2.38 just popped up on my Tablo so I applied it. After updating, I am able to connect using the Android app. No problem.

However on the Tablo app on all of my Roku’s says “Connection Failed: Your Tablo is not connected to the internet, or is not on the same network as your Roku. Please check connectivity.”

Using the Windows app and using Firebox browser I get "There was a problem establishing an authenticated session with your Tablo. This could be due to either authentication or internet connectivity issues.

Since all of the devices, including my phone are on the same network, I don’t understand what is happening. There were no connectivity or authentication issues prior to the update.

EDIT: Resolved. Turned out my 2.4ghz wifi was somehow co-incidentally turned off on my routers. Since re-enabling all is well.

How to I got back to the firmware before this. This new one is junk… I will never update again. I ready to switch to a different platform and throw this thing in the trash.

So what issues are experiencing specifically? There are many of us having no issues at all with the 2.2.38 firmware.

All my Artwork is now fixed as of sometime this week with all the new shows starting up. The artwork changed for the new season’s shows. No other issues as I have seen.

You haven’t been specific about what is not working with your firmware upgrade. For many users, this upgrade has been successful. (Disclaimer: I haven’t upgraded my Tablo yet)

Sounds to me like you need to contact Tablo support.
They can either resolve any problems with the firmware upgrade or roll you back to the previous firmware version.

Use the search… there are post to roll back your firmware - you you just search.

I I searched and got this I guess we have to deal with tablo

You have to send a request to Tablo Support to do that.


Smart move not upgrading. The last one one great this new one is no good.

After Firmware 2.2.38 is applied, my Samsung SmartTV TABLO App no longer functions. When I activate the app, it wants me to “Begin Setup”. When I try to do that, it states that “no channels are detected - try moving your antenna”. If I could back out 2.2.38 I would but there doesn’t seem to be a method to rollback the update. I’ve tried: rebooting the Tablo unit as well as removing and re-installing the Tablo Samsung app. All to no avail. It has rendered your device useless. So, to the Tablo support staff my questions are: Will the Samsung TV app be fixed at some point in the future to allow access to your device? Or, will you release a fix to 2.2.38 to allow us to utilize the app on the Samsung TV? If I am forced to purchase a Roku unit in order to utilize your device will Tablo pay for that?

1 Like

I had the opposite experience. After the update, I lost my hard drive. Right now I’m trying to get my Tablo to see my storage device. It no longer detects it.

In the past I have had an experience where my Tablo hard drive was not available after the firmware update, but power cycling fixed it.

Also wondering if the “post-upgrade database processes” that can happen after a firmware update somehow exposed an existing problem on the drive?

FYI only… not really an issue. This is with the Roku app on a TCL Roku TV.

After the update to my 4-tuner classic Tablo, I decided to run a rescan as long as I “was there.” Pressing the Rescan button had no effect. Re-pressing it had no effect. Hmmm…

I hit the Back button on the Roku remote, and the app whined at me that I hadn’t saved the rescan results. I chose to cancel the rescan and the Tablo apparently responded by rebooting: I lost connection temporarily, and when it came back up it didn’t have a storage drive for a few seconds.

After that reboot, rescan worked fine.

This new update has rendered my Tablo useless on my Roku. It plays a show but when I go back I have to go to home on the roku and back in to do anything else. The screen just goes blank. Do you guys even test your updates? This is the second time some weird bug started after one of your updates. Last time it wiped out all my recordings, and support said “oh you just see a bug that very few people have seen”, is this a rare bug too??