NEW - Tablo Firmware Release 2.2.32

Scheduled manual recordings disappear everytime a channel scan is performed, then “Save & Continue” and then the live guide gets updated (typically happens within a few seconds after saving, I see the guide “Updating now…”). It doesn’t matter if nothing changes in the channel list after the scan.

@ProjectGuy @Aubrey @Richard_and_Diana_Mc @MSR We’ve sent you a PM with some steps to try so that we can take a look, get back to us when you can!

And the obvious question(s) is why is there a need to scan multiple times a week and save the results when nothing has changed.

Another engineer on here would also gladly answer your question. I like experimenting with different placements and orientations of my indoor antenna. Sometimes the signal strength of some channels varies during the day, and I’d like to know that. Typically I get similar channel lists on each scan, and almost always the channels I favorite/watch anyway.

To get back to what I perceive as the real question your asking…I think you are right, that I should stop saving the channels if nothing important has changed, to prevent any manual schedules from disappearing from saving the list again.

Before Firmware 2.2.32, anytime a channel would lose strength or disappear, I would move my indoor antenna for 1/8 of an inch, rescan and save the channels. This doesn’t mess up any of my scheduled recordings since I got my Quad.

After my update to Firmware 2.2.32, I get the same issue as MSR.

Just for the record, I’m updating my other Tablo to 2.2.32.

I’ve had some of the same issues with the 2.3.32 update - buffering (spinning blue circle) and frequent disconnect errors. I tried the following solutions which have helped in the past - blue button - reboot, rebooting router , rebooting and clearing cache/data on my Fire 4K. Also the issues were present on all my android devices and in the web-based app on my PC - so IMHO problem was with the Tablo. Nothing helped.

Then I tried something I usually don’t do. I pulled the power plug from the Tablo 4-Tuner and plugged it back in after a minute to do a cold-restart. This fixed my problems. Your mileage may vary, but simple to try (less intrusive than reformatting your drive).

Report back and let others know if it helped!


I tried the power cycling, and it seems to work for a short while after doing so, but the issue I’m getting (disconnect and unit rebooting) starts happening again within an hour after power cycling. Once it starts happening again it will happen regularly every minute or so after.

Some of my thoughts on why a cold-start helps:

  1. Tablo is stuck doing something that needs cold-start to stop.

  2. Tablo is overheating - unplugging allows it to cool down -

Since the bottom of a 4-tuner is a metal plate that is used as a heat sink I glued to to some leftover tile strips to add to the heat sink and allow more air flow around the unit.
Before this anything the Tablo was sitting on got quite warm. Redneck engineering at its best!

  1. Power Adapter is wonky - try another power adapter.

Sorry for the layman’s language , didn’t want to complicate things with scientific jargon. :slight_smile:

Umm maybe it’s a good idea now to put a heat generating object like the HDD on top of the Tablo? You’re just asking for trouble. Put the HDD somewhere for it passively cool, not touching the Tablo.

I’ve just posted a quick reply to some questions about the 2.2.32 update in this thread: Constant disconnecting after latest firmware update - #21 by TabloSupport and I thought it would be good to share here:

I can confirm that so far, we have not found any new bugs (in the .32 update) that would cause connectivity issues. We are still investigating reports that come in very closely, but so far, most of these issues (as is the case for most firmware updates) are related to either a network problem or a brief connectivity hiccup that can be solved by a reboot.

Our advice is to follow the standard troubleshooting guide seen here: Troubleshooting Connectivity Issues – Tablo

And if you still have issues, to contact our support team either by email or phone: 1-844-TABLOTV (822-5688).

As a quick note: we do not recommend reformatting your drive, or factory resetting your Tablo before contacting our team to take a look. It is certainly possible that a pre-existing hard drive problem could be discovered with some investigation from our team and fixed, but we have no reason to believe drive errors would be caused by a firmware update.

Note: We are still investigating some scheduling issues originally reported by @MSR, and will post updates on this report when we have them.


Your right, that was a consideration for heat from the HDD. In practice, there is really not that much heat generated from my WD Element 2TB HDD. The bottom of the Tablo has always been warmer to the touch, so it is where it is.

Have you touched the top of your Tablo? I’d be worried about the heat from the Tablo causing early hard drive failure.

While I’ll agree that drive on top isn’t the greatest idea, my original drive has been velcro’d to the top for going on 6.5 years. But I use a cool slow rpm drive. They are more durable.

It would be very helpful to have some kind of break-down of what units have experienced these issues the most? Any common threads? Is the only common thread so far a network connectivity issue? And was the network connectivity issue experienced before, during, or after the update?

Is there one version (2-tuner, 4-tuner, Quad, HDMI) that has seemed to be more likely to see issues?

Any specific hard drive mechanisms more suspect than others?

A common time of day when the update was applied by those who saw issues? (Am I wrong that the Tablo units perform some database maintenance tasks over-night? Could applying the update too long after the last maintenance be a contributing factor, IE should I focus on applying the update in the early AM hours?)

Since the recent AppleTV App update just recently fixed the AppleTV Top shelf display issues, a frequent complaint from my family members the entire time they were seeing it, I’d really like to avoid any new issues for at least a few more weeks, if at all possible?

Thanks again

I upgraded last night about 10:00pm – constant disconnects since.

I agree with @perfectfaceforradio in that isolating any common variables might help in tracking this issue down. The common issue, bad antenna, bad network, etc… I can categorically eliminate. My (Quad tuner with a 2GB WD internal 2.5" drive) unit is hardwired to my network, and has been working flawlessly for over a year; but the latest firmware update broke that. As a software engineer I realize it might not actually be the firmware, but the update process itself that caused the problem. I opened a support email with Tablo. I have 1.7GB of stored programs that my wife watches everyday, reformatting is not a viable option.


I think it is either a period network disconnect, or a reboot. Every few minutes the blue bar LED on the front of the box start flashing, and that is the disconnect. It flashes for 30 seconds or so, and then comes back. Anyone know if one can see the log files for the linux it is running?

I did a scan today to pickup a channel change and did not lose any of my settings when I did an add. Has this issue been corrected at your end? :grinning:

Did you have manual recordings scheduled? For other scheduled recordings, did you have a specific channel selected? If no, then that’s why you didn’t lose those settings.

More data on constant disconnects – It is not a disconnect, it is a constant reboot of the Tablo. Here is the note I sent in a support ticket this morning:

Some further information.

The Tablo Quad reboots itself every 2 to 3 minutes.
I pulled the internal hard disk. The Tablo Quad is stable without the hard disk. I can watch live TV without issues.

As a software/hardware engineer, I thought there could be a problem with the 2.5" internal drive and heat that somehow manifested itself right when we did the firmware upgrade. I plugged the 2.5" drive into my linux laptop, and there were no filesystem errors, fsck reportes the drive clean.

I then formatted a blank 4GB USB drive on the tablo, and copied my entire 2.5" internal drive to the new 4TB (surveillance grade) USB drive.

The tablo booted fine with this new drive, and it had all my recordings, however it is behaving exactly the same as it did when I had the 2.5" internal drive installed. The system reboots every 2 to 3 minutes.

1 Like