Constant disconnecting after latest firmware update

I did both the factory reset and reformatting my external drive. That solved my “constant disconnecting” problems after trying everything else. The factory reset didn’t fix the problem, but formatting the external drive did. Perhaps the reformat would have fixed the issue without the factory reset. I was willing to lose all of my recordings to get back to being able to use the Tablo. After reformatting, my Tablo has been working for 48 hours without any “connection” issues. Good luck!

Note: while trying to self diagnose “let’s see what happens”. If you just re-format your drive, your tablo will still show all your recordings - just not be able to play them.

The DB data storing all the configuration settings, guide and recordings data is internally on the tablo, while the recordings and associated (thumbnails, playlist, captions, etc) data is stored on the drive.

It’s kind of ok, this should get cleared up during overnight maintenance mode.

If you just factory reset, and connect your drive, it may (most likely) think you’re migrating your drive to a new tablo. Personal experience, suggest you at least delete the /DB directory. If you choose to format it on a PC, you don’t have to actually format, just otherwise delete the partition (create a new if you want) since tablo will need to format it no matter what.

Note, I’m not suggesting you format your drive or reset your tablo to “fix” a problem as a “I hope this works”… but it’s your device and you should be free to operate it yourself if that your decision. Just some tips to help you along.

You shouldn’t have to ask for someone to read you your logs.

Update a couple days later:

I have also wound up with very frequent disconnects, playback which abruptly fails completely, stutters badly, gives me an error message to visit a Tablo Roku help directory (even when stalling my AppleTV players) along with an error message (starting today) which reports no available disk space even though the disc is essentially empty. Fast forwards almost always result in blank screens and a spinning cursor. Most of my new recordings but not all of them continue to be broken into very short 1 to 4 minute slices, with an occasional recording completing correctly after 30, 60, 90, or whatever number of minutes it actually required.

Problem is in both my four tuner and two tuner Tablos. The 4 tuner unit is way more broken, failing maybe 90% of the time. The two tuner Tablo works maybe 50% of the time,

Both my initial problem a few days ago before reboot and HDD reformat which temporarily restored mostly normal functionality as well as my subsequent experience of again nearly being bricked a second time strongly indicate that in both cases some corruption of the hard disks is being created by the new firmware, not necessarily immediately, but shortly after a freshly formatted disk is connected to the Tablo.

I don’t have the same Tablo models as you do, but it’s now been 72 hours without a problem after I did both a factory reset and a full reformat of my external drive. In addition to your HDD reformat, did you also do a factory reset on your Tablo devices?

I hope that a firmware bug doesn’t sneak up on my external drive again. I’m sorry that you are continuing to have problems. If you haven’t contacted support, please do in order them to try to identify the problem so we can all have a more stable product! Thanks for your contributions to the community!

@TabloSupport , @TabloTV so is there a bug in the new firmware? Can you confirm this yet with these issues, or is this an unsubstantiated opinion?

@djk44883 @Aubrey I can confirm that so far, we have not found any new bugs that would cause connectivity issues. We are still investigating reports that come in very closely, but so far, most of these issues (as is the case for most firmware updates) are related to either a network problem or a brief connectivity hiccup that can be solved by a reboot.

Our advice is to follow the standard troubleshooting guide seen here: Troubleshooting Connectivity Issues – Tablo

And if you still have issues, to contact our support team either by email or phone: 1-844-TABLOTV (822-5688).

As a quick note: we do not recommend reformatting your drive, or factory resetting your Tablo before contacting our team to take a look. It is certainly possible that a pre-existing hard drive problem could be discovered with some investigation from our team and fixed, but we have no reason to believe drive errors would be caused by a firmware update.

Thanks! I have 2 devices, a Dual and a Quad. The Dual is kind of just “left over”, and I’ll update that later and see how things go. I know these are different devices, but do they use the same firmware? or just the same versions for a specific device?

From what little I’ve seen about stored update versions, they just seem to have revision numbers, none device specific …but I understand this may be a trade secret.

as unlikely as I hope this is true - suddenly “everyone” seem to have similar issues and coincidentally at the same time, allegedly after a firmware upgrade. Certainly this is odd.

I would bet that there are 1000’s of us that have absolutely no problems at all with our Tablo after the upgrade - almost 6 yrs now. Cheers!


1001! I just upgraded my Tablo Dual – not even taking too long or nothing. Waited out “rebooting”, then clicked done and everything seems to be functioning as expected. I can’t wait to figure out how much better it’ll be with the enhancements :wink:

I understand users have issues, but “self proclaiming” a non-existence bug can be troublesome for everyone… then again… it unlikely could be, yet unconfirmed :neutral_face:

THANKS TabloSupport

1002! Zero problems with every firmware update so far. I’m also going on 6 years with an original 2 tuner model using its original self powered 1tb hard drive.


1005, 1 OG 2-tuner, 2 OG 4-tuner models.
3 to 6 years old.


While I’m certain most people don’t have issues (I’m sure they tested it after all) it doesn’t mean that something doesn’t exist in the firmware, or the way it is delivered, that causes problems for a small subset of users. It’s practically impossible to test for all possible situations and outcomes.

I am happy for those of you without issues, but it seems more than coincidental to me that I had zero issues, then upgraded to the latest firmware, and now I have issues. Again it may not be the firmware itself and something that happened as it was delivered, but it also seems to me from other posts on here it is not an isolated issue.

I’m still waiting on hearing back from support, so I’m hopeful they can figure it out. If not I’ll try the factory reset and all else fails I am pretty sure I’m still under warranty.

Edit: and I just checked, my recordings all unsurprisingly failed last night. Never really had any issues before. A sporadic fail here or there that I chalk up to spotty reception. But i had 5 recordings fail yesterday on strong signal channels

IF, big IF, you’re absolutely certain it’s the firmware when tech support determines your issues are from the upgrade they do have a process to go back the your old firmware

You do not have to factory reset and loose everything, you do not have to format your drive and loose everything.

When you show them the firmware messed up your tablo, they can walk you through the “bank rollover” and revert to your previous version, with out

This is all speculation. If the firmware update process corrupted the HDD then even downgrading to the previous firmware won’t fix the corruption on the HDD. You’re still SOL.

As somebody who committed to the Tablo product line well before it actually was officially released, and have purchased three Tablos myself, the first in November 2014, and recommended it to countless family and friends who then went on to buy their own units, I have to say that one huge problem has remained an issue for me throughout my seven years of ownership.

The firmware and app software has been a continuing source of owner frustration. Having lived through every single release of updates of both server firmware and client app updates for Roku, Apple TV, IOS,and Nexus players, from the very beginning, there has been a pretty deadly combination of software bugs, insufficient testing, and dismissive blame of the victim. I never cease to be astonished when the words “alleged” “coincident” and “suddenly” fail to acknowledge legitimate customer complaints which all occur “suddenly” because a poor update is “suddenly” released.

There is a reason I have not posted here in at least a couple years, since there were no such problems, Only when “suddenly” an “alleged” problem in the firmware update turned both of my Tablos immediately into useless bricks Was it necessary to seek advice.

Since my previously originated thread complaining of this latest update was removed, and portions were merged with this thread, I wanted to report very positive progress solving the connection problem which many frustrated users are reporting. It is my hope that it may provide support people and consumers with some useful observations.

Below is my tentative but pretty likely solution:

I wanted to first say Thank you very much to all of you who have offered suggestions and assistance here. It is sincerely appreciated.

I’ve spent nearly a full day experimenting, rebooting, reformatting, et cetera. All of this has been in response to the firmware upgrade recently which took most of my DVR capabilities out of commission for a few days, as posted elsewhere on this forum.

What I ultimately learned was that my disk drives had both become corrupted/damaged, perhaps due to wear and tear, higher I/O traffic required by the firmware update, or some combination of both.

Even though reformatting the drives would temporarily recover some stability, the eventual “solution” was to put new drives into both of my Tablos. I have aggressively loaded both machines with very heavy work loads, using all tuners, doing a lot of shuttle fast forwards and generally high data rate activity. I am finally no longer seeing any connection problems, stalling, spinning cursor’s, or any error messages complaining of no disk space, no hard disk connection, player errors, etc.

My conclusion would be that marginal hardware combined with a more stress inducing firmware update caused my problems.

I have decided to add a third Tablo, and ordered it this afternoon. Operationally, it will replace my two tuner unit purchased in November 2014, with a quad tuner box with an SSD Samsung EVO 870 SATA drive. Compared to the SSD speed, I recognize that the peak demand for making or playing 4 simultaneous streams is orders of magnitude lower, but the low SSD SATA cost along with their low latency and no moving parts makes them an interesting alternative. Unlike some of my earlier experiences with SSDs, these drives, and especially the Samsungs, can write over 2 petabytes (2000 TB) before write “wear-out” is a problem. I also ordered a Samsung T7 USB external drive to be used on my older Tablo 4 tuner unit, just to see how it compares, and potentially enjoy the same benefits of the EVO SATA.

If my hypothesis is correct, and a marginal hard disk caused all of the totally disruptive “bricking” of my Tablos, when the update came along stressing them much harder, then I would suggest that future beta testing include a much wider range of older “compatible” discs, which may suddenly become Incompatible once the update is applied.

I will need another day or two to convince myself that the remedy I have described above is based on correct conclusions. I do think it is pretty safe to conclude that significantly increased disc traffic is at the root of this latest update kerfuffle.

That’s an interesting take. I pulled my HDD out earlier this evening and I have yet to have an issue just watching live TV. I will leave it out and see how it behaves tomorrow. I do think it may have become corrupted somehow during the update process, but I doubt it’s due to age, and hopefully it’s salvageable. It is just a 1TB HDD, not an SSD, but it’s under a year old, and it was the one that came preinstalled in the unit. Also, I’ve never filled it to capacity yet, so I doubt it’s had many rewrites.

When it was installed the HDD was noticably hot, but I don’t know if this is new since I never had a reason to check it before. So far most signs are pointing to it being a HDD issue though. Again, I’m still patiently waiting to hear back from support about it, but for now I’m going to leave the drive out and watch live TV. I’m tempted to try out an external drive on it in the mean time to see if I get any of the same issue.

“corrupted” HDD is kind of a vague and catch-all term. If the drive is physically dying, it’s reached the end of it’s life. Some have discovered bad cables can simulate this as well.

If the filesystem has some how become corrupted …repeatedly? - this is odd. Presumably maintenance mode cleans this up is possible (it’s unclear).

I’ve seen an occasional drive failure way more than I’ve seen a filesysten (ext4) become flubbed up beyond use, although it’s always possible and does happen.

But the phrase - my drive is corrupted, is vague. As here, it may have been synonymous with my drives are failing or dying, but this could be semantics.

1 Like

It IS semantics.

A few final thoughts from my Tablo reconnecting-problem after the firmware update:

  • I cannot speak to the definition or existence of a “bug” or “corruption” in any of the software and hardware that makes up my home environment.

  • I can speak to my satisfaction and appreciation of Tablo Support’s reading community posts and contacting me after their long holiday weekend. Even though my problems were solved, there are too many vendors who are totally unreachable or ignore their community forums.

  • In the absence of Tablo support while they were out of the office, I was more interested in restoring the usability of my Tablo system than trying to identify the cause of my problem, so I just started trying things.

  • My problem, whatever its cause, made the Tablo unusable with constant “Reconnecting…” messages on my Roku and “Unknown player error” on my iOS devices.

  • My problem began immediately after I chose to install the firmware update. However, it is a true statement that the timing of my problem could just be a coincidence.

  • After changing numerous network settings without any improvements, I decided to take the extreme step of a factory reset (despite Tablo’s warning against doing this unless requested by Tablo.)

  • When the factory reset did not eliminate my problem, I decided to take the drastic step of reformatting my external drive.

  • Reformatting my drive immediately eliminated my problem! But one could argue that this was also just a coincidence.

  • It is correct that had Tablo Support been in the office during my 3-day battle with my Tablo, they may have diagnosed the source of the problem and repaired my environment with neither a factory reset nor a reformat being required.

  • After examining log files from the short time between my factory reset and my later drive reformat, Tablo engineers apparently did not identify the source of my problem or tie it to the firmware update (per their community statements.)

  • Even if I were the only Tablo customer in the world who experienced the unexplained “reconnecting” problem, I do not believe that the timing of my problem and the timing of my solution were coincidences. But that’s just my opinion.

  • I also do not believe the similar “reconnecting” issues reported in the community (just 3?) are separate coincidences that are unrelated to my problem. But that also is just my opinion.

  • Perhaps my external drive is on the verge of failure for some reason and that’s the common element between other users with a similar problem. Perhaps my reformat has simply postponed my need to replace an old external drive it to avoid another Tablo “Reconnecting…” problem.

  • I agree that there are thousands, perhaps millions, of Tablo customers who have likely not experienced any problem after the update. That is a shout-out to Tablo for testing their firmware and rolling it out in stages.

  • But I also wonder how many Tablo customers have had a similar problem, but never considered joining the community or even contacting Tablo support for help. I wonder if some customers have simply discarded their Tablo or purchased a competitive system. That’s sad; Tablo is a good product!

  • Thanks for the interesting dialog!

1006 - went through and upgraded a Tablo Quad

zero issues, it didn’t corrupt my WD 7500-BPVT Blue, at least not right away … but as old as it is, hasn’t reached the end of life.