NEW - Maintenance Firmware Release - 2.2.6

Hey all,

A new maintenance firmware release (2.2.6) is available for Tablo which includes some helpful fixes to make your Tablo viewing experience better. Like 2.2.2 this will be done as a staged rollout with additional users being pushed the new load each day. All users should receive the update by Friday.

This is release includes the following updates:

Support for new 1080 streaming quality to improve buffering on Roku
Firmware 2.2.2 added the capability of Tablo to record 720p broadcasts at 60 fps (when available) when the Tablo was set to at the 1080 recording quality. This increase in frame rate caused buffering issues with some Roku models, in particular those with older hardware.

As a resolution, we have added a new recording quality which will enable users to choose whether to record at 60 fps or not but maintain a 1080 recording quality. We have also updated the choices to provide more information to the end user about picture quality and bit rate.

The new lineup is as follows:

You can get an updated overview of the different recording qualities and our recommendations here:

Fix to maintain scheduling of single-airing events across updates to guide data
Some users were also reporting the random unscheduling of recordings. We have tracked the root cause of this down to a large spike in edits and updates to guide data after it has been published and distributed by our data provider. This change will allow users to enjoy more accurate guide data without the loss of scheduled recordings.

Recovers hidden recordings
Some recordings made on 2.2.2 may have not been available for viewing in the recordings tab. This fix will restore these recordings.

Performance and reliability improvements for connecting
Added a few tweaks to improve connections to Tablo apps.

Other performance and reliability improvements
A few minor tweaks to enable future features and increase the platform’s reliability.

***** NOTE ***** The recording recovery process will take several minutes. During this time the LED will be blinking. Do not power down the Tablo until the LED is solid again.

Check out the Tablo Knowledge Base for tips and tricks on successful firmware updates:

If you have any feedback, please let us know by posting in the thread or placing a ticket with Tablo Support:


Wow, restoring recordings. I have been doing that for almost 2 weeks now. I wonder if I put my backups on another USB drive and connect it, if those earlier recordings will stay available instead of tablo thinking it needs to reformat at some point like it has twice already. I have over 1500 titles to still transfer to my PLEX using Tablo Ripper. This update would be a BIG THING if it worked for this and my backups. Right now I am manually doing this and it takes about a hour to do 20 or so.



The missing recordings aka recording in purgatory only happened with 2.2.2 of the firmware. Which has only been around for a few weeks now, I don’t think your “backup” HDDs will have any missing recordings on them.

1 Like

I’m thinking this is what this new firmware does, compares tablo’s database record to the hard drives exFAT record. I will give it another try to be sure once the update gets to my tablo.


The real question is were your older HDDs ever using the Tablo when it was running the 2.2.2 firmware? If not, then you won’t recover any recordings off of them.

No, the earlier firmware was on it. These backups were done quite a while ago. To get this backups back on a USB hard drive is to let tablo format a the USB drive as it normally does. I then do a disconnect through the settings (little red (x) ), shutdown the tablo, remove the drive, connect that drive to my Qnap PLEX server’s USB port, transfer all the content from the backup on the Qnap (less the NUVYYO file), connect it back to the tablo, start tablo, do a connect and tablo connects and syncs. At this point Tablo Ripper has access to the existing records on the disk. All the while, Tablo is thinking “What in the world is going on here” and starts to do whatever tablos do when they get confused.

So, that’s the scenario. What tablo eventually does is reformat the drive, all on it’s own. It seems to me there should be a workable method to restore existing backups to tablo and have the data from the drive be reconstructed by tablos database. I use to build databases and all the software I have use could do this by some means. Tablo is different from just about anything I have ever seen or used though, so no telling what it’s up too.


is the new fw pushed out once a day or multiple times per day?

Is it in the same order of users, or will people like me that were at the tail end of the last release get it sooner?

Every day your Tablo automatically checks in with our servers to download the latest guide data. The first X number of Tablos to check in each day will receive the update until everyone has it.

Access is randomized.

1 Like

I’m waking up at 4 am to reboot my Tablo.


Is this the same as the latest beta version?

Turning off my Tablo and getting out one of my Christmas light timers to flip on at 3:59am.

Uh oh…I’m having issues on this one. I switched over to 1080p (8mb)…and I’m having an issue where I’m not getting any video. I have audio, but the only thing on screen is the “Loading…” screen and the spinning icon. Of note…this particular Roku updated yesterday to its new 7.0 firmware. This is on both live TV and recordings.It seems to WORK maybe 25% of the time. It doesn’t seem channel-specific. I can have it work on a channel, exit out, and then go right back into that same channel and then have no video.

It seems to be playing fine on my other Roku that has NOT had its firmware updated (still on 6.2).

So…there seems to be an issue with Roku 7.0 firmware!

Edited to add: These are all Roku3’s (2013 version)

Thanks, I know your developers have been working hard on this release and glad to see it’s here.

@DaFury has a curious finding… Wondering if Roku’s update could have crossed up with Tablo’s. I’ll be interested what others with 7.0 on Roku find (mine is not yet updated to 7 series). Have you tried any other recording settings yet, than 8 Mbps?

I set it back to 720/5mbps…reset the tablo…and then reproduced the same issue using the 720p setting.

Installed the update last night, all my missing recordings are back! Thanks Tablo! Keep up the good work!


@DaFury - We have a fix for this in the version of the app we have waiting on approval from Roku. We were hoping that it would have been approved for publication well before the rollout of Roku’s new firmware but it seems like we ran out of time.

Instead, we’re going to sneak it into the already approved preview channel later today/early tomorrow. Stay tuned.

In the meantime, you can use backing out of the playback and restarting it as a workaround.


Do I have to update to 2.2.6 when it comes or can I opt out of doing it and install it later? Everything is working great right now and I am a fairly new user. I am not as tech savy as some that thankfully I rely on in the blogs. I just want all the bugs to be worked out before I install it. Again thanks to all that give me and others helpful hints to solve/answer small questions. I totally enjoy Tablo and am glad to have cut the cord, let alone that it saves me about $200.00/month on my cable bill.

Yes you can decline to update, but it will prompt you to update every single time you connect to the Tablo.

In my opinion though, update to 2.2.6, 2.2.2 introduced some bugs which were quite problematic.