Live TV won’t airplay

Everything on my tablet from apps to Tablo recordings works fine when using airplay to stream to my TV, except live TV. It has worked in the past, so what’s changed that it no longer works? And can it be changed back?

What is your tablet? And iPad? Or Android tablet?

It’s an ipad with ios 13.3. The strange thing is everything else works fine with airplay from it except live TV from the Tablo.

@jen.plaid Since we have a native Tablo app for both of the most recent versions of Apple TV we haven’t been testing AirPlay as much.

What Apple TV device do you have?

First gen. I don’t have app store capability from my Apple TV device. My first thought, since only live TV is affected, is this has something to do with a Tablo firmware update. I can watch recordings from Tablo and air play from any other app. Mirroring also doesn’t work with live TV.

Hrm… It’s been quite a while since we did a firmware update but we did update the iOS apps in September of last year: NEW - Tablo iOS App Update (v. 1.8.0)

We aren’t able to reproduce the issue here but the oldest hardware we have is a 2nd generation Apple TV.

It’s possible that the issue you’re running into could be hardware-related.

In general, we don’t recommend using AirPlay or Chromecast for primary viewing so it may be time to invest in a new streaming device.

We realize a new Apple TV is a bit of a budget buster, but there are many Roku or Amazon Fire TV devices that are much more affordable:

It’s been a while (probably before last Sept) since I’d streamed live TV, but when it had worked before and no longer does, that’s disappointing. Thanks for the advice.

I am having a problem doing Air Play from Roku devices (brand new ones, Roku Ultra 2020). Was working fine then just stopped.
I am Air Playing from either iPhone 12s or relatively new iPads.
Youtube plays fine, other streaming sources play fine.
Nothing from Tablo will stream via Air Play – just get the “This video is playing using AirPlay” on the iPhone12 screen and the spinning Walmart-looking icon on the TV (Relatively new Samsung TVs)
This was working just fine 3 weeks ago and one day while using it at friends place, it just wouldn’t. Was working minutes before, then wouldn’t. AND I HAVE TWO TABLO LITES AT THE SAME LOCATION AND BOTH OF THEM WERE WORKING BUT THEN DIDN’T.
I’ve rebooted Tablos, checked cables, and even rebooted the cable modem/router (which I suspected since other sources AirPlayed and the Tablos wouldn’t).

Using Tablo version 2.2.34

Hopefully someone has insight to the problem and can help. Thanks in advance.

Most Roku devices recently received the Roku OS 10 update. If you have rebooted your Roku and iPhone (by reboot I mean power cycle) and it still doesn’t work I would factory reset your Roku. When you re-link the Roku to your Roku account it will re-install all the channels you had before, you won’t lose any channels. I have had issues with AirPlay on Roku devices, and the only way I could fix it was to factory reset the Roku.

Of course make sure your iPhone or iPad is running the newest iOS as well.

Thanks for the quick reply. Seeing as how this is malfunctioning with three Roku devices it doesn’t seem to point to a Roku device. I’m suspicious it has to do with my in-house network. Two Tablos Lites connected by ethernet or wifi and for some reason won’t stream via AirPlay. They stream other sources, youtube, Pandora, etc. I’m still searching . . . . .

@vagent Is there a reason why you’re using Airplay versus the Tablo app on the Roku?

And on your phone, are you able to play live TV without punting it to the Roku?

Thanks for the question. I often use the “Remote Access” feature when I’m away from home. Using a smartphone/device (iPhone/iPad) allows me to access the Tablos at home then stream them via a Roku I can carry with me. That’s when this problem surfaced. I was streaming a golf recording and during the process I became unable to stream from the remotely located Tablo. I thought I would be able to resolve the problem when I returned home but alas, could not. I can’t even stream via AirPlay within my own home and network environment (which I could before).

And yes, on my phone I can play live TV. I can also play Pandora, Youtube, etc., and AirPlay them via the Roku. It’s just when streaming from the Tablo that I can’t AirPlay it via the Roku.

But you can play live TV just fine on your phone without sending it to the Roku?

Yes–just checked both Tablos to make sure :slight_smile:

On your iPhone is the Remote Streaming Quality set to Full Quality?

Can’t find anything for “Remote Streaming Quality” on the iphone itself, but I have raised and lowered the streaming thresholds on the Tablo to see if that would make a difference. The real kicker is that all was working well, and had been for months (if not years) until all of a sudden. :frowning:

Also puzzling is that it will AirPlay Youtube videos, and sound from Pandora. I know it seems like it’s pointing to something in my in-house configuration.

Each Tablo Lite is connected via Ethernet and each has a 1TB “My Passport” hard drive for storage. At one time I thought it might be because a hard drive was “failing/faulty” and couldn’t be read fast enough–but for both of them ? ? ? ?

Roku devices haven’t had AirPlay function for years so it’s only months. AirPlay on Roku is actually fairly new.

And this was the Remote Streaming Quality setting for Tablo Connect, this under Settings on the iPhone app.

I see what you mean by “Remote Streaming Quality” now – and I’ve tried mine at different values as I thought it might have been having an effect. Final setting is at “Full Quality” now.

Wild guess—disable surround sound at the Tablo.

AirPlaying surround sound-encoded recordings or live TV to a third-generation Apple TV (the 1080p-capable last model prior to the App Store on Apple TV) while on my home network displays only a still image with no audio. AirPlay to an Apple TV 4K (although unnecessary while on the same network as the Tablo) works great.

[Edit - May 18th - Tablo responded to my support ticket]
I submitted a support ticket and “this is currently a known issue that we’re working to solve ASAP”. Tablo is “hopeful that Roku will have an update available soon to address this”. This does not explain the problem with Roku OS 10 AirPlay, nor Tablo’s use of AirPlay that sees the problem.
[end Edit]

I am experiencing the same problems using AirPlay to a Roku Stick+ with firmware 10.0

To add to this discussion’s data points - AirPlay does work from OS X Catalina in Safari but not on iOS 14.5.1 in either Safari or the Tablo iOS app. YouTube and other content does AirPlay correctly to the Roku. Remote/Local Tablo Dual/Quad same results. iOS screen mirroring also does not play from Tablo DVR, but does play other content.

I was able to share a VPN connection to my Roku Stick+ to my remote location and that did perform well without using my iOS device to remotely connect to my remote Tablo, but AirPlay 2 to the Roku is not working in either the Tablo iOS app or Safari.

AirPlay to an ancient generation 2 AppleTV does still work with the iOS Tablo app, but that is a completely different protocol.

At my current location my ISP performance does not allow reliable remote access on a FireTV stick, while AirPlay to an old generation 2 AppleTV has no problem streaming live TV at 1.5Mbit quality. Recordings manage twice the throughput of live TV.

End of info.