KNOWN ISSUE - Some Tablo Apps Failing to Handle DST Time Change

Hi folks -

We are aware of an issue with some Tablo apps failing to properly handle the transition to Daylight Saving Time.

This issue will cause the time on the Live TV grid to be displayed incorrectly. New and existing recording schedules are not impacted.

The web app at my.tablotv.com has already been patched. If you continue to see this issue on the web app, try clearing your browser cache.

The following Tablo apps are still affected by this bug:

  • Tablo mobile apps on iOS and Android
  • Tablo Smart TV apps for Samsung and LG
  • Tablo apps for Xbox and Windows 10

We are currently investigating solutions to remedy the issue on these apps ASAP. Please stay tuned for details and next steps.

Tablo apps on Roku, Amazon Fire TV, Android TV, and Apple TV, as well as the Tablo DUAL HDMI are NOT affected.

UPDATE - A fix (via a firmware update) has now begun a staged rollout:

1 Like

As per the usual event the clock sprung forward 1 hour this morning, but the Tablo is still showing the guide time as 1 hour behind. I tried a system reboot and a guide refresh and no change. I don’t see a setting for supporting the time change. Any thoughts?
Thanks

What device are you using to access the Tablo? It gets the time from the client device.

I’m not sure this is correct. It seems to me that if your devices (Roku, Firestik, PC, Smart device, etc) were even a minute or two different, this would be constantly resetting the Tablo time.

I really don’t know where the Tablo gets its time, but I’m guessing that it would come through a standard source such as your ISP or through the ‘Network Time Protocol’ (NTP) over the internet.

As to the problem the OP is talking about, I don’t have an answer. My Tablo already updated to DST when I used it this morning.

Interesting, my Tablo shows wrong time too. My iPhone connected to the Tablo has the correct time, but the Tablo guide shows one hour behind. It hasn’t done this before in 6 years so might be a bug in the 2.2.32 firmware.

I hit “Update Now” on the guide data, that didn’t fix the time.

My Windows 10 desktop via .http://my.tablotv.com/.

Neither has mine using Google Chrome. I’m on Pacific time (Vegas).

I meant to say it gets the time zone from the client device. The time, as you say, is ntp.

I checked mine after I posted, and it’s time has not updated either. But the show grid is also off by an hour. So it’s actually at the right time in the schedule, but the display numbers are off by an hour.

I’m having the same issue where the time is incorrect if viewed on a Windows 10 PC using Chrome but the time is correct when I access the Tablo via a Roku device.

The time on the Tablo guide is correct on my Roku but it’s one hour behind on the iPhone. The guide is still showing the correct shows airing on both devices though.

Seeing the same as @theuser86 - time is correct via my Roku, but 1 hour off using my phone.

I’m having a time issue here as well. On the Roku, it’s showing correctly, and all shows in the live grid are at their correct times.

However, on my PC (Windows 10, Chrome web browser, PC clock is correct) the time is showing as an hour earlier, as are the shows in the live grid, so they’ll probably get recorded when they should. The Tablo app on my Android phone, as well as my Android tablet, are off as well.

I suspect the issue is with the Windows Chrome and the Android clients rather than the Tablo itself.

Rebooting the Tablo didn’t fix the time on the iPhone. I also did a channel scan and saved it on the iPhone, that didn’t help.

You are likely correct, the my.tablotv.com website in Chrome, iPhone app and Android app are all based off the same “web app” so it is likely incorrectly pulling the “standard” time rather than “daylight” time for your time zone.

I too believe the tablo device has all it’s time in UTC or Zulu time (?) and interrupts schedule to local.
example ‘http://tabloIP:8885/server/guide/status’ all it’s responses have time ending in “Z” in other queries as well.

I believe to recall, the displayed time is from the client device. It does get local time zone from ZIP and/or location during channel scan – so it knows you’re in an area for daylight saving time. Not sure how often it check NTP (likely maintenance mode).

In my web app and android tablet both show live grid AND the start times for shows to be off by an hour! I don’t recall having an issue in the past.

This is scary
[edit]
I checked my schedule with APL Tablo, 3rd party app and it shows all my scheduled show at their right times for recordings.

Best i got is 1.9.4 build 984 [202008181147] of the web app unannounced release was during the summer/fall (between Jul-Sept, don’t check regularly enough). Not sure if it’s device/app specific, but there does seem to be a trend and this is really, really… really flubbed up.

Reboots are known to set time, yet it doesn’t correct for the time adjustment - since it’s technically not wrong, just displayed wrong… in certain apps? If my device is in the Eastern timezone aka America/New York - and my client device/app is correct, what’s the hassle?

+1 for another instance of Live TV being off by an hour. +1 for multiple power cycles of the quad. +1 for multiple channel scans. +1 for accessing from web browsers on linux, Windows, MAC, and iphones all also rebooted this morning and all showing the correct time. This is a tablo issue.

What’s the problem then?

1+1+1+1 *  (reboots - power cycles) = ?

The first line says Live TV off by an hour. That is the problem. The tablo quad has been power cycled multiple times. Multiple Linux, Windows, MAC and Iphones here all adjusted automatically and properly. The quad did not. The Linux and Windows systems were used to access the tablo quad via we browsers after reboots to perform rescan of channels per multiple other threads here. The Iphones used the app to perform channel rescans. The Tablo quad live TV time remains off by an hour as though it did not adjust automatically during the night as it should have nor after all of the quad power cycles and the channel rescans.

I don’t know that this is a Tablo issue. I only say this because the Tablo app on my Roku shows everything correctly.
Not so much on my Chrome browser.
I tried clearing the cookies and local storage on the browser and restarting the browser, but the live tv grid is still an hour off. But my Sunday morning scheduled recordings are recording correctly.
So for now I just think it’s a problem with Chrome. For now, as long as my recordings are recording correctly, I’m not going to sweat it.

Well I think it’s a Tablo app issue, it seems to involve all the apps based on the web app. The time is also correct on my Roku but off on my iPhone.

Guess we wait until Monday for a fix.