Fire TV Cube not Tablo compatible

Thanks Nilwx for the info. It there is not a fix quick I will have to return the unit. Too bad because I like it but the Live Play and recordings are almost un-watchable to me.

Just got a new Tablo 4 Tuner plugged into my router. I am running a WD My Passport 2TB with it and streaming to a new Amazon Fire TV dongle. Everything recorded or “play live” seems to sutter or drop frames every few seconds. The Fire TV seems to be good as it streams other sources without a problem. The Passport is one I have had videos on and played them on a my computer without a problem. I have tried to reduce the Live TV Quality to HD 720 - 3 MBPS. I rebooted the Tuner but that did not help. I called the Support Help Phone but they are only there when I am work and I am sure they want me at the set to trouble-shoot. Any ideas on what to try? Thanks Bill

Unfortunately you are simply out of luck at the moment. Tablo is not compatible with the 3rd gen Fire TV dongle &/or cube. Amazon is unmotivated to address the issue & Tablo has yet to develop/distribute a fix.

Tablo works very well with the 2nd gen Fire TV devices & the Fire sticks, but that is of little consolation for 3rd gen Fire TV owners.

It’s not just Tablo (despite an assertion I read above that ‘everything’ else works just fine with new Fire devices). SiliconDust has a pinned entry specifically for Fire TV problems. They politely state that Fire has a … unique … method of implementation. There are also posts of stuttering regarding the Cube in the HDHR app as well.

There’s actually even more complaints with regards to latency issues surrounding the chipset used.

Could it be that this Amlogic processor is one of the first Amlogic processors to support hardware decoding of VP9 profile 2. And that VP9 is a Google video format used heavily by YouTube.

And thus h.264 and h.265 may be driven by a software library. And that this library may be supplied as part of Google Android TV - Oreo.

And that this library may not like open GOP’s where a b-frame references cross GOP boundaries. And if there is a video that demonstrates the problem and this video passes H.264 certification and not work with Amazon Fire OS Cube maybe the Cube H.264 could be decertified.

That would tend to piss off the 1000 pound gorilla.

1 Like

An news on pending updates from Tablo?

Tablo says they had a fix in testing. How’s that going?

Can’t discuss beta releases.

Become a member of the beta team.

Sadly there aren’t a lot of folks with the newer Fire TV devices in the beta pool.

Seems to be going well on our devices internally, but we’ll be offering early beta access to folks like you in the next week or so.

Stay tuned!

Probably not a lot of folks using the newer 4K FireTV devices with the Tablo product simply because it doesn’t work with them!

I’m glad to help beta test any new firmware. I expect you can contact me directly via the email address associated with this account when the time comes. Please be aware I will be out of the country starting next week and not returning for several weeks. I wont be able to test anything until the second week of August or so…

How is that done?

Do you have a DUAL LITE?

Go here: LF: Tablo DUAL LITE owners to join Tablo Beta team

Any other type of Tablo?

Go here: NEW - Join Our Firmware & App Beta Team!

Got it! Thanks!

I have a feeling this issue will get much more traction given Prime Day sales of Amazon devices. I am generally an early adopter (I got a Tablo very early, Roku, etc.) and I have had the Fire TV Cube since day one. I really like the Echo integration and find the voice commands and device control useful. So, you can imagine how annoyed I was when I tried to watch the World Cup final on a stuttering Tablo app.

Regardless, I bought three more Fire TV Cubes and a few Fire TV Sticks on Wednesday and will make the switch from Roku to Fire TV this weekend. I still find Tablo to be very useful and hope that the app can be fixed quickly. I just registered for the beta program and will be happy to provide feedback if included.

Hey folks - A firmware workaround is on the way:

Just wanted to let Tablo know the stuttering workaround is not working.

I have a Fire TV 4k (3rd Gen) with the newest OS ( (NS6253/1437) along with the newest Tablo Version (2.2.22) - The stuttering is still there. Tried different bit rates, etc. I assume there is no setting I have to set to enable the “workaround”.

I have tried the Tablo app, the Tablo Preview App - still stutters. The stuttering is not as frequent as it used to be, but still freezes every 15-20 seconds for a second (gives the buffering symbol).

I am surprised at how long Tablo is taking to get this problem fixed. I know Tablo will say it is Amazon’s fault, but given basically all other streaming services/devices are working just fine, there is obviously something that Tablo could do to take care of this. The stuttering issue on newer FireTV devices has been going on since the end of last year - it is almost like Tablo wants you to go to another OTA device like HDHomeRun. The new Fire TV devices will continue to become more common and Tablo can’t get their product to work with it. Very frustrating.

…or another streaming media player, like Roku.

As mentioned in the other thread you posted in, this sounds like true buffering and not the stutter.

1 Like