Constant disconnecting after latest firmware update

A few final thoughts from my Tablo reconnecting-problem after the firmware update:

  • I cannot speak to the definition or existence of a “bug” or “corruption” in any of the software and hardware that makes up my home environment.

  • I can speak to my satisfaction and appreciation of Tablo Support’s reading community posts and contacting me after their long holiday weekend. Even though my problems were solved, there are too many vendors who are totally unreachable or ignore their community forums.

  • In the absence of Tablo support while they were out of the office, I was more interested in restoring the usability of my Tablo system than trying to identify the cause of my problem, so I just started trying things.

  • My problem, whatever its cause, made the Tablo unusable with constant “Reconnecting…” messages on my Roku and “Unknown player error” on my iOS devices.

  • My problem began immediately after I chose to install the firmware update. However, it is a true statement that the timing of my problem could just be a coincidence.

  • After changing numerous network settings without any improvements, I decided to take the extreme step of a factory reset (despite Tablo’s warning against doing this unless requested by Tablo.)

  • When the factory reset did not eliminate my problem, I decided to take the drastic step of reformatting my external drive.

  • Reformatting my drive immediately eliminated my problem! But one could argue that this was also just a coincidence.

  • It is correct that had Tablo Support been in the office during my 3-day battle with my Tablo, they may have diagnosed the source of the problem and repaired my environment with neither a factory reset nor a reformat being required.

  • After examining log files from the short time between my factory reset and my later drive reformat, Tablo engineers apparently did not identify the source of my problem or tie it to the firmware update (per their community statements.)

  • Even if I were the only Tablo customer in the world who experienced the unexplained “reconnecting” problem, I do not believe that the timing of my problem and the timing of my solution were coincidences. But that’s just my opinion.

  • I also do not believe the similar “reconnecting” issues reported in the community (just 3?) are separate coincidences that are unrelated to my problem. But that also is just my opinion.

  • Perhaps my external drive is on the verge of failure for some reason and that’s the common element between other users with a similar problem. Perhaps my reformat has simply postponed my need to replace an old external drive it to avoid another Tablo “Reconnecting…” problem.

  • I agree that there are thousands, perhaps millions, of Tablo customers who have likely not experienced any problem after the update. That is a shout-out to Tablo for testing their firmware and rolling it out in stages.

  • But I also wonder how many Tablo customers have had a similar problem, but never considered joining the community or even contacting Tablo support for help. I wonder if some customers have simply discarded their Tablo or purchased a competitive system. That’s sad; Tablo is a good product!

  • Thanks for the interesting dialog!

1006 - went through and upgraded a Tablo Quad

zero issues, it didn’t corrupt my WD 7500-BPVT Blue, at least not right away … but as old as it is, hasn’t reached the end of life.

Interesting. Customer support got hold of me and I rolled back my firmware to 2.2.30 and I haven’t had any issues, even using the original HDD without formatting or anything. It’s been almost two days since the rollback and no reboot or disconnect issues at all. All my old recordings work and live TV functions perfectly. Everything seems just as it was before the update. I’m tempted to try to reinstall the update and see if it works and maybe the installation was botched, but i think I’ll wait and see what customer support suggests as the next step. Everything is good now, but it’s just a slight annoyance to click “update later” every time I start up.

As a side note, I did try to use an external drive with the old firmware and didn’t have the same issue, but similar (lots of excessive loading and buffering). I think whatever happened to my updated was making the HDD read/write excessively, since the drive was always being accessed, even when the tablo was idle. This doesn’t seem to be the case with me with the old firmware running. Also the HDD isn’t noticably hot with the old firmware. It’s warm, but it seems like a normal temperature now.

:tada: :fireworks: great you’re able to be up and running (yes, tablo’s live tech support can be helpful but their restrictive contact time is a super PITA for too many :frowning: )

The something went wrong - thing, is another possibility never really brought up (I don’t recall). I can see your temptation to chance it again, while at the same time… do you really want to?

One note: tablo has noted their updates are “rolling” - that is when (made up number, but they seem to be even numbered) 2.2.34 comes along, it will include the updates in 2.2.32 …unless the new enhancements somehow superseded them.

That’s one thing I was worried about. On the next update, if I install it will I be able to still fall back to the 2.2.30 or will it then use the 2.2.32 as the fallback, even if I’m still running the 2.2.30 when I install whatever the next iteration is. That’s definitely something I’m going to ask support about because I have a stable build now and I’d be reluctant to update if it means I’ll lose functionality.

I truly don’t know, but logically, you can’t fall back to a point you never were at… I kind of recall they do each upgrade sequentially, so, yea you would have been at 2.2.32

Although there were 2 upgrades relatively close together 2.2.28 and 2.2.30 I had a notice for each, not just the latest, even though some where they posted each upgrade is rolled up in the next, here’s some discussion about sequential upgrades


2.2.28 released February 2020
2.2.30 released June 2020

That seems around 4-5 months.

I can help this far Search results for 'new firmware release @TabloTV' - TabloTV Community.

“relatively close”

2 —used to say that something is true or correct as a general statement even if it is not entirely true or correct

2.2.26 - April 2019
10 months later…
2.2.28 Feb 2020
4 months later…
2.2.30 June 2020
That’s my relatively close, you may view it as quite awhile

really? that’s it?

I started having the disconnecting problem after upgrading my router to a Netgear Orbi mesh network for better performance in my home office. My Roku ultra in my living room is connected via ethernet and doesn’t have any issue. My Roku soundbar in my master bedroom had the constant disconnecting so I did some research and found this thread. My solution was to power off the Tablo, connect a USB flash drive, power back on, format the flash drive and check operation on each Roku by watching live TV. Powered off, replaced flash drive with my USB hard drive with all my recordings and powered back on and checked operation. Problem solved.

I just moved and we spend more time unpacking than watching TV. The other day our firmware update came and since we updated we have not used Tablo much but I heard a clicking noise around the same time our Tablo started shutting off. I went in and listened and it was the external HDD which was very hot. I went into settings and it said I had no external storage connected. I thought I had a bad HDD until I read all of this. Now I will be looking at the HDD closer

Its been a nightmare since the last update. I’ve spent more time rebooting tablo than watching anything. Everything worked perfectly… then update and it was a mess. Contacted customer service, they said it was my hard drive. Replaced and no change. $200 later, new hard drive, new tablo, still a nightmare. Seems Tablo made a huge mistake and wont take responsibility. Shame what greed will do to consumers.

Sorry you are encountering issues. I’ve been running an OG Tablo 4 tuner on the latest firmware for months and other than weather related reception issues I’ve not had any issues. If you are still encountering issues after replacing both the Tablo itself and the hard drive, what other things could be factoring in? Has your reception changed as a result of the seasons at all?

Hi @CJ_Hetle - Sorry you’re having a rough time. I’ve asked the support team to reach out to you.

I have had problems since the last FW update also. I have been working with support for the last 3-4 weeks, but they have no solutions. My problem seems to be related to when I try to view my tablo content directly through the “google TV OS” app on my brand new 65" sony tv. I get pretty regular “endless spinning circle” on my screen and then a message that says “lost connection” or “cannot connect to Tablo”. The last time this happened last week, I immediately switched from using the tablo app directly on my TV to using the tablo app on my (older) roku. The app on the roku worked fine and I have no problems with it.

Support wants me to try putting my TV on my 2.4G wifi network because they are blaming wifi problems. I don’t believe this at all, since all of my other streaming apps (netflix, disney +, amazon video, apple TV) all work perfectly directly from my TV on the 5G wifi. Also, my router is only about 5-6 feet from my wifi router.

This is VERY disappointing, as the tablo worked very well for the first 3-4 months of ownership, but now it requires regular rebooting and constant “messing with” to even get it to work.

Just a friendly reminder that isn’t an apples to apples comparison.


He @patterbt, had you been using the Tablo app on your smart TV before the firmware update as well, and it was better behaving? Or did this behaviour start when you got the TV and used the app on it?

Also to address your Netflix/Disney+ comparison, those apps just require an internet connection, by any means. Whereas an app being able to see a Tablo on your home network is not quite the same process. It involves looking at just your local network (LAN) to see if the device with the app is able to ‘discover’ other devices on your same home network, irrelevant to your actual internet access. Sometimes the Wi-Fi network frequency can affect what devices are seen. This is actually common with many smart home devices and systems.

Yes, I had been using the app on my smart TV before the firmware update. It would very occasionally lock up and need a reboot but not nearly as frequently as it does now. The thing I don’t understand is that my roku doesn’t have this same continual lost connection problem, and it is on the exact same wifi network as the TV; so I really don’t think it is a network problem. I truly believe there is some issue with the new firmware, my Tablo worked great for a good 3-4 months before this last update.

If your Roku can access the Tablo without issue, then that can rule out the firmware update, as that is specific to the Tablo, not the app you use to access it. Is it possible the TV itself also got a recent update? Those can happen automatically in the background if you have it set to, and could also be the cause of your issues.

This brings me back to the entire point I have been trying to get across to the customer support person. I told them that I believe the problem is with the “Google TV OS” app that is on my brand new Sony TV. I think it is somehow related to that app, since it seems to be the source of my problems. I think my TV did get a firmware update when I first unboxed it, about a month or so ago. I don’t have the firmware numbers for the google TV OS, but I can try to look that up if you think it would be helpful.

Based on what you said previously with my roku being able to access the tablo without problems, doesn’t that also rule out wifi network issues?

If it’s possible to see when the TV was last updated, that would be helpful for establishing a timeline to see if it coincides with your issues.

And no, it doesn’t unfortunately rule out network issues, but the network issues in this case would be an issue with your TV’s wifi module or driver specifically. Certainly not saying that’s guaranteed to be the problem, but it looks like we have isolated the problem to be on your TV. Have you tried switching to 2.4ghz as a test to see yet?

Another thing you can try is if you have a smart phone, download the Tablo app for it and see if your phone can see your Tablo. That would be further confirmation.