Can’t stream over T-Mobile One Plus Unlimited Plan


#1

I can use Internet Connect over WiFi and using an AT&T 20GB plan, but my new T-Mobile Plus (HD Streaming, Speedtest 20Mb) plan connects to my Tablo but will not stream video (spinning circle of death in the middle of the screen). All other streaming services (Netflix, YouTube, Directv, etc) stream fine in HD.

I’m assuming this has something to do with the Unlimited plan trying to force 480P and Tablo not negotiating it properly. That is why I added Plus to the line which allows other services to stream in HD, but Tablo still hangs playing video.

Has anyone been able to stream Tablo over a T-Mobile One/Plus plan? Thanks,

Steve


New phone Tablo connect problem
#2

I have the T Mobile One 55+ plan, and have no issues streaming Tablo content. Tablo remote streaming quality is set to 1 Mbps.


#3

I’ve tried all the data rates, but 1Mb is where I started. What device are you using? I have an iPhone 8+ and and iPad Pro both running iOS 11.1.1. I could try calling T-Mobile but I doubt they know or care about Tablo.

Since AT&T works fine on my other iPad I have to think it’s T-Mobile causing the issue.


#4

I’m using an Android phone, A Samsung Galaxy S6. It’s Android 7.0, but that probably doesn’t help you. Odd that AT&T works, as their network is similar to T Mobile.


#5

I think the difference is my AT&T plan is a limited 20gb, as opposed to the unlimited T-Mobile plan. AT&T doesn’t care what I stream since I’m capped at 20gb. T-Mobile limits my streaming to reduce the amount of data I can use, sort of a limited unlimited plan!

I think it’s something in that negotiation to reduce the Tablo data rate to 480p that is causing the issue. I’m at a loss to explain why your unlimited plan works and mine doesn’t. Everything else over T-Mobile is fine, Tablo is the only app that won’t stream.


#6

Just to confirm the Tablo Connect (aka remote streaming) works fine on this cellphone when using a WiFi network out of the house?


#7

I have 2 IPs at my house, so I can test the remote access by connecting to the WiFi of the other router. I’ll also be able to test today by connecting to my work WiFi. Since AT&T works fine I’m reasonably certain it’s T-Mobile that is causing the issue.


#8

Also, over T-Mobile I can connect to my Tablo fine, I can see my recordings, settings, etc, I just can’t get it to stream video. I can stream several other video sources fine like YouTube, Directv fine.


#9

Let us know how it goes with the work WiFi.

Your 2 IPs at home aren’t over a VPN or something? They are actually two separate Internet Connections from different ISPs?


#10

Yes, they are 2 isolated networks. I pay Comcast an extra $5/mo for a second IP. Each network has it’s own router and external IP. I use it for testing like this all the time. If I turn off Remote Connection I can’t even connect to the Tablo from the other network.


#11

This may help figure out the issue. The first screen with the normal blue wait circle appears on the screen for about 5 seconds, then the second one which looks like the video viewer application appears with the loading circle near the top. It’s this one that hangs forever.

I took screen shots of the images but I’m not sure how to upload them.


#12

Just tried it on the Starbucks WiFi in my work building and it works fine. Definitely an issue with how T-Mobile negotiates the bitrate, or, an issue with the Tablo iOS video player playing the resulting stream.


#13

l have the same problem with T-Mobile. lt used to work fine. T-Mobile passes the blame onto Apple/Tablo so they are no help.
Interestingly if l hotspot one of my T-Mobile lines to my iPhone lt will stream just fine.


#14

Ok, so I’m not the only one! Have you tried raising the issue with Tablo Support? There must be something they are not implementing that is causing this. Surprisingly upgrading to One Plus which allows HD streaming does not fix the issue. I think it’s still worth the $10/mo for my iPad Pro to not have to watch 480p Netflix!


#15

Yes, Tablo suggested lt was on T-Mobile’s end. Turning binge-off does not help. Even streaming through the website does not work.


#16

I have the old Tmobile 10GB plan and did not have problem with the remote streaming on my S8.


#17

I’ve also been unable to stream on Tmobile, but can on WiFi


#18

I think this is as simple as Tablo supporting resolution negotiation and adding a setting to the Remote Streaming Quality dropdown. I see they are aware of the issue but given more mobile services requiring this, maybe they will finally implement it.

Funny thing is, I added HD Streaming 1080p to one of my T-Mobile lines and I still can’t stream Tablo at any bitrate! I can however stream Netflix at 1080p, just not Tablo at 500kbps (sub 480p quality)!


#19

I’ve been reading the fine print on the T-Mobile plan, and they consider DVD (480p) quality to be 1.5mbps or less. I’ve tried all of those bitrates in the Tablo settings down to 500kbps and they all fail. It would be nice if they would allow the lower bitrates but I guess it’s the negotiation of the resolution that is failing.

Just for yucks, I’ll try calling T-Mobile and see what the party line is!


#20

Just tested on my T-Mobile 55+ plan (Pixel XL phone)…and it streams fine for me, even at home a 1 bar LTE signal. Have my Tablo remote streaming set to 1Mbps.