Windows 10 Exception Error

My Ripper has been working fine until a couple days ago when I received an error

“Exception: The underlying connection was closed. An unexpected error occurred on a send.”

I tried restarting the program, restarting the computer and uninstalling and reinstalling the Application with no success. I’m still getting the same error. Any ideas as to how to fix this issue?

Follow this thread if you are talking about Tablo Ripper. I’ve already provided details to the developer and that’s the official Tablo Ripper thread the developer monitors.

I’m on Windows 8.1.

Just downloaded Version 2.4.1, 64 bit. Typed Tablo in the Select Tablo box. Hit Refresh. Get the same error, “Unexpected Exception/Exception: The underlying connection was closed. An unexpected error occurred on send.”

Do I need to download the latest version of Tablo Ripper? Is there something else I need to do?

Added my email credentials in Notification tab and hit test. Sent successfully.

In Configuration, what needs to go in the File Paths tab > Output Folder\ box and Post Processing box?

In the background (behind the Unexpected Exception box) there is a box that says Load Recording List - Initializing. But it never completes due to the exception.

I leave the Post Processing box empty for my purposes but the Output folder should be the path to which you want it to export the ripped file (i.e. C:\Rips, etc.).In the Configuration table there is an Enable Logging check box. Check it, try hitting refresh again and then on the main screen in the upper right there is a Log File link. It will open the log file so you can look for more details it may log that will be helpful in resolving your issue.

What version of Tablo Ripper do you have installed? I have 2.4.2 installed and don’t have any issues but it does look like there is a 2.4.3 available that fixes a TLS related issue. I don’t know if you could be running into an issue with Windows 8.1, I’ve always run Tablo Ripper on Windows 10.

Finally got Tablo Ripper to recognize my Tablo device by putting in the IP address. I use HULU. Found IP address under TABLO (top menu item in TABLO on HULU, then scrolling down.

Still have trouble getting the copied files to go where I want them to. I can get them to go to the right Drive, but not the right folder. Which means I have to copy them to the correct folder. Everything takes an eternity.

I’m still playing with it, so hope I can get that figured out. Anyway I’m getting output and can view the files on my laptop. That’s what I was trying to do, so yeah!

Sorry, I totally misread your first post about this. If you typed the word ‘Tablo’ into the Select Tablo box that would have been the root problem causing the error. As you found out, you can enter the IP address in the second box but for the Select Tablo box you would want nothing in the IP box and would just want to click Refresh with nothing in the first box and it should populate with the name of your Tablo. In my case I get this…


The ONLY way I can connect to my TABLO in the TABLO Ripper App is to leave the “Select TABLO box” blank, and put the IP address in the “TABLO Static IP” box.

If I click the down arrow in the Select TABLO box, is TABLO Ripper supposed to automatically find my TABLO and connect? It doesn’t for me.

Not until you click Refresh and it populates with the name of your Tablo. If IP address is working I’d just go with that for now.

Correction: My TABLO is running with ROKU not HULU. Sorry. Dan

To select the Output Folder you can click on the box with the three dots to the right of the field and then navigate the folder list to find and select the folder where you want to put the exported files. You have to create the folder first of course before doing the selection.

That was helpful. Obviously I wasn’t keying the path correctly. Much easier to pick the folder and let TABLO Ripper auto-populate the Output folder. Thanks, Dan