When will Tablo be fixed on Windows?

I’ve been unable to use my original dual tuner Tablo on Windows for a couple weeks now. This is both Chrome and the Windows 10+ app. I even tried FireFox as well, same deal.

When looking at reviews of the app, I see I am not alone. All the latest reviews are 1 star and some say the same thing (works fine on Smart TV, Phone App, etc, but not Windows).

When I go to my.tablotv.com, sometimes my browser doesn’t even find my Tablo. If it can find it and I try to connect, I’ll get the error “A connection to your Tablo could not be established. Please check your internet connection.”

Sometimes if I sit and endlessly press “connect” repeatedly, it’ll eventually connect and I can use everything just like normal (until I close out and try again).

Is this a known issue? I’ve tried on both a Windows 10 and Windows 11 PC. I’ve turned off all firewalls, I’ve factory reset my Tablo multiple times, nothing helps.

Tablo is working fine on my PCs using Windows Edge browser and the Tablo app. Both Win 10 and Win 11.

That being said when I have my VPN enabled on my PC neither the browser or the Tablo app can connect. Are you using a VPN?

There have been post similar topic. Often it concludes with some security application or add-on/extension.

Have you tried either browser in safe-mode, disabling any extension or add-ons. Do you have third party protect-you-from-yourself type of protection running on your windows system?

Do other devices or apps work alright? Does your router have some advanced configuration settings?

If you enable HTTPS only this likely causes issues, tablo it’s self, on your local network is non-S - HTTP only.

I have this enabled and it is only an issue once until you tell (in my case Firefox) that it’s ok to open. After that it works without interruption. Using Windows 10 and 11 in my case.

While some of this is relevant, see below for my real problem.

I noticed this Friday since it is affecting discovery with TabloTools as well and sent a note to Tablo support yesterday, but unsurprisingly have not heard back yet. I don't believe there's anything you/we can currently do to fix it. As best I can tell, the problem starts with their server that helps "discover" the Tablo(s) you have (https://api.tablotv.com/assocserver/getipinfo/). The my.tablotv.com web app definitely relies on that and I'm experiencing the same thing you describe. One caveat - if you've used that website previously, your Tablo(s) may be cached there (not on the server I linked) and you may only experience the "connection could not be established" part of the issue. Opening a private/incognito/etc tab (or clearing your cache/cookies/etc) will allow you to experience having only 0 or 1 Tablos found (and you should still have connection issues). FWIW, for me that was all using Firefox on Linux, so this doesn't seem to be OS (or, as you noted, browser) specific. I haven't used the Tablo Windows app, but guess it works similar to the web app if it's exhibiting the same problems. I do use the Tablo Roku app and haven't had issues, though suspect that's partly because my Tablos are cached there. Connecting and viewing works fine, however, so that app may also function quite different from the web app under the hood.

FYI @jesse - no issue with TabloTools here (Win10).

The browser app works on my windows 10 with firefox 107 and chrome 107 in regular and incognito mode. No problem finding and acessing all 3 of my tablos. Must be the app.

The web app is working my …Chromebook.

Working with Debian Linux via Firefox (^F5 reload to double check).

Working with Tablo Tools - click Rediscover, shows both and Reload updates recordings.

No VPN. I disabled malwarebytes and windows firewall, I’ve tried incognito, I’ve tried no https, all have the same issue.

In chatting with the Tablo folk this morning, I realized that the problem I’m having is that my Public IP address recently started constantly changing - like almost every time I hard-refreshed https://whatismyipaddress.com/ . They confirmed that if that is happening, many things just aren’t going to work correctly, so it may be worth checking to see if that’s the problem you’re having.

FWIW, I’m using Tmobile 5g Home Internet (for almost a year now) and this is definitely something new that started with happening with them semi-recently.

Well, this must be it then as I too have T-Mobile Home Internet. It’s worked flawlessly until a couple weeks ago, so yeah, something must have changed with them.

They do a IPv4 to IPv6 tunnel, so I’m sure the IPv4 address could be changing constantly.

Edit: I guess I never thought of this before, but this means when the Internet is down, the Tablo is unusable on a PC. I assume other apps like iOS, Roku, etc all work OK since they seem to connect directly to the device.

I constantly refreshed whatismyipaddress.com while trying to connect to my Tablo and my IP did not change, yet I could not connect to my Tablo.

A minute or two later it did change though.

That’s pretty much correct. I had to update a few things after running into this, but TabloTools will allow you to connect to and watch live tv from your Tablo on your PC even if the internet is out (or this nonsense is happening). It is limited in that respect, though - no guide, scheduling, etc., but that’s also not it’s purpose.

This is a pretty advanced work around. If you have Windows 11, you can install the “Windows Subsystem for Android”

Use this link for instructions: How to sideload Android apps using WSA on Windows 11 | Windows Central

You can then sideload the latest Tablo APK to your system and run the Android App within Windows. It even puts an icon for Tablo in your start menu and everything. I got my APK from here:

Edit: I suggest uninstalling the Windows app if you do this, as I confused myself earlier thinking it didn’t work the next day, but I was accidently launching the Windows app instead of the Android.

You can also use 3rd party emulators for Android, but the Windows “built in” solution will be nice for my family, as once installed it’s like any other Windows app (vs having to train how to launch an emulator and then app in the emulator).

If you’re going this far, you could choose to just drop Windows and switch to an user-friendly Linux distribution. Maybe even a Mac or possibly ChromeOS.