Website Requesting Disc Space

I am having an issue with the Webapp using Safari & Chrome.  Most updated versions of both, running on a MacBook Air 1.7GHz i7, 8GB RAM.  Brand new 4 Tuner Tablo, opened it Saturday.  See screen shot below.

Doesn’t matter if I click Allow or Don’t Allow it keeps popping back up every 5-10 seconds until I close the tab.  Any ideas?

I can’t seem to insert the image, so here is the link:

Are you getting the same error message when using Chrome? I have been using for a couple of weeks and haven’t seen this message once.  I’ll try on Safari and see what it does…

It is requesting that you allow the website to store a local copy of the DB on the local HDD… thats normal.  @mtuckman, once you provide permission the first time it shouldn’t ask again.

there are several threads disucssing this, and its pros/cons.  Once thing you may notice is thgat periodically things are out of sync… You will have to remove tablo from webcache and then re “sync” the browser with the device…

Dumped the cache and attempted to re-sync.  Stuck at and will not budge.  I keep clicking allow allow allow, nothing. Just keeps popping up over and over.

I do not currently have a HDD plugged into the Tablo, have one being delivered tomorrow.  Could this be the part of the issue?

odd… shouldn’t be an issue.  If you hit allow what happens?

I assume you have enough disk space on your local machine yes?

I hit allow every 5 seconds when I get the popup, it goes away and pops back up after 5-10 seconds.  

Yes, I have plenty of local space.

Okay, strangely enough when trying to sync with my iPad Air it gets stuck in the exact same location.  The tablo app is un-usable on it.  However, it works just fine on my iPad Mini Retina, no syncing issues at all.

Maybe I need to reset the tablo itself and try again with the iPad Air and MBA Webapp. 

i would yeah…

Also can you give chrome a try?

I know for certain when I first synced on my MBP using safari (i don’t use safari, but tried it for this thread)  I had to hit allow at least a dozen times.


I reset the tablo and set it up with Safari on my MBA.  Everything setup just fine, same syncing issue.  Loaded up G Chrome on MBA and didn’t even ask me to sync, everything works fine on Chrome (not my primary browser.)

iPad Mini Retina synced up just fine.

iPad Air still won’t sync either…  I am utterly confused at this point.


try hitting safari again now that you have synced with chrome.  shouldn’t make a bit of difference and should still fail, but just curious what happens.

Safari is working now.  I think i may have discovered the culprit.  

When I first loaded Safari I had changed the default load page for in GChrome to go directly to Live TV instead on the PrimeTime page.  Which loaded up on Safari when I pointed my browser to  It asked me to allow it 10MB for cache, to which i allowed, then I clicked a live channel.  However, I had to click my screen to allow flash because of the Click2Flash extension (I despise flash). 

This made me curious, so I went into the Click2Flash settings and set it to always allow, reloaded the site, and viola, didn’t ask me to allow and everything is working fine.  So that is what I am blaming it on!

Still isn’t working on my iPad Air though :frowning:

ah ha!  nice.

ipad air – try a browser… maybe it is something goofy with the app that is not working.

also try removing the app and reinstalling it from the app store.

@apathy96 - It’s a bug.  I just got the same thing on Safari on OS X (Safari on iOS is fine).  I don’t believe your theory on the culprit is correct.

I had to kill the tab as it wouldn’t not stop prompting.  When I tried again, I got a single prompt and it worked.  This is a regression; but as bugs go, not too bad.

Hey all, just tried to reproduce. Safari asked me I believe 3 times. First time for 5MB, then at 10MB, then at 50MB. All is well. Are you possibly getting prompted at the 50MB mark repeatedly? There’s a hard limit of 50MB in iOS, but I wasn’t aware of a limit for OS X. Perhaps it’s being enforced there too.

We’ve found 50MB to be plenty, but if we are hitting this wall in the wild, I’ll have to think hard on how to optimize what we store.

EDIT: just tried again, first prompt was 10MB, then 50MB, and then it went through. So prompted twice, but my DB is under 50MB. I’m working on finding a testing Tablo with a bigger DB.

Just managed to sync a fairly large DB – this one prompted me at the 100MB mark. Everything went well…

Obviously it’s happening for you guys so we just need to bridge the gap here. Could one of you copy/paste the console logs? You can find them in the Safari menu under Develop -> Show Error Console. That might give me some insight 

The 5, 10 and 50 prompts are what I always got also. When I encountered the problem, it was the 50MB prompt repeatedly – perhaps 5 seconds apart. Closing the window and trying again solved the problem. I’ll take a look at the error console on that box and send anything interesting in a follow-up.


OK, I deleted the database and then connected to my Tablo 2-tuner.  I got a prompt at 10 and at 50.  It worked.  I have the log, but it's not that interesting other than the following two pairs of lines:

[Warning] WebSQL QUOTA_ERR 4, will retry in 5000  (76362a89c52c6f7a0165a4ad63e66c56ff9f7f49.js, line 14)
[Log] WebSQL retrying QUOTA_ERR 4 transaction... (76362a89c52c6f7a0165a4ad63e66c56ff9f7f49.js, line 14)

[Warning] WebSQL QUOTA_ERR 4, will retry in 5000  (76362a89c52c6f7a0165a4ad63e66c56ff9f7f49.js, line 14)
[Log] WebSQL retrying QUOTA_ERR 4 transaction... (76362a89c52c6f7a0165a4ad63e66c56ff9f7f49.js, line 14)

QUOTA_ERR` 4 The statement failed because there was not enough remaining storage space, or the storage quota was reached and the user declined to give more space to the database.

I then connected to my Tablo 4 tuner and had no issues (and no storage prompts).

If I can duplicate the problem, I'll be sure to send the entire log.

@jkline OK thanks. I have a feeling something else is at play. The problem with how I’m testing is that I start with a clean slate each time (i.e. I go to Safari’s settings and Reset everything). I wonder if there’s some sort of side effect happening. Perhaps an older version of the database that didn’t get dropped properly (this has happened to me before, but not in a long while)

Web-based App

My i Pad air: Safari website data  17.9 MB  after asking of 5mb the 10mg then 25 mg  and works.

both My iMac's  OSX 10.9.4 repots error  after asking for 5 mg then 10 mg  then repeats this:

Allow this website to use space on your disk?
The website “” is requesting 10 MB of disk space to store “tablo_SID_5087B80036C1” as a database on your disk. Currently, this website is allowed to use 10 MB of disk space. is not asking for enough space before sending the database and repeats asking for less space than it needs.     the data base is displaying and working correctly in the Safari window when the error is not displayed.

My iPhone 5  

Web-based App

Initializing database

Checked Safari  advanced  Website Data 16.0 KB