Try Automatic Commercial Skip Again for Free (Sept 15-29th, 2020)

We know cord cutters love free stuff which is why we’re inviting you to try our Automatic Commercial Skip feature again for free!

All of the details are on the Tablo blog:

If you have any questions or need help getting the feature enabled, don’t hesitate to ask your questions below!

ENJOY!

2 Likes

I activated the “Commercial Skip Detection” checkbox in iPadOS Tablo app yesterday afternoon, but I still don’t get the skip bar on the playback screen of Chrome and iPadOS tablo app (on programs that were recorded last night). Did I miss something? Do I need to reboot the Tablo device after checking the checkbox? Thanks!

Make sure it’s enabled within the playback screen…

https://www.tablotv.com/automatic-commercial-skip/

There are specifics toward the bottom of the page depending on the playback device you are using…

image

Sounds like you did everything right unless your Tablo hadn’t recognized that it had access to the Premium Service yet? If so, the box would be there but not necessarily clickable. Perhaps you clicked it but didn’t realize that it didn’t ‘take’?

Definitely worth hitting refresh on the subscription section to make sure Premium shows as ACTIVE and then taking a second look at the checkbox to make sure it’s clicked.

@Nilex is also right that it might just be turned off in the player itself since on iOS/web you don’t get the success/failure messages.

thanks @TabloTV and @Nilex. I realized that yesterday after I checked the box in my iOS app (but did not click Refresh), my Premium still showed Inactive. I checked the box again today in Chrome web app and now Premium shows Active. Maybe either the iOS app was acting up or a Refresh was needed after checking the box. Hopefully it will work fine from now on. Thanks!

1 Like

RTFM - https://www.tablotv.com/blog/try-tablos-automatic-commercial-skip-feature-again/

Here’s how:

  • Go to the SETTINGS screen of a compatible Tablo app
  • Under SUBSCRIPTION, verify that your access to the Premium Service subscription is ACTIVE , if not hit REFRESH to activate
  • Under GENERAL, set Commercial Skip Detection to ON
    Commercial Skip Detection should already be ON for those who tried it previously

Did you refresh your subscription and verify the Premium service is active? Before the check box?

Thanks for the hint. The Premium service is active now so hopefully everything is good :slight_smile:

1 Like

Error Message: Recording does not meet criteria for Commercial Skip
Not listed at Automatic Commercial Skip Error Messages
Due to being a Manual recording (scheduled)?
Tablo Knowledge Base needs to be updated.

Also, at what point in the logic are ‘FILTERED: Program ineligible for Commercial Skip’ determined?
If 90% of the recordings are filtered as ineligible, are we still pumping (giga)bytes up the pipe for naught?

Yes, manual recordings lack ‘program type’ details and therefore are ineligible.

Network (i.e. PBS), program type (i.e. manual), and show-level (i.e. Bonanza) filtering are all done at the Tablo device level, meaning those recordings will NOT be uploaded to the Commercial Skip Server for processing.

The only potential difference is for shows that are being removed from the filtered list… Let’s take Jimmy Kimmel for example… It’s the last Late Night show returning to a regular in-studio format and is still filtered at the moment.

Once it returns and is removed, in order for it to be uploaded ANY OTHER eligible show must be uploaded successfully first in order for the filtered list to be updated and therefore allow uploads of Jimmy Kimmel again.

Thank you for the detailed explainations.

Still works no better than the last time we were able to use the feature for free. Used it on different programs, different channels–still no go! Feature doesn’t always skip commercials, suddenly skip the commercial BEFORE the commercial break actually starts, return from skipping a commercial past the point where the programs resumes from the end of the commercial break. Finally decided to turn off the feature.

I doubt this feature will ever work as planned.

Tried it for the first time, first show was the news, didn’t skip a single commercial. Apple TV.

Did the recording show one of these error messages?

Nope. No message, just didn’t skip the commercials.

In that case, and you were viewing the recording on a streaming TV device, that recording likely wasn’t processed.

All processed recordings on the main TV-based apps should have one of those messages.

All processed recordings regardless of the platform should show the yellow or grey sections in the timeline where commercials are marked:

Well, then the question becomes, why didn’t it record with skipping?

Once enabled in your Tablo’s settings screen, most compatible Tablo apps (Roku, Amazon Fire TV, Android TV, Apple TV) will display commercial skip success or failure messages next to completed recordings

There are three possibilities:

  1. The recording wasn’t completed when Automatic Commercial Skip was enabled (it doesn’t sound like that was the case, however…)
  2. The recording had broadcast errors preventing the creation of FFWD previews required for Automatic Commercial Skip processing
  3. Since it was a news program and those were NOT eligible the last time you tried the feature, the eligible list on your Tablo wasn’t yet updated to allow the processing of the recording… See the Jimmy Kimmel example above
1 Like

Yes, but the question is- why?