TabloRipper MCEBuddy Metadata

I was trying to set up an output location in MCEBuddy using the custom file renaming. I tried their example for setting up the file structure: [TVShows%showname%\Season %season%%showname% - S%season%##E%episode%## - %episodename% - %airyear%%airmonth%%airday% ]. I’m using TabloRipper and MCEBuddy 2.3.13. I just get %showname%.
Yet, TabloRipper seems to get everything in its title where it gets the showname, season, episode, air date and channel. It also gives a file structure of showname/season/showname - season episode airdate channel. I’m thinking the meta data isn’t coming through the ripper for the file it creates. I also tried checking metadata in the TabloRipper with the same results. I just started trying to do this. What can I do so MCEBuddy can use the metadata? Thanks, Allen

Hi Allen,
I suspect you are following the configuration sample in the TabloRipper Wiki (

I noticed some differences between your example and the same output to value in the wiki. Just a missing \ and # - though I don’t know if is the root cause.

Can you post screen shots of your TabloRipper and MCEBuddy configuration? It will let people see your configuration and hopefully help you more quickly.

1 Like

Here are my settings in TabloRipper to build the files:

I made a simple transfer to run the MCEBuddy:

Here are my settings for the output of MCEBuddy. I used the link you indicated with the rename of
%showname%\Season %season%##%showname% - S%season%##E%episode%## - %episodename%:
This is my simple file structure to drop the file into temp 1 to get the result in
The file I put into temp1 was:
The Burns and Allen Show (1950) - s04e08 - Gracie Thinks Harry Von Zell Is Broke.1300508 - ch31.2.mp4
Next is the result from this in temp2 folder:

As can be seen, only the %showname% was provided information from the file. The others, %season%## and %episode%## never got the information.
I even tried use a few other variables indicated in MCEBuddy, but they didn’t get information as well.
Thanks for your help, Allen

Hi Allen,

I’m wondering if you can update your version of MCEBuddy. I think the current version is 2.5.1.

The conversion task image is missing the “Expert Settings” button (between OK and Cancel) The expert settings screen has a couple of check boxes regarding metadata that I have selected in my configuration. Once you have updated, edit the conversion task and add a check to “Download Information” and “Add Information” in the expert settings screen.

I’m not near a computer right now to send you a screenshot - sorry.

I tried using the MCEBuddy 2.5.1 trial version before. After installation from their site, it right away prevented use and indicated license was expired. So I found an earlier version to use. I’ve tried this again with the same result. I’ve now asked about it from their support site and will wait to hear back from them.

I hope they can help you out. Here are screenshots of my configuration.

Conversion Task (top half of screen)

Conversion Task (bottom half of screen)

Expert Settings


1 Like

Thanks Bruce,
I received a reply back from MCEBuddy to download the trial version, 2.5.2, which I did, and it worked, but had a limited number of uses before it expired, which it also did. So I went ahead and donated for the licensed version. I set everything up like you showed and also made the Movie selection. So far even the Movies get transferred in the TV Shows part and not the Movies. Can you help me to make that part work as well?
Here’s my settings for Movies:

So it doesn’t seem to process the Movies part. What can I do? Also thanks for the quick help you have provided to get me this far.
I’ve set up TabloRipper just like yours except for the one checkbox for “Beta version opt-in”. What is that setting used for?

Hi Allen, This happened to me last week (around the same time you posted). I had to rebuild my setup a while ago and just set-up the Movies task last week. I also upgraded to 2.51. I don’t know which change caused the issue but here is how I fixed it.

If you notice, I set up two Monitor Locations: One for movies. One for TV.


Then in the conversion task, I select the location each task should grab files from (Movies from Movies directory and TV from TV Directory). With this, I think the Show type is pretty meaningless.

That should look after it for you.


The beta version opt-in doesn’t do anything anymore. Sadly for the community, @CycleJ isn’t developing TabloRipper anymore. When he was this let us know when a new beta testing version was available

Yes, that worked. When I first set up the monitor for the Movie folder, I selected Movies in the Show type so it didn’t work. But putting the Show type back to Shows/others did.
Now I think I’m on my way to doing this. I have a lot of recordings for the past three years that I want to store and eliminate commercials.
Thanks again for your help.