Tablo unavailable on Fire TV

I just received my Tablo and tried installing the app on my Fire TV and it says “unavailable.” I called Tech Support and they told me to reach out to Amazon. Ive tried installing on all 4 of my Fire TVs. I’ve had my Tablo for less than 24 hrs and I am already disappointed with it. I see that it only has a 2 star rating so that doesn’t sit well with me. I am willing to see if this can get resolved, but i have little hope that it will.

1 Like

@Brian4 Are you certain you downloaded the proper TabloTV app from the FireTV app store? There are two apps – one with a white background icon that works with “Legacy” Tablo devices; the other TabloTV app has a black icon background and is only for the Tablo 4th Gen device. I suggest you double check which app you installed. I have the black background TabloTV app running (Gen 4 device) just fine on a FireTV Cube and two Firestick 4k Max devices.

Goodluck. Cheers.

1 Like

Thank you for the response. I am trying to download the correct app. I don’t know what the issue is and tech support is non-responsive to my request.


I don’t know what your skill level is but it is VERY easy to download the Tablo app/apk online and then easily sideload it directly onto your Firestick. You can scan the downloaded apk with virustotal to verify its a clean non-malware file. I apologize if this seems like the “deep end” of the pool. For beginners there is a learning curve, but once learned this is a simple process where you get full control of your Firesticks. Just a thought.

e.g. ---- >

Good morning, I have a fire TV, a Panasonic Smart TV and a Samsung TV plus. I was told by representative that it would work on all three TVs. I will fourth-generation white tablo and when I tried to use it it tells me I have a weak signal. I downloaded the white on my fire TV and televisions are working proper. I attempted to reinstall on the fire TV and gave me was the black box please help.

Thank you,


aren’t working properly. disconnected and using just antenna

What gives? Just hooked it up and voila, it doesn’t work.

Brian, did you get a solution?

So it appears only certain fire TV devices are compatible with the app. What gives @TabloTV ?

There is a different app for the 4th gen Tablo (the white one) vs the legacy Tablo units. Make sure you are trying to install the correct app (the app with the blue background icon is the one you need for the 4th gen Tablo).

My solution was to return the Tablo to Amazon. After dealing with their Tech Support who told me to reach out to Amazon for a solution and then the lack of a response for my online submittal, it isn’t worth my time. The app only has a 2 star rating. This is probably part of that reason. Good luck!

Hi there @brian11b and @Randy_Lloyd,

Sorry you’re running into this. It’s possible that your devices may be too old to be compatible, as we can only support back to certain generations of Fire TVs.

Are you on 1st or 2nd Gen Fire TV Sticks? If you’re not, which ones are you using that you see this issue on?

As I’ve mentioned a number of times the gen 2 fire tv stick blows(crashes) after the app loaded and you try to d-pad off the home menu.

So I thought I would try it again. It was still installed on the gen 2 fire stick but when I tried to run it the app was removed.


I just got my new 4th Gen Tablo, and I went to install the app on my Fire TV Stick, and I can install the one for up to 3rd gen devices, but the one for 4th gen devices shows “unavailable”

is that normal? Is there a new release to be expected soon?


I haven’t seen anyone else report this very rude behavior. I have both the old and new Tablo applications installed on my Firestick devices which are 3rd and 4th generation devices. My understanding, which is very feeble, is that the Amazon firestick app store shows “unavailable” when the Firestick on which you are is not compatible with the app. Is your Firestick an old one or out of memory? I don’t believe there is any restriction on the generation of Firestick, however.

I assume you have restarted the Firestick just for kicks.

Some one reported on the 10th the app wasn’t available for a fire tv. Something probably is messed up with the amazon app store. Of course some older fire tv products are too old and don’t work. But that didn’t stop me from installing the app.

Some people seem to think the ceo of nuyvvo is calling jeff bezos on his yacht demanding he fix it immediately.

yes, I have a 2nd Gen Fire TV stick. I ordered a new Fire TV stick today just to rule that out.

I’ll let you know how it goes. Looking forward to canceling cable :smiley:

Gen 2 fire tv sticks don’t work. But it use to be you could install the app. Maybe tablo has started to lock out devices that don’t work.

prices now are as good as during black friday deals.

You need newer updated devices for the updated hardware and specs for some of these devices. I know another brand DVR needs a specific sound feature that is only found in certain newer devices.

Also check what country you are signed in on the FireTV for the heck of it, as not all apps are available everywhere.

Is there a way to tell which version Fire TV you have? Roku’s have a model number both on the box it comes in, and in the Settings/System/About screen. Is there a way to tell on a Fire TV device?