Tablo Tools - Bulk Export/Delete on Win/Mac/Linux

If I release a new version, I will certainly keep these requests in mind.

One more request… Please add partially watched to the “watched” filter. I’m not sure how readily available this information is but I know you can determine it from comparing the length of the recording to the playback position. Great Tool by the way, I use it quite often.

1 Like

Compatibility with Mac osx 12? M1 chip?

I should be able to build that, but have not yet tried. I’m supposed to get an update out, so if I get it built I’ll let you know so you can try it out.

I’m Using the WIN10 version and the “skip export” if file exists feature is not working. It just overwrites no matter what the setting is. Am I doing something wrong here? I’m expecting the app to not export the show if a file with the same name exists in the target directory. The color coding on the export page seems correct but the behavior is not aligned with it. Any help with this would be appreciated.

Not sure if I’d had it set to skip, bit I know increment and add ID has worked on a non-Windows system. Just tossing out some considerations. Maybe special characters in the filename and Windows filesystems not making a 1:1 comparisons? Just because it looks the same human readable, doesn’t mean underneath it’s the same to the system.

Storage on a local device? network shares have character coding or page codes or technical stuff.

Have you tried other options to see if this is the only one not working? How do you confirm a new file is created? Just the “color coding”?

The latest beta should have full M1 support (probably TabloTools-0.3.0-beta.4-arm64.dmg in that list?) and should be appropriately signed so there are no warning when installing.

I don’t have a way to test a M1, so if you have a chance, I’d love it know if it works.

The “partially watched” filter is included in today’s latest beta!

1 Like

I mentioned this over in the github issue, but for anyone here, this was an actual bug and was fixed as of the 0.3.0 beta.4.

As of today’s 0.3.0-beta.4 release, both Windows and Mac distibutions are signed.

Because I went with the less expensive option for code signing on Windows, some of the warnings will exist until a lot of people install the app. (So install it everywhere you are - it doesn’t need to run, just have people agree that it’s safe to install)

@jesse - I just downloaded this on one PC and it looks great - I love the partially watched capability! I can probably load it on a couple more PCs to get the installed count up. Thanks for all your efforts, it is much appreciated.

1 Like

Release v0.3.0 is now out. It is mostly a more reliable version of v0.2.4 with bugfixes and a few small additions.

The biggest additions are Code Signed Windows and Mac installers, plus new M1/M2 builds.

Will it install over version 2.4 or does 2.4 need to be uninstalled first? Also I am guessing that Setup-0.3.0.exe is the correct version for Windows 10? Thanks much!

It will install over 0.2.4, though will keep any settings. And yes, the .exe version should be the best option on any Windows 10/11. I’m not certain if it will run on previous versions of Windows.

1 Like

I’m having issues exporting files. It seems to be because it throws in a “/” which doesn’t play nice with Windows and I can’t get it to do anything without it. I’m using Windows 11.

Its been a while since I’ve used the program, so not sure if there was a trick to get it to work.

1 Like

Wild guess - edit [click on the pencil in the square] the naming template or create a new one [click on the plus] with the characters you want.

It’s a multi platform or not platform specific, and been noted it needs to have a default template. So until the user adds or edits one, it comes with one. Since it’s a one OS fit’s all…

This was caused by a couple of issues, all of which should be resolved in the just released v0.3.2.

Thanks for the quick action and response!
Still issues with setting the folder path in Windows, but I am able to export the files.
The example below is creating a new folder at C:\D\Videos\Movies\TabloRecordingsEraser - 1996.mp4
Not exactly what I thought it would do, (should be D:\Videos\Movies…) but it’s something. I didn’t try the Export button with this in v3.1 because the path looked so wrong (so not sure if it would have worked in that version).
I think this is a great tool, but not something I use often. Doing some digital housekeeping and I thought I would use the latest version while doing that.

The update works for me too, was able to download with no issues. A couple of minor bugs.

(1) When browsing TV shows, if I go into a show and play an episode when I click back it goes back to the top of the TV shows list, not where I left off. Probably the same for Movies, etc.

(2) In a list of TV episodes, play an episode then stop it. The play button disappears.

Great application @jesse !

1 Like

Oof. Did you manually enter the file name while exporting? Under Settings->General->Export Paths, is Movies set to D:\Video\Movies\TabloRecordings or similar? Are you using a custom template (if so post it, please)?

I played around with the templates and the file name editor - there’s definitely a lot of room for improvement there on Windows. I could not, however, make something this awful show up…

And yes, I’m not surprised it ended up on C:\ and yes, this app should translate / to ’ \ ’ on Windows to avoid invalid path issues. Hopefully I’ll have this ironed out by the next time you check in.