Tablo stuck on retrieving

I second the notion to use 1080p 8 Mbps recording to get the best resolution possible given this problem. However, don’t fool yourself that 8 Mbps is “just as good” as the 10 Mbps version. Text crawls on screen will be “herky-jerky” and sports simply won’t look as good on the 8 Mbps setting.

Tablo could do more. If I owned the Tablo company, I’d have one of every model of Roku TV and every streaming device with a Tablo App. I’d test every version of the Tablo App across all platforms before I released it. If the software update broke the App on some platforms, I wouldn’t release it.

Tablo should come with a disclaimer “May not work properly on Roku TVs”, because it doesn’t and there is nothing the customer can do to fix this fault in the product, other than annoying workarounds. It’s kind of like having a car that you can’t drive over 35 mph. “Hey, don’t complain - at least it runs!”

And then, two weeks after you released your comprehensively tested product, Roku sends out an update that breaks your shiny new app. What do you tell your customers then? Because I believe this is the situation Tablo finds themselves in. They often have to retrofit fixes to resolve issues introduced by Roku (or other client platforms).

Will you also have one of every version of IOS, Android, Fire and whatnot? Any idea how expensive (both in hardware and human costs) that would be? It is my understanding Tablo has a decent cross-selection of equipment they test on - but you start doing the match of the possible combinations of settings, carriers, clients, reception levels, antennas, station glitches and you’ll soon realize that there is no possible way Tablo can test (or even attempt to test) everything.

Good points, Bardel. Perhaps there are just too many platforms to thoroughly test. My main complaint at this point is that the customers have provided the testing and feedback and Tablo still can’t fix it. These forums and Tablo customer support (initially) kept insisting that there must be a problem with the local customer setup/equipment. (“It’s your antenna, it’s your wifi, maybe it’s a fault in your tablo unit”). That was just not the case. Someone pushed an update around Oct. 21, 2017 that broke important functionality for Tablo users on Roku TVs. Tablo needs to fix it.

Thanks for the input,

Was the update push by Tablo to your Tablo unit or the Tablo app on your Roku TV?

Or was it Roku who pushed an update to the firmware on your Roku TV?

If it’s Roku and the firmware, it is not Tablo’s fault, but it will be fixed eventually. It is not their fault Roku likes to f*** everything up once a year.

Sure sounds like the Roku 8.0 OS feature. Roku wanted to finish the 8.0 update by the end of the year.

During this festive time of year, I got my update Dec. 16th. I’ve had the problem ever since. It also seems to affect SlingTV. If you are in a rush to clear the issue: Sometime you can back all the way out of the tablo app(disconnect) and reenter to correct the situation. Sometime just playing another recording works. Sometimes playing a different OTT app clears the problem.

Ho ho ho, it don’t get better than this

I’m not really sure; everything else works except Tablo. And, Tablo/Roku works fine on all of my mobile devices and Roku streaming devices, just not Roku TVs. I wish I knew how to see a log of what updated and when and I could precisely tell what it was. However, I still don’t understand why it can’t be fixed. A station broadcasting at 480i or 1080p gets recorded at 1080/720fps 10 mbps and streams just fine. But, a station broadcasting at 720p recorded at 1080/720fps won’t stream on any Roku TVs. This is a very specific problem that Tablo should be all over, and yet the response is a “we dunno” shoulder shrug.

“It will be fixed eventually.” Well, it’s two months and counting that it’s broken. My guide renewal is coming up. Tablo better hurry.

What firmware version are you running on your Tablo, mate? I’ve got the 2.2.16 which came out in July I think, and there hasn’t been another update since. So the October update must be from Roku which bodged up your Roku tv. This is typical of Roku, every second update breaks things that were working well.

By the by, I don’t understand all your numbers mate. Hdtv numbers confuse me on the best days, but one thing I know with certainty is that only 720p channels have 60 fps.

Thanks for the reply, John. I too am showing 2.2.16 as the latest Tablo firmware. I think the problem arose from a Tablo App update for Roku, not the Tablo firmware itself.

Yeah I have the same issue on my TCL Roku TV. It has since updated to Roku OS 8.0, and my Tablo firmware is: 2.2.17, support pushed it out to me to see if it would help with this issue. It is a bummer to have to lower the resolution in order to be able to watch certain channels/recordings on my Roku TV, when on all other devices, (Shield TV, iPhone) work perfectly. As I remember it, it was a Tablo App update that caused this, though the Roku TV updates automatically, so I can’t say if there was a Roku update as well or not, I just remember updating the Tablo app, and immediately this started. I believe it was the Tablo app update in preparation for the Roku OS 8.0 update that has caused this?

I can’t explain how I know (I have an agreement), but your assumptions are misguided. It was indeed a Roku update that broke the compatibility, as is evident by the fact that it came out when the 8.0 update hit most users. It is up to Roku to fix this, not Tablo. It is roku’s OS that broke it, and Tablo has their hands tied until roku fixes it, from what I can tell. I have personally reported the issue to Roku, while we all wait on them to fix it. They are aware of it, so hopefully it’s on their list. A big give away that it isn’t a Tablo issue is that it works fine on all your other devices, even other Roku players. Again, I can’t say exactly how I know what I know, but please continue trying to help, and stop blaming Tablo for something that A) isn’t their fault and B) they can’t really fix. We need to pressure Roku to fix what they broke instead. Send some emails, perhaps. I’m still working on it, on my end as well, because I’m just as annoyed as you all are.

Another thing I can say is that this is a PLAYBACK problem, not a recording problem, which is easily shown because those same recordings from the problem channels work on your other Tablo devices. That means the recordings are fine, but the playback on the TV is broken. I will also say that I’ve submitted my own error logs to both Tablo and Roku to check the problem out.

I would think it is in tablo’s best interest to work with roku to get this issue resolved, regardless of who is responsible for creating this bug. I am sure they have more influence that you or I.

That assumes they aren’t ALREADY working with Roku. Why assume that when as you stated it would be in Tablo’s best interest to do exactly that. Although they may have a slightly ‘louder’ voice then us individually when you consider the thousands of apps available on Roku it’s probably not as much louder as you would think.

I think most of us based on current information and issues that have been encountered in the past feel like the ball is in Roku’s court now which Tablo can’t really control.

I hope they are, that is why we are here to report the issue, so they can look into the cause and get it fixed. Honestly, I haven’t noticed much difference in resolution from 1080 - 10 Mbps to 1080 - 8 Mbps, though a younger man with better eye sight may, but this work-around is fine for me until it’s resolved.

I don’t agree with giving Tablo a pass on this one. Where is the updated Tablo settings that would let users set different recording resolutions on different channels? That would be a good workaround for this problem until Tablo can persuade Roku to fix it (assuming this is truly a Roku problem, which I’m still not 100% convinced of since Roku devices work just fine with Tablo - just not Roku TVs.) Tablo support should have a much larger presence in this community and on their web page detailing the steps they are taking with Roku to get this resolved.

If my cable or satellite box didn’t work with my TV, I wouldn’t be on the phone with the TV manufacturer telling them they needed to fix their TV software. Rather, I’d fire the cable or satellite company for not providing hardware compatible with the standard technology of the day. Customers have already thoroughly documented, described, and reported the issue to Tablo. Tablo needs to do 100% of the work with Roku to get this fixed!

I don’t think most of us would disagree with you, we just know how seriously Tablo is and has been taking the situation but if the reality is it’s something Roku broke in their lastest update there is obviously a limit to how much else Tablo can do to fix the root issue.

1 Like

Thanks for your thoughts Nilex. I appreciate the active support community here. Bugs or no bugs, I still absolutely love the Tablo concept. I just hope that the execution of the software/hardware improves so that OTA streaming/recording can really give the cable and satellite companies some serious competition!

Tablo just released an update today that will start rolling out (2.2.18) that says it has a workaround for this issue. Hopefully it helps. :slight_smile:

My comment from last night probably makes more sense now. :slight_smile:

They have indeed been taking it very seriously and the workaround introduced in the 2.2.18 firmware update seems to have addressed most of the issues we were encountering until Roku is able to provide a more permanent solution.

1 Like

So I’m still running 2.2.16, the new .18 hasn’t been made available to me.

I’ve had this problem off and on since I’ve had Tablo. My recording is the default 720p/5 megabit. I’ve had it happen on my Roku Premier+ on 8.0.1 but it’s happened off and on on my Roku 3 as well in the past too.

Interesting when this happens it’s like the entire tuner/streamer hangs. Rebooting the Roku doesn’t help. Rebooting the Tablo does help. After browsing this thread I’ve seen people with multiple devices say other platforms non-Roku are fine. What’s interesting is after this happened tonight on the Roku. I ran the iOS app to start the show I was watching there and it works. I resumed it on the Roku and it was fine.

It will be interesting to see if 2.2.18 fixes this. I really wish it was available. Those new recording retention features I’ve been wanting since before I bought my Tablo!