Tablo stuck on retrieving

One channel will not play on my roku TV tablo app, either live or from recorded shows. It goes quickly to retrieving but the show doesn’t play, it just stays on the retrieving bar. All other channels work fine. If I wait long enough, it might eventually start playing but then the audio and picture are way out of sync.

Thanks for any advice,

Sounds like it might be a signal quality issue for that channel.

Thanks for the response. The strange thing is that this very channel streams just fine on all my other IOS and portable roku devices. However, it doesn’t stream properly on either of my Roku TVs. I think that Tablo has pushed an app update that may be struggling with the Roku TV platform.

Ah, okay… then 2 possibilities ar 1) a network issue, or 2) your Roku TV … is the TV on wi-fi? Can you test it by moving it closer to your router to see if a stronger signal fixes it? Can you connect to Ethernet?

Very interesting that the Roku TV is the only unit having issues - we haven’t made any changes specific to those devices.

As @lkahhan noted - is Ethernet to the TV possible, as a test?

I still have this problem. Definitely not an antenna signal issue. Also there is no need to try Ethernet because all 30 to 40 other channels stream just fine to the Roku TVs. There are now two channels that will not play on either of my Insignia Roku TVs, but these channels play just fine on all other Roku and IOS devices. So, I stand by my previous claim that some Roku Tablo App software change during the month of October created issues for streaming with certain broadcasts. These problems only show up with resolution HD 1080 - 10 Mbps, 720@60fps. No other resolutions cause the problem for the Insignia TVs, and ONLY these two channels cause the problem for the Insignia TVs. All other channels play just fine at 1080/10/720@60fps on the two Insignias. And, I reiterate, the two troublesome channels play PERFECTLY on ALL other Roku devices and IOS devices. This seems to isolate the issue to Tablo App compatibility with Insignia Roku TVs.

I am having the same problem. One station stops on retrieving on one TV. It is fine on other TV’s and devices – and the station has a strong signal. That TV is WiFi with no Ethernet option – however, I do not believe that could be the problem considering I get all the other channels, as well as streaming services, with no issue. A bit frustrating.

Thanks for the post. Are you having trouble with a Roku TV? What brand?


The problem is only on my TCL Roku TV 5107X running software 7.7.0 (8 apparently hasn’t pushed for this model yet)

Just to confirm what you’re seeing: does the channel never play on this TV? Or does it play with A/V out of sync? Do you get any kind of error messages?

Ok, thanks, King. My problem remains only with my two Insignia Roku TVs. I’ve still had no trouble streaming to any portable Roku devices or with any IOS tablets/phones. Tablo techs/engineers are stumped, but there is clearly an issue with certain Roku TV models and this issue only appeared in October of this year for me. (I had no problems at all previously.)

TabloSupport, for me, sometimes the channel will eventually play, but always with the A/V out of sync. Sometimes, it never plays at all, just “retrieving”. But, it never plays correctly now on these two channels on my two Insignia Roku TVs.


Mine looks like it is loading that one channel and goes to max while “retrieving” – but then stops, not showing the broadcast

I just noticed this topic was the same as I’m having with my Roku TV. Only the ABC channel indicates it is loading but stops before it brings anything up. Also anything recorded from that channel will not load either. This seems to have happened also back in October. It gets all the other channels fine.

My 3 other Roku devices attached to tvs work for this channel. Could it be an update that occurred with the Roku TV on Oct 22 (that’s what mine shows)? Any more ideas of what could be done for this? Maybe a new topic that indicates Roku TV problems with one channel might help see if others are having the problem as well.

asauer and King, do you only experience the issue when recording at 1080 - 10 mbps, 720@60fps. I am ok at any of the other resolutions, but it always fails to work for my local ABC and FOX affiliates on that highest setting. My problem definitely started in late October. I recorded the World Series on Fox on Oct 24 and then tried to watch the game the next day. I couldn’t get it to play on either of the Insignia Roku TVs but it worked just fine on the other devices. A few days later I realized that ABC was having that problem as well. I notice that my local FOX and ABC channels broadcast on a max of 720p, but that was never an issue until late Oct. of this year, and even now I record at 10 mbps, 720@60fps and stream this just fine on all of my portable Rokus and my IOS devices.

I really hate that this is happening. I was about to settle in with Tablo for the long haul and I had been telling all of my friends and family how wonderful cutting the cord and going to Tablo has been. Now, I have to warn them that Tablo may not work if they have a Roku TV. I’m having to look into YouTubeTV and other options because I won’t accept a lower resolution/poorer quality picture than 1080/720fps when it used to work just fine. I really, really hate to do that since I love the Tablo concept. But, it has to work!


I changed the Tablo resolution to HD 720 - 5 Mbps which allows the ABC channel to now load from my Roku TV (it was 1080 before). Thanks for pointing to this to make it work again.

Tablo support why is this just recently happening? I hadn’t had this problem for over a year from when I first bought my Roku TV until last October.

WiFi issues? Some things don’t stay constant. My best guess.

Here was the information I received from Tablo Support on 11/15/17:

"Since we started investigating this issue, we believe we’ve managed to find the root cause of the issue.
The two channels you’re having issues with (21.1 and 13.1) are the only channels broadcasted at 720p in your area.
Because these channels are broadcasted in 720, and you have the 10Mbps recording quality enabled, the Tablo is transcoding the video for these channels to 60FPS. This appears to be triggering a player failure in the Roku/Insignia branded televisions exhibiting the issue.
Unfortunately, this lands as a hardware of firmware failure on the television’s end, and we can’t pinpoint exactly where it’s failing. We’ve passed along this bug report to our contacts at Roku.
In terms of how to avoid the issue in the future, we recommend changing your Tablo’s recording quality to 8Mbps to avoid triggering the issue on the Roku TV."

So, the current status is that Tablo simply doesn’t work on some Roku TV hardware. Question for Tablo: Would it be possible to allow recording quality to be set at the highest level but have the Tablo cap the recording quality at the detected broadcast resolution? Or, to set different resolutions on different channels. Either of these options are better than accepting a lower resolution on ALL channels, or living with playback failures on some TVs.


I am really annoyed by this – and it would be a deal killer, except for the part I already paid a LOT for Tablo. Can’t recommend it with this problem though. I’m already unhappy it doesn’t do surround sound – and now I’m supposed to reduce to 720 because Tablo has a bug they blame on the TV hardware. Ridiculous.

You don’t have to reduce to 720p recording quality, choose the 1080p 8 Mbps recording quality and the 720p channels won’t be recorded in 60 fps. The 60 fps is only recorded when using the 1080p 10 Mbps setting. The issue described in this thread was for 720p 60 fps recordings.

Edumacate yourself - see link below.