Tablo Roku App (4th Gen) Update (v. 0.8.500)

Trying to stop recording a particular show, as in “unschedule” it, like don’t record the show anymore. Went into “Scheduled” under “Library”, and the only thing I saw for that show was setting “episodes to record” to “none”. So I did that, and the show stayed in the “Scheduled” area instead of disappearing after a minute or so. I did re-check, and at that point “episodes to record” was still “none”. So I went over to “Live” and then back to “Scheduled” in the hope that the show would have been removed from the “Scheduled” list when that list was re-rendered. Nope, it was still there, and the “episodes to record” had been changed from “none” to “new episodes”. Bam!

Seems like a bug to me, but what do I know? By the way, the Tablo firmware is 2.2.50, and the Tablo app version is 0.8.500.

So how are you supposed to stop recording a show? Anybody have a method that works? Or is what I did supposed to have worked?

Sometimes a recording gets hung up here or there.

When you go into your scheduled tab and look at that show’s upcoming episodes, how many episodes do you see marked for recording? It’s possible one of them was either mid-record or that an individual episode was selected to record and sometimes the “none” doesn’t seem to stop them all. I don’t think you’re in either of these categories, but check out which future episodes are set to record and manually cancel them. See what happens after that.

One thing I’ve done in the past is set a show to record “all” then waited a few seconds and selected “none” to try to clear up the issue when I couldn’t see it.


Once I set the “episodes to record” to none, it showed no episodes scheduled to record. The show definitely wasn’t being recorded or played.

I have no other explanation for why I can’t delete shows from being scheduled other than it being a bug. I have to admit I haven’t tried any other shows, just this one that I’m done with. I’ll try scheduling a show and seeing if I can get rid of it. I suppose that this particular show’s data might be corrupt in some way that doesn’t allow it to be unscheduled.

This show is finally gone. Not sure when it went, but after I updated both of my Apple TV’s to 17.4, the show was finally gone. Not sure what the death knell was for it, since it was fine overnight after I unscheduled it with the Roku. Don’t think that the Apple TV upgrade was cause and effect, but don’t know what suddenly convinced the Tablo to unschedule the show.

Could be a one-off, time will tell.

Wonder if it was an issue with the new FW and it needed some time to refresh itself.

I was going to ask if this is something that the overnight cleanup would take care of, but since it’s hard to say when that happens… (and if I have the timing of your post right, you might have been dealing with it after the overnight refresh.)

Glad it’s up and running, though.

1 Like

Don’t know when the overnight cleanup is, I was using the Roku last night around midnight. However, with the Legacy Tablo, the unscheduled show icon disappeared when you unscheduled it, they didn’t sit around until the next day…Haven’t unscheduled very many shows on the Gen 4 Tablo, mostly been scheduling there :-). I would expect the show icon to disappear once it’s unscheduled…not instantaneously, but within a few minutes at the most.

Yeah, I’m glad it finally resolved itself, too.

For legacy the overnight maintenance ran when the guide update occurred. But over night maintenance is to cleanup any inconsistencies between the meta data and files on the tablo unit. not inconsistencies on the app device. On a gen 4 who knows.

I can confirm this has happened to us many times when we attempt to time shift a something that is currently recording. Just Monday, my wife started to watch the Bachelor 30 minutes into recording the 120 minute show. Start from the LIbrary, select the recording, its starts at the beginning, but you will see ‘LIVE’ at the bottom of the screen. It will not allow you to fast fwd at all. You are stuck at the current point of the recording with no opportunity to pause, fast fwd or rewind. Time shifting a live recording is a standard feature of a DVR. It’s happening for a lot of us. I was able to hook up the TiVo Stream to the same TV. I accessed the same recording via the Library and was then able to time shift the live recording. I’m not sure I’ve seen this same bug on any platform other than the ROKU.

Yes, the other two streaming platforms that I have, the Chromecast and the Fire Stick, haven’t seen this problem on either of them. And I’m not sure that I saw it before the latest Roku release…if I did, it was occasional and I was able to clear it by rebooting the Roku. Now when it happens all I can do is switch streaming platforms.

Glad it’s gone here at the moment. Used the Roku for the evening news yesterday night, but I have a strong feeling that it’ll be back. And yes, this is basic DVR functionality, without it I’ll just pay extra for Youtube TV instead of Sling and be happy :-).

I’ve also noticed a problem with this forum. About half the time when I reply to another poster, that poster’s nom de plume is left off my reply. The only reliable way to indicate which posting that you’re replying to is to quote that posting. Have to remember that :-).

Any estimate on fixing the Roku CC issue? I know there is the pause live tv for 30 secs to prevent crash work around. But that is not an acceptable permanent solution. I need the CC for Deaf and HH users.

I’m using a 2 channel Gen4 Tablo running the latest firmware with a 4 GB external hard drive attached. Roku Ultra 4670X with 12.5.5 build 4174.46 firmware.

Last I heard they were at the mercy of Roku.

This is correct.

Hopefully Roku will include a fix in their next firmware update, but we’ll have to wait and see.

1 Like

Are you really expecting Roku to fix this in their current 12.5.5 OS base or in Roku OS 13. The thought of moving to a new major release is scary enough.

It likely won’t be included until the next major release.