Tablo Ripper - Automatically download new recordings

If memory serves, that happens when TabloRipper opens without network access to your Tablo.

The PC Tablo app (browser not Win 10 app) is working fine, so it has a connection to the network. I’ve rebooted and re-installed and am still getting the error. It worked fine for years and suddenly I get this error. I’m hoping someone might be able to diagnose the problem. I made no major changes to my computer, either.

Here are 3 screen shots. I tried to manually fill in the fields and I am no longer getting the error, but no recordings are loading, either…

Try doing just by IP if you haven’t already.

I tried that first and same result. Really confounding me… :thinking:

You might try looking at any events produced at the time in the Event Viewer.
There’s another event viewer inside Computer Management. This is likely to be kind of cryptic but may lead somewhere useful.

For me, windows 10, these are here:
C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Administrative Tools\Event Viewer

C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Administrative Tools\Computer Management

Also, these are under Windows Administrative Tools in the Start menu.

I honestly would have no idea what to be looking for. When I put in just the IP address, I get the following popup without the error, but no programs load…

I also uninstalled 2.4.3 and installed 2.4.2 and am getting the exact same error. I’ve unplugged the Tablo and tried everything. Crazy that it was working fine one day and then won’t the next.

FML… It was my damn Norton VPN that was causing the problem! I totally forgot I had turned it on a few days ago. It normally defaults to “OFF” when I reboot my computer.

Thanks for all the input!!

1 Like

I have a Tablo HDMI. From what I read, it should be storing recordings in the raw MPEG2 as broadcast. I tested using Tablo Ripper, and it seems to have converted it to MPEG4. It also seems rather fuzzy compared to the original, and was only in stereo. Is there a way to have it either copy the raw file, or use higher bitrates, and allow multi-channel?

You might want to follow this thread and/or contact @TooleManTV.

Tablo Ripper runs a script every time you bring files from its USB drive to your computer. The script uses FFMPEG. The generic script that came with my downloaded copies the MPEG2 video to an MP4 container. It also converts the audio (AC3 broadcast) to AAC.

The script is called Settings.xml. In windows it is stored in the ProgramData\TabloRipper folder. It can be modified to change the encoding of the files it creates on your computer. Somebody must have modified the script on your machine to convert the video to an MPEG4 format, probably at a low bitrate.

I never modified anything. It is just a stock install.

I love Tablo Ripper. My PC’s hard drive crashed that I had Tablo Ripper installed on. I lost the program. I have a legacy Tablo and would love to be able to reinstall Tablo Ripper. Can I get a link to down load the program? Thanks

Looks like you’re SOL - as Tablo Ripper…

has been deprecated
As a result, I’ll no longer provide the download link here

The first post was lasted edited Sept 7 2023 with that note.

I saved a version in 2017, not sure if that was after the developer stopped making updates or not.


1 Like

Wow! I’m shocked and appalled that CycleJ would just delete the public repo of his excellent tool like that. Why didn’t he just mark it as an archived repo and add a notice to the top of the Wiki pages noting that all development and support had ended?

Fortunately, has preserved the last version (v2.43): Downloads & Release Notes · cyclej/TabloRipper Wiki · GitHub

It’s strange though that the 32bit variant is different by a few bytes than what I had downloaded before. So anyway, get the 64bit if you can.


That’s a bit strong - “shocked and appalled”

Tablo Ripper’s age has been discussed, developed in the Windows 7 era, now EOL. With no future development 8yrs old is severely outdated in Windows, actually any software running on a networked system.

It’s fortunate it runs, knowing there’s likely some libraries that are depreciated with new, security patched ones out there

Wow! I’m sad and disappointed @CycleJ just deleted everything. Yet grateful he continued providing support for the pas 8 years!! a big



Wow! I didn’t realize it’s been 8 years for Tablo Ripper. I remember the early days when @CycleJ had just introduced it to the community, and he was still adding features and fixing issues. I was one of the early users, and offered feedback and suggestions, and greatly appreciated the effort that it took to bring this great piece of software to the Tablo community.

Sorry to see it go, but I understand that continued support of Tablo Ripper can take a fair amount of time. A big THANK YOU to @CycleJ for all your efforts in having provided us with a great tool to use for all those years!


Thank you Joltarin for the link. Mt Tablo Ripper is up and running again.


Has anyone gotten Tablo Ripper to work with the new Tablo 4 ?

I tested it and can’t see the Tablo 4 on my network. I use Ripper with my older Tablo box fine on same network.