Tablo Ripper - Automatically download new recordings

Pretty much the same advice for background issues:

Since you have ripped some shows manually, I suggest deleting the log file, not doing anything manually, then allowing some time for the background process to kick in. That way it’ll be easier to see what’s going on.

Alternatively, open the program, wait a while, then scroll all the way to the bottom of the log file. That’ll get you the most recent activity.

@CycleJ deleted the log file…now waiting as you suggest. I will look at the log file tomorrow and send you what is there. There are 12 possible items to rip.

Happy holidays !!

Looks like TabloRipper doesn’t think anything is “new”. There are several things that can affect that, usually it’s the “filters” you’ve entered.

Try checking the “New?” box on the main screen - do any recordings show up in the list?

I’ll DM you with my email address for logs.

It’d help if you included screen shots for the “Ripping” and “Configuration” tabs.

@CycleJ As discussed in our DM, reloading and clearing out old entries (logs, etc) solved the problem! Thanks for all you help - next time a migrate from an old to new computer, I will do a fresh install - its just better!

1 Like

I am successfully using Tablo Ripper with a Tablo Dual HDMI :+1: Works nicely, and solves 90% of my needs. Now I need some help with the remaining 10%. :hand_with_index_finger_and_thumb_crossed:

My goal is to copy the video AND audio without conversion. Out of the box, Settings.XML invokes FFMPEG to convert all the audio to AAC. This line of code in Settings.XML does it:

-codec copy -strict -2 -c:a aac -threads 0

I researched the FFMPEG settings and changed Settings.XML to this:

-codec copy -strict -2 -c:a copy -threads 0

When I run Tablo Ripper after changing the Settings, somehow the original Settings are restored. The audio is converted to AAC. I opened Settings.XML and discoverred that my changes are gone! The original code is back. What’s going on here?

Thanks in advance!

My first guess is that you need to stop the TabloRipper service, close the TabloRipper app, make your change, then restart everything.

Give that a try and let me know, ok?

Thanks for the quick response. Unfortunately, I tried everything you suggested with no difference in results. Even rebooted the PC.

I made the changes to Settings.XML, saved the file and closed the editor, then re-opened the file to be sure the changes were saved. They were there.

It looks like Settings.XML is being overwritten whenever Tablo Ripper runs. Is there a way to prevent that?

The Date Modified of Settings.XML is updated when Tablo Ripper is initiated. The code reverting back to the original with the aac conversion seems to happen when “Start” is clicked.

I used a brute-force method to keep my code change from being replaced. By making Settings.XML read-only, the “copy” statement was not overridden. The MP4 contains the original AC3 soundtrack. I consider that a workaround to use until we know what the process is here.

There was also a warning thrown by FFMPEG, “stream 1 frame size not set.” Not sure what that means, but the video plays fine.

When I get time to dig out the source code, I’ll take a look at why the program thinks it needs to restore that default value. But since I can’t make changes any longer, I won’t be able to fix it. Your solution works great unless you plan on trying to make configuration updates via the UI. And you’re obviously skilled enough not to need that option.

You could try looking up that FFMPEG error to see what it means, but since you’ve got it working, why bother?

Well done on your part!

Aw shucks, it weren’t nuthin’. :blush: Thanks.

I’m an old coder and a bit of a hacker at heart when it comes to things not working as advertised. The FAQ told me exactly what to do to with Settings.XML, and the FFMPEG reference was clear about what I needed to replace. But where the FAQ said, “Replace the old Settings file with your new one,” everything went south.

See the fourth or fifth topic in the TABLO Ripper FAQ

Let me know what you find in the program, please. I’ll bet it just overlays the settings with a copy from the “official repository.” Future releases could address this, since the behavior contradicts the FAQ.

1 Like

Never satisfied with a solution that doesn’t include understanding what caused the problem, I googled the error message “track 1: codec frame size is not set.” This thread on led me to a post on VideoHelp where the answer is given:

Use -acodec ac3 instead of -acodec copy it should solve your codec frame size is not set error

It works! :laughing:

I’ve updated the FAQ to reflect the current behavior.

1 Like

@CycleJ - I created a work around using TagLib.DLL and Powershell running a scheduled script. When I get some free time, I’ll post the code.

1 Like

I wrote a little .bat file to open the folder where ripped videos land. I typed the path into the Configuration tab Post Processing field. The field was cleared after I closed and re-opened Tablo Ripper. Is that by design?

Nope, but is your settings file still read only?

Yes. I never thought of that! I’ll unlock it and see what the code looks like, then go from there.

I typed in the path to the .cmd file and ripped three videos from Tablo to my PC. Each time a rip completed, the .cmd file was executed. I thought this only would happen once after all the rips finished. Not a big deal, but not tidy, either.

If a user wanted to post process the exported video, wouldn’t it kind of have to execute each iteration? Or after all have exported, once for each exported file?

Speculation, if you wanted something to happen after Tablo Ripper had successfully exited, run it via a script. If it puked along the way, you may not want it to happen, so you can avoid it as well.

That’s a good point. I need to get out of my box more.

1 Like